Z-Axis Motor Wiring

I am hoping someone can guide me in the right direction here. I bought this motor off amazon after dropping my sled and messing up my original Z axis motor. I figured by swapping, I could also try and gain some z-axis speed. So I went with 131:1 on the gear ration rather than the 270:1.

My issue now is, I wired it up as the connectors are not the same and my right motor is moving when the Z axis is moved. I know they share a port on the Audrino, just wondering if there’s something I can do to correct the issue. The only wiring difference from what I can tell is that the A and B channels are swapped on the two motors. I have tried swapping them back and forth, but it doesn’t affect the right motor turning.

Any help would be great!

1 Like

if you unplug the Z motor does the right motor move when you try to control the
Z? If so, you have a problem on the board

If it doesn’t move unless you plug in the right motor, then there is something
that you have crossed in your wiring.

if the A and B are swapped, the motor will thing it’s running the wrong

unfortunantly I don’t know the wiring on the stock motors offhand (I’m sure it’s
in the wiki somewhere)

by the way, this motor may end up being a better choice (due to it’s higher

The one concern with these motors is what is their current draw under normal
load? (no load .25A, stall, 6A the controller is rated at 2A)

1 Like

I’m not sure how you accomplished the wiring change, but if the z-axis motor is connected to the MP2 connector, the right motor should not run at the same time as the z motor :thinking:
If I were to make an attachment for the motor you linked, I would probably use one of these connecotrs for the board end:
this one if I didn’t have the crimp tool

or this one if i did.

One of those would plug into the board, and the signals on the connector are so:



Great work. Can you put this in the Wiki somewhere?

Thank you

1 Like

After more testing and observing, actually when I raise or lower the Z-axis through GC, both the positional motors are moving as well as the z axis. The odd thing is that when doing the “Test motors” in GC, all the motors test out great and when the Z axis comes on, it moves with neither of the positional motor moving as one would expect, but it still says Z-Axis fail in GC. I have tried swapping the AB with no affect either.

Also with no Z axis cable connected, both left and right motors move when you try to raise or lower the z axis in GC. I’m stumped lol

I’m pretty stumped too. That is very strange behavior!

What versions of GroundControl and Firmware are you using?
If not V1.03 on both, it would be a good idea to update them. The newest release of the firmware and GroundControl are always worth updating to.


I did just update to 1.03 and now when testing the motors, all motors including the z axis pass the test. The issue of all the motors moving at once is still happening though when I try to move the z axis with GC.

How did you attach the z motor to the board?

1 Like

I’m just using a terminal strip right now until I get everything sorted out.

1 Like

This is the thing that has me really stumped. Just to be totally clear, even with nothing plugged into the z-axis port both the left and right motors move?

If that’s the case I think one of two things is going on. Either the software is in some strange state and the left and right motors are moving as a result of trying to get to where they should be which would be weird but unrelated to the zaxis or the PCB is damaged from the new motor.

The fact it’s both the left AND right motor has me leaning away from the PCB being the issue. The fact that

This makes me think it’s a software thing too. Is it possible that the machine calibration is weird (like one of the calibration values is way off)? Do you see the crosshairs moving in Ground Control to show left or right movement when the motors are spinning while the z-axis is moving?

1 Like

Did all the motors move at once during the motor test?


The motors moved individually during the test. @bar, I would agree that it’s something software related though I wouldn’t rule out a PCB issue either. My question is how do I wipe everything and start from scratch on the Audrino as well as ground control? I know there is a .ini file, but I’m not sure where that is located. I have been searching for it but ini isn’t a friendly search term.

Yes, when raising or lowering the Z-axis in GC, the motors both move even when there is nothing plugged into the Z-axis.

The groundcontrol.ini file is in your home directory. It gets re-created if it’s not present when ground control starts up. You could hide it or rename it so if a new file works, we could compare it to the old one and learn.

1 Like

I like where you are going. Let’s unplug the z-axis from the board and then start fresh.

The buttons “Actions -> Advanced -> Erase EEPROM” will wipe the memory of settings stored on the Arduino

Edit: It’s actually called “Wipe EEPROM” like this:

1 Like

I wiped the EEPROM as well as changed the name on the GC.ini and started over, haven’t gone through the calibration or anything but again, during the motor test, each one moved independently and passed. When trying to raise the Z axis though, both left and right motors move while the Z axis does nothing.

:slightly_frowning_face: Darn

I think something is still strange with the software because I would expect that the machine demand that at least the chain lengths be recalibrated after wiping the EEPROM.

Can you post a screenshot of GC while this is happening like this:

1 Like

until you go through the calibration (or do the manual calibration to tell the
machine what it’s dimensions are), it cannot do anything sane with movement

1 Like

I was able to replicate something this locally by enabling Custom Velocity PID Values in the Advanced Settings page with some values I had from previous testing.
Can you confirm that neither the Custom Velocity PID Values nor the Custom Positional PID Values are ‘ON’?

1 Like