Maslow Home Maslow Community Garden Newsletter

Feedrate slowing unexpectedly

Twice recently, my machine has slowed down significantly below the specified feedrate during a cut. Sometimes it will speed back up to normal, travel and inch or two, then slow back down to snail’s pace. It’s only happened during 3D carving operations - 2D contours seem to be reliable. At first I thought I had accidentally enabled the Feed Optimization function in Fusion 360, but I went back and ruled that out. Looking over the G code of the most recent example, I can’t find any feed commands other than F15, but the sled is just barely creeping along. It still follows the toolpath fine, it just turns what should be a easy half hour operation into a 2.5 hour slogfest. Mysterious. Any ideas?

the Z axis is extremely slow, so if you are doing a Z move along with the XY
move the machine will slow to the limit of the Z move

the other possible problem is that it takes a significant amount of time to
process each line of g-code, so if you have lots of tiny movements, the machine
slows down a lot while processing each line.

David Lang

Much of this behavior was occurring on the XY plane (I should have said that), so I have a hard time blaming the Z axis.

Your second point, about the time it takes process each line of code, sounds much more like what I’m running up against. Is there anything to be done, either in GroundControl or in CAM, to minimize this, or am I just running up against a limitation of the machine?

in CAM, look at how it is doing curves, if it’s doing them with a ton of
extremely short moves, see if you have a config that reduces the accuracy of
this so that it does fewer, slightly larger moves

it’s not unusual to see CAM configs that try to be super precise and schedule a
lot of moves that are so small that the machine doesn’t actually do any of them
(say movements of < 1/1000 of an inch)

David Lang

I had a chance to look over the CAM, and it looks like you’re right - the machine was “data starving.” Even seemingly straight toolpaths were made up of many many points. What’s more, those clumps of superfluous points corresponded to the slowdowns I observed. By playing around with tolerance and smoothing settings, I’ve decreased the number of instructions by an order of magnitude. Hopefully that should take care of it. I’ll try running it tonight and update with my results.

3 Likes

what are you using for CAM?

Fusion 360

I ran the updated operation yesterday, and it looks like I can confirm that data starvation was the issue; increasing the tolerance and smoothing tolerance almost completely eliminated those intermittent slow downs. In retrospect, this issue is pretty easy to visualize in Fusion 360 (might be in other CAM too but I’m not familiar). When you simulate the toolpath, you make sure to enable “show points.” If a seemingly simple line has a gazillion points on it, you should probably revise something. Thanks @dlang for setting me on the right path!

1 Like