Firmware Upload not working

I’ve downloaded the latest firmware from Releases · BarbourSmith/FluidNC · GitHub and I’m trying to update the bin file. It lets me select the file, and I see the firmware update progress in the serial messages window, and it gets to 99%, then the thing reboots. But I’m not seeing the new UI for calibration, and when i check the System Status tab I see FW Version FluidNC v0.63 and not 0.64 as I would expect.

I then tried to upload the latest index.html.gz, in case that the UI was not part of the firmware. I’m using the FluidNC Local Filesystem tab. When I go to upload the gz file it says that there is insufficient space to do the upload.

Thanks for any help you can provide.

This one I can solve. Because we’re right at the limit you have to delete the old version before uploading the new one. I’ve worked on making it smaller so that won’t happen in the future.

This I haven’t seen before. Let me try it.

OK, I got the gz file to upload. And I now can see the new UI, but the FW version in FluidNC Status is still v0.63

1 Like

Can you give it a try with this version?

I just tested that to work for me so at least we can be starting from the same place.

OK! That firmware uploaded fine. I am seeing the same build number etc.

Now, I can get to the initial problem which was the support straps not moving. I am hoping the higher current rating will work for that!


1 Like