Fusion G-Code issues

Is anyone successfully using Fusion 360 to create G-Code for Maslow? If so what “machine” are you choosing to post to? When I run the simulation in Fusion everything looks good, but when I go to cut using the posted code it seems to be skipping lines. Tool path in Ground control shows the correct program, but I can watch it cut directly across the part for, what seems like, not reason.

The last few versions of GC and the Firmware have had some issues that sound like the ones your describing. there were some firmware memory issues that caused lines to be dropped a few weeks (1-2) ago. Remember, maslow is still on weekly software releases, so there’s not quite yet a long term stable release to point to use.

I would recommend building from source using the latest code, or waiting until Wed’s release.

good luck!

Try Generic Grbl. That has been working just fine for me. There are a few lines of code like the M codes that will be skipped, but otherwise it works well for me.

Oh and yes, there were some issues with arcs less than a week ago that I fixed which would cause the machine to cut straight lines instead of the arcs. You need at least .82 to solve this issue.

1 Like

I just tried defining toolpaths in Fusion just now, and something is mucked up with my Z-axis depths.

A rough sketch of your Setup would be useful here, if you have a moment to provide it?

Take a look at the unofficial Fusion page. While I don’t have a maslowCNC just yet, all the CAM paths have been fretted over and appear to do what they should.

1 Like

Try watching this too:

I don’t agree with everything, but it should get you started. Also if you hover over the options in Fusion, it often gives you a nice image and description.

If you are having z-axis issues. Pay attention to the heights page. I think I set everything to be .2 above Stock Top and Bottom is Stock Bottom. Not sure why all the default options are do different.

1 Like

Yes, that’s what I went through to get paths defined, and understand what they’re doing (and not doing), but I’ll give it another try. Something went wacky with my heights page - probably time to take a deep breath and start over :slight_smile:

It’s good to know that the generic Grbl post-processing generates correct code!

I’m running FW0.83 and a test build of GC0.83 - I’m pretty sure I also need a re-calibration for a variety of reasons. Lots on the todo list…

Going through this again, I see what I did wrong - this is not covered much in the video, so it is worth mentioning:

A few pointers for Fusion360 that may be obvious for anyone but me :slightly_smiling_face:

  • When you import a DXF, be sure you put it on the X-Y axis plane - it’s possible to fix, but this makes life easier
  • Extrude in a negative Z direction (you’re cutting INTO the wood)
  • When selecting contours to cut, I found that selecting the bottom (-Z side) contour produced sensible results

Another tip, that comes from another mistake by me - select your outline contours in the order you’d like them to be cut (think carefully about this), and then check the “Preserve Order” checkbox in the 2D Contour setup.

Also, Fusion360 is very quick to drop paths/contours if it decides they’re too close together. This can be circumvented by setting up new 2D Contour jobs for these specific profiles.