G-Code generation

I use QCAD to draw and EstlCam to post (create the G Code). I just built the Maslow and it ran the Maslow logo G-Code program just fine.

When I load one of my programs, Ground Control will load the drawing OK, but wont run (or simulate). I haven’t hooked up the Z axis yet, so that may be my problem. I have tried to delete the Z axis commands in my program but still no work.The bigger question is, is what format should I save the G Code in? There are many processor specific variants…
How do I troubleshoot a program that seems to load but not “run”?

1 Like

Can you post a copy of one of the problem files here? Are you able to use the on-screen arrows to move the sled around? That would prove that the serial connection and the firmware are proper. On a Maslow without the z-axis, and with the setting ‘z-0axis installed’ set ‘OFF’, you should be prompted for each z-axis change, and I believe use the yellow Pause/Resume’ button to continue.

1 Like

Here is a sample G-Code. I do have the Z axis off in the setup…Anchor1Gcode.nc (13.9 KB)

I can move the sled…I’ve cut the Maslow logo G-Code

The file looks OK, though it starts out with some z-axis moves that you’ll have to do when prompted. There are a few items that will be ignored (the Sxxxx spindle speed, for instance).

OK, I think I’ve found the issue.

Most pre-processor programs put some gcodes near the beginning of the program to set the units - mm would be G21, (inches would be G20) and choose the absolute coordinate mode G90 (rather than the relative mode G91).

I’m not sure whether the anchor is supposed to be tiny (metric) or huge (inches), but put a line near the top:

G21 G90


G20 G90

and things will start working for you!


Thanks! I’ll go out and give it a try. The anchor is huge (inches).


Blurfl-thanks for the help. The G20/G21 G90 cleared up some issues. I’ve also changed the processor the post creates the code for. I’m cutting now.


Good to hear - anchor’s aweigh!