Maslow with a mind of its own

Hey,
So my Maslow gets to about line 2374 of this code file and then its off to the races, it runs up about 4 inches then all the way across the board. Very strange. you guys have any ideas.

Guest Sign In.nc (420.6 KB)

That’s a nice looking sign, it doesn’t look like it should be troublesome. Here are a couple pieces of information that can help with he troubleshooting - Which versions of GC and firmware are you using? Which PC platform? Are you using 0,0 as the ‘Home’ location, or is the ‘Home’ location shifted?
The file looks pretty straightforward, pasting it into gcode simulator looks pretty clear, though there might be something missing in the second line of text? Line 2374 is the last step before lifting the Z and traversing across to another figure. Does 2374 complete? does the z-axis lift? Are there any on-screen messages at the time of failure?

3 Likes

Version 1.13 for both, I am running on a windows tablet but build the .nc file with makercam on a Mac. The z-axis does not lift and the router runs line straight across the board. I have redefined the home position but don’t know about 0,0.

Some older versions had trouble with G2 and G3 gcodes but your versions are good. Line 2375 raises the Z axis, and line 2376 moves across the workarea like this (pink):


Is that the track that got cut? There have bees several threads recently about z-axis kind of troubles with Ridgid routers.

No, definitely not moving toward that point, went up then like 3 ft to the right before I stopped it the first time.

Later I tried to rerun the same file but caught the router just as it started to go off schedule, then after I tried to goto the gcode line and the router would snake around the board and pop up the error about the maslow not responding as expected.

  1. When did your Maslow start misbehaving?
  2. Is your Maslow perfect at cutting other files made with same program?
  3. Besides updating Firmware and Ground Control to v1.13, have you changed anything else recently?
  4. Can you share some pictures of what the result is?
  5. Can you record a Timelapse of the maslow, and show sceenshot of what Ground Control says during failure?

This file was the first malfunction. Haven’t had time to try and narrow the search. Haven’t changed anything since the last cut but haven’t cut since then.

If it goes off schedule at the same point each time, then that’s good - a repeatable error is easier to troubleshoot :grinning_face_with_smiling_eyes:

This description has helped me zero in on the trouble in the .nc file. MakerCam has a way of creating arcs that require precision beyond what is available with the floating point software we use. There are cuts in the .nc file that are .02 inches long but have a radius of more than half a mile. I think we could approximate that with a straight line, yes? If you’d be willing to test a fix, download and install this version of firmware. It changes those problematic curves to short straight lines, and your file seems to run correctly through the problem spot.
I’ve opened PR#430 in the Firmware repository for this change. If you have a chance to try it, let me know what you find.

1 Like

This is a terrible picture I took of the damage, hard because the sled was in my way.

The first attempt on the left and the second, where I tried to start the Maslow at step 2374.

I’m sorry that the problem continues. I’ve made another change to the firmware branch that I linked to, available as a .zip here.
Thank you for your patience solving this.

Tried the most recent firmware and had the same issue so I tried to run a smaller code file to see if I could piece meal the project together and it had the same malfunction as the same location of the project. this is the smaller file. Guest Sign In.nc (85.5 KB)

Yes, the patch has not been merged with the most recent release yet. The patched version is here.

Unfortunately, the issue isn’t confined to one small part of the file. I’ve run the smaller file you provided using the patched version of the firmware with success, as I had with the large file as well.

I meant to say that I tried the most recent patched version you provided. With the same problem.

I looked back at the link I posted yesterday, and I find that it was wrong. Here is the patched version of firmware that I was trying to link to
Firmware-Fix_large_radius_G2-G3_as_in_PR_-430-3.zip (1.1 MB)
I’m sorry for my error, I hope you find this version helps.

two other questions,
First what determines what order MakerCam places the cuts, it seems like when doing letters for this sign it will do one part of all the r’s then all the a’s then the e’s, takes a long time with the sled running all over.

Next, this SVG file that I’m using will not allow 2 of the curves to be cut, this is in maker cam, I select the outside of the sign and pick profile operation but it doesn’t calculate, but when I try a follow path, is works.

I noticed what you’re describing in the smaller file you uploaded. MakerCam seems to be treating all the disconnected shapes as one path and cutting the first depth on all of them then going back to each one for the second depth.
I’m not a MakerCam expert, but I think that when calculating it treats all paths that are selected together. If you selected each ‘island’ separately and did the calculation for just that island then it would create a separate profile for that island, When cutting, it would finish up that cut before moving to the next. Each would have its own profile in the list when you go to export, and re-arranging that list would set what order they get cut (to optimize travel between them).

The red zigzag is the travels without cut.


With the bCNC editor you can move the so called blocks up or down for a more logical order.
Will save allot of travel time.

2 Likes

do you have a downloadable copy or a link to bCNC editor?

Edit1: Looks like lots of work…

Edit2: There must be a faster way then editing. Perhaps look into F-Engrave

1 Like