Ground Control doesn't launch on Linux Mint

Hi everyone, I am kind of new here so please be kind. :slight_smile:
I am running on linux mint os, and after several attempts, I haven’t been able to get GC to launch.
I have carefully followed the procedure, installing correctly all the packages required. After uncompressing the groundControl folder, and trying to open the file trough the terminal(from the folder), simply nothing happens.

The error is showing is the following: Import Error: No module named PIL

The google search of this error, directs me to several topics on stackoverflow, all related to python, but none related to groundControl specifically. I am not a programmer, but I have tried some solutions from the topics, but none work. Some of them suggest to instal PIL, other says PIL is deprecated, and now you have to use Pillow. After trying to install both of them trough the terminal (sudo apt-get install pil (or pillow on the second try)) the answer is : Unable to locate package Pil. So I am guessing pil or pillow are components from the python language rather than installable linux packages. As I mentioned before, no topic about this error related to ground control at all. So all the answers are for trained python users, I am guessing.

Please if someone can direct me to a solution of this matter, I will really appreciate it.

1 Like

Hello @Santiago, welcome!

From within the GC directory, run:

pip install -r requirements_linux.txt

That should install all the required files.


Thank you so much everyone for the help.

I solved this issue by instaling the missing pil…

sudo apt-get install python-pil

Best forum ever… thank you so much