Ground Control on Chromebook/xfce4 Linux "Not Connected"

Hello all, I’m working on setting up my Maslow with Chromebook running xfce4 Linux… It took a good bit of playing but I finally got everything happy to where Ground Control will start up. But now, whatever I do, it just says “Not Connected”. Works fine with my Windows PC. I have added my user to the dialout list using both commands, and have installed Arduino IDE. The Port is listed in the list and disappears when I unplug it. but it just doesn’t seem to do anything when I click connect, no errors or anything… Anyone have any ideas or things I can check? I didn’t install any drivers separately from what the IDE install did automatically, but don’t know where to start there.

Are you using Crouton or Crostini? I was running GC up until recently, before switching to WebControl, under Crouton in a xfce4 environment without any issues.

I think I followed the instructions here. They information may be a bit dated, but I had both the Arduino IDE and GC working and chips flying.

Crouton… Install was much more troublesome than everyone made it appear…wondering if something didn’t install right along the way. Took a lot of packages and programs, to get Ground Control to start up without any errors. :frowning: Might check into WebControl…

Solved: Webcontrol didn’t connect either…so i was forced to dig further…turns out that port was not part of the dialout group…in was in “serial”. So just had to run same script to add user but replaced dialout with serial…all good… But using Webcontrol now as well (things to note about that below, probably common knowledge, but i had to learn for myself)

Webcontrol doesn’t display properly on stock linux browser…does fine on Chromium though, so install and run on that.

And webcontrol appears to use a different g-code flavor compared to GC, had to find another post processor in Sheetcam that worked…still looking for a better one than the one i’m using currently…

1 Like

more information please? in both cases the gcode is interpreted on the arduino,
so they should be identical

what problems did you run into?

David Lang

Since Sheetcam has a large database for post processing “flavors” I tried a few of those to see if they loaded properly into the CNC control software for the Maslow… When I used Ground Control, a post processing for a Fagor Router worked perfect…when I loaded the same code into WebControl some of the arcs, were not interpreted correctly and coded full circles rather than just the small portion (as shown in the cut path visualizations). Switched the post processor to Dynatorch Router and it loaded properly. (traits of each are below) Only thing with that one, is there is one line of code that the Maslow doesn’t use at the beginning (like a tool change or something) so it pauses as soon as you press start but continues after skipping to the next line of code it runs till the end.

Fagor Router:
Non modal G-codes
Modal coordinates
Comments enclosed with ( and )
Incremental code

Non modal G-codes and coordinates
Comments enclosed with ( and )
G23/G25 turn the torch on/off
Incremental IJ

So looks like it has something to do with the non modal/modal coordinates. Wierd…wouldn’t think that would change…this info was listed by Sheetcam so i can’t confirm its accuracy

Ok, there is a known problem with the arduino not handling very small numbers,
and that can cause you grief.

both GC and WC have a setting to let you truncate values, which may help, or may
trigger the problem (the difference between a tiny arc and a circle is if they
start and end at the same point, so imprecision in this can cause this behavior)

in general, you should use the grbl post processing flavor

David Lang