Maslow Home Maslow Community Garden Newsletter

Ground control won't connect to arduino on Ubuntu

Hi there, maybe this is silly, but my maslow is working pertfectly with my macbook pro. My dilema is that i have an ubuntu machine and i want it to be my maslow PC. But when trying to connect to the arduino via ground control on ubuntu it shows a lot of ports and none of them connects to the arduino sucessfully. What can i do?

Do you have the Arduino IDE installed on the Ubuntu box? That might be necessary.

I also remember something about a “dial out group” which is a list of programs which are allowed to access the ports?

1 Like

on Linux it should be something like /dev/ttyUSB0 or something like that.

from a command line do lsusb before you plug it in and after to make sure it’s
being recognized correctly.

David Lang

k

Here are screenshots of all the ports available. On Arduino IDE it gets me the board info on port ACM0 and becomes available on ground control when connected. Arduino IDE is installed and the firmware is 1.17. Ground control is on 1.18 maybe thats the problem. Thanks for your reply blurfl.

1 Like

I think @bar is right - you need to make sure your username is a member of the ‘dialout’ group so you have access to that port outside the Arduino IDE. The command line command for that is:

sudo usermod -a -G dialout yourUserName

Log off and log on again for the changes to take effect

3 Likes

Thanks for your help guys. I opened terminal and pasted the dialout command, restarted the pc but it wont connect. I’ll keep on trying to solve this and let you know any progress. Thanks

1 Like

I bet someone with more Linux experience will chime in soon. When you figure out the secret be sure to add it to the instructions so that others don’t get stuck in the same spot.

The place I would start is to install the Arduino IDE on Linux and try to upload the firmware from there. If that works then we will at least know the port is working and the permissions are OK for the Arduino IDE

1 Like

You need to put your Linux username in place of ‘yourUserName’ in that line, yes?

2 Likes

Thanks guys, it worked with this two commands
sudo usermod -a -G tty yourUserName
sudo usermod -a -G dialout yourUserName

I hope this will help other users.

5 Likes

You could do:

sudo usermod -a -G tty $USER
sudo usermod -a -G dialout $USER

It’s the same command, but since $USER automatically gets replaced with the current user name, you can cut and paste and get the right action.

2 Likes

Is that in our Linux GC installation instructions - or should it be?

2 Likes

It does now.

Thanks for the suggestion!

2 Likes

I know this is an old post, I am having same issues, but have tried everything above and still GroundControl just says “Not Connected”