Ground Control v1.23 not starting

Hi there,

We are assembling our frame and trying to get the hardware and software up in tandem.

I installed v1.23 firmware on the Arduino, and I am trying to run v1.23 Ground Control.

The PC is a Windows tablet running 32-bit Windows 10 Home on an Intel Atom Z2670 @ 1.8GHz.

The firmware installed ok, and I used the Arduino serial monitor to verify it is sending data back to the PC regularly.

When I start Ground Control I get a command prompt with a list of diagnostic startup information (which I found recorded in the .kivy directory log files). These include messages about Kivy, Python, OpenGL, Shader etc.

I get one Warning: 0:20: ‘function_call_constructor@vec4_vec4@0’ : used without being initialised

Then

Success.>

Then a couple more info messages.

The GUI starts, which is a full-screen window with a title bar. The window is mostly black, with a smaller white rectangle within it. That’s all I see.

Then Windows helpfully tells me ‘GroundControl.exe has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.’

Spoiler: no solution is notified.

I downloaded the previous version v1.22, but I get the same error.

What to try next? Suggestions appreciated. Thanks.

Try updating windows, and the video driver.

Thank you

2 Likes

Checking for updates…
Updates are available…
Downloading updates…

This could take a while. No spoilers yet. :slight_smile:

2 Likes

Video driver is the Intel driver. It’s up to date.

I think we’re hosed. We’re “Getting Windows ready. Don’t turn off your computer.”

I unreservedly despise Microsoft.

3 Likes

There’s a fix run Ubuntu!

Check out POP OS from system 76.

Thank you

1 Like

Yes. Unfortunately Samsung and Microsoft have conspired* to make it impossible to put Linux on this tablet (otherwise I assuredly would have done it).

The reboot after the partial update finally happened. Ground Control still doesn’t work, but there are still more updates, so I’m eagerly anticipating the conclusion of that operation (10% downloaded already! And it’s still only afternoon!).

If it doesn’t work I’ll get another laptop or tablet and try it, although I would like to know why it’s not actually working. The Kivy logs tell me just what I wrote above. The Ground Control log is empty, so no clues there.

Cheers.

* Probably by incompetence rather than bad faith.

My Suface pro 2 happily boots Linux on a regular basis.

just my 2 cents

Thank you

That’s as may be, but this tablet is known to not work with Linux. It’s impossible to get it to boot from a USB stick.

I didn’t believe it, but after much wailing and gnashing of teeth I concurred that indeed that is the case. That’s why it’s relegated to Maslow duty.

I’m sure everyone will be excited to know the current status.

All updates applied. GroundControl.exe has stopped working. :frowning:

The behaviour is exactly as it was.

Any other suggestions? Thanks.

I’m going to try running the source code. We’ll see if that gets me any further (or gets any more info).

1 Like

Oh. This time “python.exe has stopped working”.

Le sigh.

1 Like

is that progress?

Well, not really. I was hoping that python would barf and spit out an error message. It must be something more fundamental.

The tablet has decided to do more updates, despite telling me I was all up to date.

The result: no difference.

1 Like

Ok. The error occurs in Lib/site-packages/kivy/core/window/window_sdl2.py at line 389

self._win.flip()

When that is executed, the program dies.

It’s probably something about this tablet, and Kivy, but I don’t know what.

See if you can download a newer video driver from Intel.com

That’s about a 6 year old chip that giggle says supports OpenGL 2.0. I don’t recall what Kivy/Ground Control require but it shouldn’t be hard to search it on this forum

1 Like

thank you

No dice I’m afraid. The Intel upgrade utility (from their website) tells me I have the latest version of the driver.

OpenGL is detected by Kivy as version 2.1

I think there’s something more subtle going on. This tablet was probably dropped on its head as a child.

1 Like

I just tried one of the Kivy demos. It crashes identically. I expect it’s this tablet, but none of the obvious solutions have worked.

In the trash, I think…

Same software, different tablet. Installed and working in about 30 seconds. I am disappoint.

3 Likes