Maslow Home Maslow Community Garden Newsletter

OpenGL 1.1 to 2

#1

I can not run Ground Control because my version of OpenGL is 1.1 and should be at least 2. I checked to upgrade my Intel driver but was unsuccessful. It looks like my only option is to upgrade my hardware… or my laptop :slight_smile: Is there a way around this problem?

Thank you in advance!

#2

Upgrading the hardware is for sure the best option.

I was successful on a very old desktop, but not with window$.
On the Linux I tried, Kivy is complaining heavy about the OpenGL version, but GroundControl runs.

I am not telling you to delete your operating system and I am not a linux guru.
For old hardware, linux is an option and information of linux being hard to manage is outdated 8 to 10 years.
You can try, install and test everything on a USB drive, as long as you know how to boot from it.
For testing, there is no need to install or delete anything on the harddrive!
If it works and you get along with it great, if it doesn’t work, nothing but time lost.

2 Likes
#3

What make and model computer? Which operating system and what version? How did you try to update the driver? What error(s) did you get, the exact text is best?

1 Like
#4

Hi mooselake,
here are the information:
-DELL
-Inspiron15r
-Inspiron N5010
-Microsoft Windows 10 Home
-Version 1703
Use the Intel Driver Update Utility 2.8.2.
The utility suggest to install "Intel Chipset Device Software (INF

#5

(INF Update Utility-EXE-Only) SetupChipset.exe version 10.1.1.14

The installation seems successful but … not.

#6

image

#7

They must love standards, there’s so many of them. OpenGL, OpenCL, OpenWhatzit.

From a bit of googling I found the specifications: i5-430M, maybe ATI HD 5470 graphics, 6GB (don’t know if that’s up to 6GB or just what they stuff in it). Assuming that matches your laptop (likely lots of configurations with that model #), that’s not bad specs for around 2010 or so, although the gamer community would look down on it. Even if it’s just the embedded GPU it should work according to Dr. Google.

So there’s two possibilities, either it only has the on-CPU graphics (Intel HD), or there’s an additional graphics adapter. Run dxdiag (Win-R, type “dxdiag” in the box, skip the WHQL driver signing test) to see what graphics you have, it’s on the display tab. Lets assume Intel HD. IIRC the chipset update doesn’t include the graphics adapter, there’s a separate download listed here. Looks like it’s from 2013, from here and other comments looks like Intel does the hot potato drop on products after a few years and this is in the pushing 10 years old catagory. From here it has opengl 2.1 support (that took far longer to find than it should have…). Of course the Internet follows Sturgeon’s law, 90% is cr*p.

Dell has a download section for that computer, including a “latest driver” check. Just be aware it may not have been updated since they quit making the product, but it’s worth a, er, check.

ATI got et by AMD, which will have the latest drivers if that’s what’s in it. Report back if you need somebody to dig it out for you.

There’s also the possibility that the OpenGL level test is bad and doesn’t work right on your CPU, but let’s discount that for now. There are downloadable utilities to tell you which level OpenGL you support, but since I haven’t tried them I don’t know which are reputable. Somebody else here should.

IMHO running a Maslow is a great use for an older laptop, dedicate it and then use it as an excuse (if you want one) to get a new one for daily use.

2 Likes
#8

Hi Mooselake,

first, thank you for your time and effort. It is much appreciated. I realised that this laptop is old, but it is working perfectly and does the job. I was hoping to use it in the shop. The CPU is a i3-370M @ 2.4 GHZ. As far as I concern, this CPU should be able to run OpenGL 2… but not doing it. I did all the update possible with DELL and INTEL, still no success. If I try to run GroundControl, I get this Kivy Fatal Error and the program stop. The good news, I have an iMac 21" and able to run GroundControl. It is not as “portable” as my laptop :), but I will be able to play and learn my new CNC machine for the time being. I am not giving up finding a solution to use my old laptop. Not yet :slight_smile: Again. thank you for your time.

1 Like
#9

I just had the same problem on my 10 year old laptop. Last year this laptop was reformatted and I put windows 7 on it.
The fix for the open gl 1.1 to 2.0 for me was to just do a windows update and it fixed it. I usually leave windows update off on that laptop so that it’s not constantly updating.

Good luck

#10

I had the same issue with an old laptop I recently reformatted and installed windows 7 for the purpose of being the maslow computer. I’m gonna try running all the windows updates (holy cow there are a lot of them) and see if it works after that.

1 Like
#11

I had the same issue on a clean install of windows 10. As soon as I ran the updates everything started working.

1 Like
#12

I am having the same issue with a Dell laptop but it is only about six years old. This information is a great help to me. I will try the up grade for the GL 1.1 to 2 and see if that works. Thanks again Walt66

2 Likes
#13

OK I have tried like 4 different Intel graphics drivers… no luck. I have an Intel i3 380M in an HP laptop. It even says on this extension OpenGL tester thing I downloaded that I am running OpenGL v2.1 at 100% compatibility…

OpenGL version: 2.1.0 - Build 8.15.10.2476
Vendor: Intel
Renderer: Intel® HD Graphics
DLL:
Device:

OpenGL 1.2: [ 100% - 8/8 ]
OpenGL 1.3: [ 88% - 8/9 ]
OpenGL 1.4: [ 93% - 14/15 ]
OpenGL 1.5: [ 100% - 3/3 ]
OpenGL 2.0: [ 100% - 9/9 ]
OpenGL 2.1: [ 100% - 2/2 ]
OpenGL 3.0: [ 80% - 17/21 ]
OpenGL 3.1: [ 85% - 6/7 ]
OpenGL 3.2: [ 55% - 5/9 ]
OpenGL 3.3: [ 10% - 1/10 ]
OpenGL 4.0: [ 0% - 0/13 ]
OpenGL 4.1: [ 0% - 0/11 ]
OpenGL 4.2: [ 0% - 0/11 ]
OpenGL 4.3: [ 0% - 0/26 ]
OpenGL 4.4: [ 0% - 0/15 ]
Spec score: [ 43% - 73/169 ]
Func score: [ 111/517 ]

But whenever I try to run ground control I still get the same error saying that I’m running version 1.1 and it won’t work!! I don’t understand!!

Is there some registry key somewhere that needs to be changed for ground control to recognize the true power of this ghetto laptop I got from a coworker?!

Thanks for any advice.

1 Like
#14

This fix worked for me, minor change in the config file and the problem didn’t appear after that.

3 Likes
#15

Did you edit your local Kivy configuration file:

Change multisamples key value in config file (%HOMEPATH%\.kivy\config.ini for me) from multisamples = 2 to multisamples = 0.

or did you have to edit one of the GroundControl files to make the change?

Glad you found a solution, it would be good to add to our Windows support lore somewhere :slight_smile:

1 Like
#16

I am having this same issue. I am not very computer savy so sorry if i ask a dumb question.

I am using a dell e4300 with windows 10. I am trying to install the latest version is there a quick solution some one can point me to? thanks in advance.

#17

I am having a similar issue.

I can not find the local Kivy config file, as I do not have Kivy installed on the PC. I am running groundcontrol from the extracted zip. (works perfect on my newer machines) I can not find any config file in there that has a “multisamples” value.

Any suggestions on where I should be looking or how to bypass the OpenGL 2.0 check? This is on Windows 7. I may try the Linux install later.

Thanks
Steve

1 Like
#18

@Steve_Shaw

Welcome to our group. I’ve seen this issue before. I may have a solution for you. May I ask why you’re still running Windows 7? I would like to get some details from you. Can you PM me?

Thank you

#19

Apparently no I can not PM you??? I can view your profile, I can check my messages, but some how I see no way to send a PM??? Maybe I need a minimum numbers of posts in the forum first? Send me one, then I should be able to reply.

I am only running Win7 because it it was I have a legal copy of and I know it will run half decently, on this underpowered LG x110 netbook. I can upgrade to Win10 if you think that will help. The biggest issue maybe that I am trying to run this on an LG x110 net book, and it looks like there is no way to upgrade the Intel Mobil 945 to support OpenGl 2.

This machine will be dedicated to the Maslow, so I am good to run Linux on it if needed, if we think that will help.

Thanks
Steve

#20

Ok I’ve PM’d you. I have website over here -

https://www.disciplesofcnc.com/

If you signup I’ll reach-out to you. You don’t have to take the magazine to sign up. Membership is free.

Thank you