No response from motors

Guys,
new to the Maslow, of course, and have spent quite a few days getting it set up.
But I have a BIG problem and cannot seem to find a way past it. Could do with some help :slight_smile:
Followed Electronics set up; everything lights up.
Downloaded Arduino IDE (1.8.3 windows) and set up the board and uploaded.
Downloaded Ground Control (0.84).
Now my issue;
nothing works…
Tried testing motors (orange light flashes, but nothing moves)
Tried Calibrating (no movement)
log keeps telling me “USB connection lost” so tried different USB cable, but still nothing…
Read thru’ lots of forum topics and have tried all sorts of things, but I can’t help wondering if there’s a fault with the board?
Or am I just stupidly missing something simple?

Hi @Waldek, sure you checked that the power supply is in the shield and not in the Mega. Happened to lots of us :slight_smile:

  • after uploading the firmware, in the Arduino IDE, click the mag-glass for the serial monitor. Do you see lines like:

ready
ok
Grbl v1.00
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<<< ?
Is the output of that monitor ‘stable’, or do you notice a drop of connection there already?

  • Is the Arduino IDE properly closed, before you start Ground Control?
  • In Ground Control, on the right bottom side, do you see it connecting and reporting:

Connected on port xxx and reporting firmware and groundcontrol version?

  • Is the drop of connection more random, or is it in intervals, like every 2 seconds?

Hi Gero!
Power is connected to the shield, for sure.
Tried clicking mag-glass in Arduino as you suggested and there are no lines…

what does this mean?

connection drops every couple of seconds in the log as well

No lines in the arduino IDE sounds like the firmware is not loaded. What are the board and the port settings in the IDE?

1 Like

2 Likes

That looks good! Confirm that you don’t have GC and Arduino open at the same time.
When you uploaded the firmware, it should look similar like this:

3 Likes

In the serial monitor it should look similar to this:

3 Likes

In your picture you would be uploading an empty sketch to the Mega. That would explain the empty serial monitor.
Opening a new sketch makes Arduino IDE put it in a new window. Close the window with the empty sketch, so only the one with cnc_ctrl_v1 is open before uploading.

3 Likes

Hurray!
You star!
I completely missed the downloading firmware part…
doombrain.
Many thanks :smile:
Now let’s get this rig going!

5 Likes

Hurray! Let us know how it goes. Still worried with the dropping connection. Lets hope that just disappeared :slight_smile:

4 Likes