Groundcontrol crashes when connecting

Hi There

My groundcontrol crashes when its connecting to my Keystudio Mega 2560 microcontroller (Arduino compatible) via usb. In the morning i got everything working for the first time and i was getting ready to do my first real cut. Then my groundcontrol crashed, and kept crashing… I have tried to re upload the firmware and reinstall groundcontrol, several times now, but it just keeps crashing. It does not crash when the cable is not plugged in, but as soon as i reconnect it crashes again… Can somebody please suggest a way for me to fix this? i am in need of some inspiration! Thanks
Best regards

What OS, GC version, Firmware Version?

Hi ScrumdyBum

Firmware 1.12 cnc ctrl_v1
High Sierra 10.13.4

This may help find a root cause

*Edit:Well maybe it is not for Mac

1 Like

…hm you might be right there. but thanks. Any other ideas?

Can you Try 1.11 ground control and firmware to see if that works? I’m sure somebody will pop on here shortly that has a good answer.

On a Mac, I’ve had GC crash like that when I renamed it and had a space in the name. Is that the case?

1 Like

hi - i do not think so. i have not changed any names recently? thanks

I will try this in the morning and let you know how it goes. thanks!

1 Like

The groundcontrol app needs to be copied from the .dmg to the Applications folder, it won’t run from within the release .dmg . You might also need to right-click on it and choose ‘Run’ to confirm that it should be allowed.

Hi - Its is. And i had it all working fine yesterday morning. but thanks

Hi ScrumdyBum

I have tried to install both; Firmware-1.11 and groundcontrol-v1.11. But Groundcontrol still crashes upon connecting to my Keystudio Mega 2560 microcontroller. ihhh… is there a way to clear out old data on the harddrive on the microcontroller?

Best regards Mads

I am real eager to get this thing working…

Please check the earlier post!

Is there any body who knows if i can erase and clear old data from the microcontroller?

Best regards Mads

1 Like

I believe there is a reset button on the arduino under the sheild.

1 Like

If you program the Mega with something other than the firmware, like the Arduino Blink sketch, I think that would do it.
Does GC stay running if you start it with the USB cable unplugged? If not, try moving the ‘groundcontrol.ini’ out of your home folder to see if that helps.

1 Like

hi. it did not help, yes, it stays open when not connected…

I think this means that moving groundcontrol.ini did not help? One setting in that file is the port that it expects to see the Arduino on. I hoped that if it didn’t know where to look for that connection, it wouldn’t close when the Arduino USB gets plugged in. Then choosing the port again to refresh the connection, I hoped all would be well.
GroundControl keeps a log file named ‘log.txt’. Uploading a copy of that might help sort this out. In OSX Finder, in the Applications folder, find the groundcontrol app, right-click on it and ‘Show Package Contents’ to open a window that lets you navigate to the right place. The GroundControl log.txt file is in the ‘Contents/Resources/yourapp/’ folder.


Here’s a link to an Arduino sketch that will clear the EEPROM without needing to use GroundControl.

nice!!! i will safe the link! i got it working during the night. i shifted to a pc an recalibrated…

and, yes moving groundcontrol on the mac did not work…

i just saw your message now. so no log file. but i can see i if can find it, if you want to see it?

best regards 'Mads

I’m glad you got up and running. If you’re happy with how things stand, no need to go find the log file. I’m interested, but don’t want to get in the way of your making wood chips :blush:.