Maslow Home Maslow Community Garden

Ground Control message continually toggles from "Connected" to "Not Connected"


#1

I am relatively new to this. I cannot test the motors, I believe, due to this. Anybody have the same issue?


Cannot calibrate, toggles between connection on port com3, and connection timed out
Calibration issues
#2

Welcome. Yes, I had this but on Linux with an outdated pyserial module long time back.
It would help if you could post your operating system and the versions of GroundControl and Firmware you are using.
Did you close the Arduino IDE before starting GroudControl? Did the Firmware upload go well?
Edit1:
One more test please. In the Aduino IDE, after the upload, kindly click on the ‘Magnifying Glas’ (top Right) to open the serial monitor. With a baud rate set to 57600, do you see something like:
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
?
Ignore my numbers here, they might be different, the question is, if that output runs continuously through without loss of connection.


Calibration issues
#3

I also experienced this when I was first getting my Maslow set up. I was able to fix it by re-uploading the firmware to the Arduino. Not sure if the code didn’t compile right the first time, or if it was something else.


#4

what are you using to interface to the Arduino? Raspberry Pi, laptop, or what? If it is the Raspberry Pi - type this in on the command line: sudo pip install --upgrade pyserial


#5

As “jberd” I am also new to this and also having the same issue.
I am running Windows 10 off a laptop.
I have re-installed both Arduino IDE and the latest Maslow Firmware a couple of times and still continue to get “Connection Lost” "Connection Timed Out.
Any help would be greatly appreciated.
Thanks.


#6

Those messages indicate that although the serial port selected in GroundControl is alive, the data coming from that port is not the expected data. You can troubleshoot this in the Arduino program after you’ve uploaded the program to the Mega2560. After you see ‘done uploading’, open athe Serial Monitor from the Tools menu. Make sure the baud rate is 57600. You should see something like:

ready
ok
Grbl v1.00
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:0.00,0.00,0.00,WPos:0.000,0.000,0.000>

That’s what GroundControl expects to see.


Calibration issues
#7

Hi, I changed the baud rate to 57600 in Tools-Serial Monitor. GroundControl
still gives me Connected on port COM11…Connection Timed Out…
I am running GroundControl V 1.0 on Windows 7 Home Premium on a HP pavilion
g6 Notebook PC…64-bit Operating System.
Has anybody else experienced this and passed this point?


#8

Usually this issue means that the firmware either did not upload to the Arduino successfully or that COM11 is actually some other device. Did it seem like the firmware uploaded OK and that the Arduino was COM11 when uploading the firmware?


#9

OK let’s try this. When you have a failure. Do not change anything. Close Ground Control open the Arduino IDE and attempt to upload the blink sketch under file-> examples. Tell me if this works or fails. If it works re-load the Maslow firmware.

Please report back.

Thank you


#10

I am good now. I uploaded the new firmware…opened GroundControl…testing of the motors went well. Thank you so much. I will continue with the posted instructions.


#11

Thanks for the update! It always feels good to help :grinning:


#12

Okay, my Maslow has under gone a rebuild, and I’m firing her up again, but have the problem detailed in the thread title. All the connections are the same as before, when she worked, except I have z-axis plugged in. It’s repeating the ‘Connected’ / ‘Connection timeout’ about every five seconds. (All latest versions).
Any suggestions?
Cheers.


#13

If the USB plug is in a different socket, the port name might be different. Do you see the Arduino in the port list of GroundControl?


#14

Dunno, weirded me out! I’ve been around in circles. Third install from firmware up and, it’s working. I blame my lappie!


#15

I’m also having the same problem where ground control continually toggles from connected to not connected
I’m running win 10 (up graded from a win 7) gateway desktop dx4822 I also re-installed a couple of times.
with newest firmware… I tried running it on a RCA win 10 tablet and still same problem very frustrating!!
an FYI the board came with 3 or 4 pins bent which I fixed and the board that I received was a mega 2560 R3 don’t know if that matters or not…
someone please help
thanks


#16

Make sure anything that could access the port is closed - like the Arduino IDE. Also if you ave another USB cable to try.

If you close Ground control and Open the Arduino IDE - Load a program from examples that outputs to the terminal and open the terminal.

I’m looking for an example and will up date this in a few minutes

See if it disconnects

Thank you


#17

thanks @Bee, but I don’t know what that means, I’m totally new to this.


#18

No problem - I will explain but need a little time to set it up.

Thank you


#19

The ‘connected…not connected’ symptom is a showstopper for sure. The 'mega 2560 R3 ’ is the right version/model of Arduino board, it’s the one we all got with our kits.
The first thing to ask is - have you been through these steps? If you have, and got the happy ‘Done uploading.’ message, then there might be an issue with the USB connection from the computer. Do you have a different USB port, or a USB hub you could use to connect to the Arduino?
Keep asking the questions, we want to get you cutting!


#20

I opened the firmware by selecting cnc_ctrl_v1., there was no “ino” extension only cnc_ctrl_v1 and clicked that and received the done loading.