How long on pause?

Is it reliable to leave a cutting programmed paused for a long period of time? I have a cut that will take about 7 hours, but I rarely have that much time to be in the garage. Is it reasonable to cut this over a few days or a week or two, pausing after an hour or two of cutting each time? Is there an upper time limit? I know, of course, to watch for windows updates, laptop going to sleep, etc.

just watch the line number when you need to stop. Stop it. Make a note of the home position just in case. Then when you get back to it, enter the line number in the box and press “goto” and then press “Play” (start). If you are off by one or two lines, hit the “<1” button above it and it will go to the previous line. if you are concerned about z axis movement and want to start where it previously plunged, then use the “<Z” button.

1 Like

the problem with doing this is that there may be settings earlier in the file
that you won’t set if you just jump to the line you left off at.

David Lang

I tried exactly that in web control recently and could not get it to work. It was communicating and I could move the sled around but it would not go to a line in the Gcode but it would allow me to start over. Another use (I can’t remember who) suggested modifying the nc file so that the initial paramerts wer still there but the already cut lines were removed, which also addresses the issue David pointed out in his post. I was miffed at myself because i did not think to try this, frustration had me at that point and I watched the machine cut air for 3 hours.

When I attempt this, I get “Error with moving Z move”.

What am I doing wrong?

I suggested chopping the gcode file down. I’ve periodically edited the gcode in webcontrol or rearranged pieces of them before uploading. I’ve not had any issues with restarting, but I’m not using overly complicated files either… except today’s. The system always runs in metric and is in absolute mode. Today’s code was running yesterday and today. On this cut I’ve broken bits and resumed and I have recently had some gcode with radius codes ® that cause the system to just hang, so I’ve restarted the current cut I’m on about half a dozen times. It is the most frustrating one I’ve ever done. I’ve reset the chains twice, shifted the home position twice, and for a 4 pass cut 3 passes in, none are the same, so I’m going to recalibrate. Wasted a whole sheet of mdf. I’ve only ever calibrated the system twice and it has run awesome other than my jenky z axis that I just rebuilt and is now working amazing. That restart is a life saver.

but to the original question… as long as the pc or the rpi doesn’t go to sleep and disconnect from teh USB, you can leave it on pause as long as you like.

Oh I should mention I was running web control on a samsung tablet that may or may not have something to do with it. And thanks for the tip again, sorry I forgot you were the one who offered it.

I find using webcontrol on an amazon kindle kind of annoying because it is jumpy. the text boxes that show the gcode file currently loaded changes the page so it tries to resize all the time on the tablet. minor annoyance, but it still works. Does it do that in the web browser on the tablet you use?

I think your initial idea of using pause makes a ton of sense. It might still be worth writing down the line number in case something goes wrong, but pause seems like the easist way to me. There is no time limit as long as the machine stays connected

It is not jumpy, the UI doesn’t fit in the window though. I did figure out how to get a small view of the workpiece and the main control buttons on the screen at the same time.

Webcontrol tries to process the gcode to put the machine in the right configuration and position so when you do use a gcode index move, it works. It’s pretty difficult to do coding-wise and if you find you are having a problem, there might be something in the gcode that is causing webcontrol and issue. Email me the gcode at madgrizzlemaslow at gmail dot com and I’ll be happy to look into it.

Make sure the gcode has a G90 or G91 at the beginning of the file. Next release will catch this issue and default to G90.

1 Like

@orob, @tinker made some changes recently that might have helped this problem. Is your html/js code up to date?

That post should have stated that I found it problematic when I tried it in January in version 919. It was continually going from portrait to landscape as it reloaded and the button sizes were changing. On the phone it never did that so have just used the phone since then. It may be related to the kindle browser as well. I’ll try it again on 931.

Pausing overnight worked fine. Thanks all.

2 Likes

@Orob, The whole layout has been reworked in the experimental branch but I do not see a release for it.


This experimental branch removed all calculated CSS and JavaScript resizing so it should work flawlessly on all browsers that support HTML5 (almost all).

There may be an option to downgrade to experimental in the 0.932 release. It should have an odd ending number e.g. 0.931. Settings->WebControl Settings called ‘Enable Experimental Releases’.

There’s issue in release manager in 0.931 so I’ve removed it. I’ll be pushing 0.933 soon with the changes… just need to find time. Things are hectic atm.