I WISH I could make something great... but I can't get it to work!

I finally got my machine to stop jumping teeth on the chain and wrapping around the gear. I had to put a counter weigh system on it. Now, I can’t get the Z axis to work right consistently. I tried setting the z axis to plunge 5mm. I can’t get it to do it consistently. It ranges from 4 to 8mm depths.

Also, I set the calibration of the Z axis to “0”. When I start to mill a part, the Z axis retracts, the sled moves to the start position. The z axis extends but does not extend enough to cut anything (it cuts air). Then the second pass starts 3 to 4 mm into the material. Typically, the X,Y axis stops, then the Z axis extends. Now the Z axis extends while the X,Y axis is moving.

Then the Z axis plunges all the way down and the router chuck gets pushed into the material.

I re-calibrated the Z axis and it did nothing. I then tried to put an older version of firmware in (right now, it is 1.12). but I can’t upload the firmware because Arduino says there are errors. Yes, I have the correct port and board selected but it will not let me upload anything.

I’m about ready to give up on this machine. I have yet to be able to make anything with it yet.

Why can’t I upload the firmware? Why can’t I get the Z axis to work?
Any help would be appreciated.
Thank you

I can possibly help with the Arduino issue. I have a simple installer here:


it directs you to a page with a firmware up load explained. It takes about 2 minutes to do.

Also do you have a bungie cord installed over the router yet?

Thank you

I had similar issues to start with and it turned out to be a combination of several problems… I am using the recommended Rigid router.

  • No back pressure… I used 3 hair ties and put the large handle bolts back in to attach them to.
  • The ring lock on the router was way to tight… I loosened it up and waxed the inside of the housing. Be careful not to make it too loose!
  • I did not have the two lock screws tight enough on the Z-Axis connector… so there were times that the router would plunge, but not enough and would “cut air”

I have cut around 160 .5" x .75" deep test holes over the last few days and have not had any Z axis issues.

I will add some pictures when I am back in front of the machine.



Your Z axis problems sound like you have the latch open on the base, you need to
loosen the nut under the latch so that when it’s closed, the router can move,
but doesn’t stick.

Try waxing the body to give it more “slippery” too.

Thank you

Thank you all for your help but I have tried all of those suggestions already. Except the bungee cord. I’m not sure I understand what to do with that.

I have the standard Ridgid router. I adjusted it so that the clasp is closed but I can still slide it up and down with my hand. I also used wax on the mating surfaces.

Another thing it does is the little latch that slides into the guide and locks in the adjustment screw pops out during use. Now, remember I said I have the clasp adjusted so that the slop is minimal but I can slide the router up and down with my hands. But often, when the z axis is turning, that latch pops out. For the life of me I can’t see how/why it is doing that. The spring is tight and when I try to pull or push the router out by hand with that latch engaged, I can’t get it to pop out.

Also, as for the Arduino issue, I tried another laptop and was able to upload 1.11 to the Arduino. I think it went in but I did get a few lines saying that some files in the library could not be found. So, I am not sure it is a good upload or not. All the words were white and none were orange.

I tried running the mtn.nc but this did NOT fix the z axis issue. It still adjusts the z axis while the x,y axis is moving and plunges the router all the way down and bottoms out.

I think that might be your problem. It sounds like it is not engaged correctly and then the Z-axis is turning, it has nothing to drive. Can you post pictures?? I will post pics of my setup later tonight or first thing in the morning.

concussiongfx, I will try the bungee cords. I bet that with fix it because when it pops out, I can push the router down and I can hear a good solid “snap” as it engages. I just don’t get how it can pop out.

I think maybe with the bungee cords, it will keep downward pressure and eliminate the router popping out.

Now I just need to figure out why the Z axis is malfunctioning. I didn’t have this before I put in firmware 1.12. Maybe I should go through calibration one more time although I am not confident that will help.

Regarding the Bungee, here is what mine looks like…


I have not had any interference with the chain rollers and the bungee hooks. There has to be a constant downward pressure on the router housing to insure that the z axis motor and router linkage drive the blade to the same depth all the time. There is too much slop in the router linkage otherwise. Observe the small screw in the bungee on the motor top… be sure that is as short as possible. This keeps the bungee towards the rear of the router, and therefore the bungee hooks will stay at the bottom of the ring.

Hang in there!

That picture explains a lot!
I will give that a shot. Thank you VERY much for your help.

Rubber bands work just fine over the spot the handles used to be.

You should not be able to move the shaft by hand… IIRC there is a little plastic piece the snaps into a notch on the metal part of the router shaft. Sounds like this is not in and when the screw turns it does not raise or lower the router.

no no no… not the shaft. I meant I can slide the router itself up and down with my hand. Meaning, that the router does not appear to be sticking or jamming up. Which is why I don’t understand why that latch pops out of the groove.

But, I’m hoping that the bungee cord fixes that issue.

If it is popping out, then maybe the collar is too loose.

I had a similar issue with my Rigid router. It ended up being a .75 cent part. Part number 10. below, which is a small torsion spring made of metal thinner than a paper clip. I noticed there was space between the out body and the spring and thus not supplying enough force to keep the lock lever engaged. I disassembled the screw and was able to bend the tiny spring out enough so it was supplying tension again. I also ordered spares.

I will mention when I had everything apart, I noticed that the part 6. the interlock lever piece that plunges through the router base was not flat on one side, and lightly filed the edge to make it flat where it rubs up against the router base.

I then reassembled everything and lubricated all contact surfaces with paste wax or light machine oil, and I have not had an issue with my Z axis since doing this.


Thank you jamtek,

I did bend the spring for a stronger tension but it did not help completely. I have been watching the Z axis move up and down several times and I noticed that whenever I move the Z axis down, the ccw rotation of the shaft just slightly rotated the lock lever (item # 6 on your parts breakdown) away from the hole/router basically disengaging it. So, I loosed all the mounting hardware for the Z axis as well as the z axis motor, ran it up and down a few times to let the assembly “find” its center and then remounted the brackets to the sled base. I waxed the shaft and it seems to work better now.
i have only tried it a few times so I am not confident yet that this fixed it.

I do like your suggestion of filing item 6 down so it seats better. I will try that next,

Check to make sure the head of the router isn’t coming in contact with the z axis motor bracket. When I installed my linkagekit, I had turned the bracket so it wouldn’t interfere but in doing so, I moved the top of the bracket a hair closer to the router and the head of the router, being slightly larger than the body, would hit it and get stuck. This resulted in the router disengaging from the z axis adjustment.

1 Like

I had the same issue that Jamtek had. Spring came loose and caused the router to plunge 1 inch deep.