Is anyone here running GC on Ubuntu?

Is anyone here running GC on Ubuntu? I’m thinking of testing GC under Ubuntu on a Raspberry Pi. First I want to know if anyone has impression of just running it under Ubuntu.

Thank you

I know there are some issues with running Kivy on the Pi without using KivyPi but I don’t remember exactly what they are

I ran into that with the default stretch desktop, no pointer is visible. This would be straight Ubuntu on the PI so the hardware is irrelevant at this level. I appreciate the feed back any information is helpful before I jump in the deep end.

Thank you

This is because Kivy is in touchscreen mode instead of mouse mode. I don’t know
exactly where to set this, but this is why you don’t have a pointer.


I’ve edited the config to force the mouse to use the touch interface on Stretch but nothing seems to work so far. I found the experience to unstable on Kivypi to make the PI a candidate. That is why I am looking to Ubuntu to see if it is a better experience. My understanding is the mouse should a the Ring where a finger touch is located.

Thank you

you don’t want touch mode, that hides the cursor.

I’m painfully aware of that …

In Kivypi I can only see the mouse when it’s moving. It crashes because it times out finding the touch location.

searching I found this:

A bit of an old topic, but in case anyone abandoned Kivy because of this issue
(like I did), I found that it’s been fixed!

Mouse cursor support was added by way of the TouchRing module, which is a
default addon module that allows you to see a ring around your touches (this
lets you calibrate your touchscreen if needed, for example). You simply need to
enable this module and pass it a command to enable the mouse cursor.

Once you’ve compiled and installed Kivy, you will have a hidden directory in
your home directory named .kivy which contains config.ini. At the bottom of this
file is the [modules] section. In this section, add the line:

touchring = show_cursor=true

Now any Kivy app you run will have a working, visible mouse cursor! You can
ignore the old complaints about the keyboard not working too, since it works
just fine as well. I’m working on a smart thermostat project that will make use
of the upcoming Pi Foundation touchscreen, and now I can comfortably develop the
UI while I wait for the screen to come out. 

1 Like

I appreciate that. I have done that as well as cursor=1.

I added this to the congfig.ini

touchring = show_cursor=true

rebooted, no joy

I also tried the file

This does work in Kivypi

Thank you

1 Like

If you look through the old forums there’s a lengthy post from me that’s a detailed saga of me trying to get Kivy working on Raspbian (albeit Jessie). I never got the mouse cursor to show up. The Kivy community considers that issue “solved” and repeated solicitation for help went unanswered.

It is well documented, I spent around 10 hours researching the net on this. I then spent around 12 hours trying every combination I could come up of loading to see if it made a difference. I appreciate your pointing it out. I don’t know where the old forum is I’m only about 2 weeks in.

Thank you