Running GC on Raspberry Pi - Best Experience

Free Advice - You get what you paid for :wink:

IMG_3474

Ok that disclamer out of the way. KivyPi on my Pi 3 not using a touch screen pretty much is a fail for me. The mouse cursor is missing until you click and move, it then shows up as a ring as if you touching a touch screen. In other words what is happeing in this setup is you mouse is emulationg a touchscreen and it sort of works in the best of circumstances. For me in les then 90 seconds of use it crashes with a menu location error.

I tried setting this up with the Defult Raspian Strech desktop and it failed to yeild a mouse cursor at all.

Both are slow and slugish over all where GC use is concerned. If you don’t want to us GC then there are some fiine peices of software that can run here.

I reported that under these circumstances I wouldn’t bother running on a Raspberry PI. It turns into a expensive choice for a less that satisfactory experience.

I posted some questions about anyones experience on Ubuntu. @Gero reported hew is using successfully using Ubuntu Mate desktop with GC. I truely appreciate that. The flavor of Ubutu for Pi is Ubuntu Mate on the Raspberry Pi dot Org page.

The quick answer is - I’m running GC on a Pi3 with Ubuntu Mate. I’m having a better than adverage experiance on the Pi3. That is I’m running GC in full screen with an arrow cursor and mouse control just like on windows. I have not plugged in the Maslow yet but I doubt I will run into any issues with the conectivity that cannot be worked out.

That is the good news. What is the bad? The bad isn’t so bad. Ubntu Mate is slow to load up, some things are more sluggish. Some of the installs semed to go “busy” for over 40 miuntes. I think I have a 5 hour total working onthe install to get to the GC screen. The point is when GC is running it’s very resonable in speed. The install is not clean it throws errors and some stuff just has to be figured out.

In the end barring a connection issue I can recomend this as a Raspberry Pi solution.

Let me expalin the hardware I’m using. I happen to have a Raspberry Pi laptop. I do not like to be nagative about products publicly under normal circumstances. I’m going to stay away form this here mostly. I have a laptop kit that is know for battery issues, so it’s a laptop that is not portable and must remain plugged into the wall. It features a 720p display and and a nice keyborad with a PI3.

From my perspective running GC on lower resolution than 720p could be challanging.

I’m going to say it is probaly a waste of time to run anything below a Pi3. A $29 price point sounds good but with a power supply and memory card your closer to $60. If you have a 720p monitor or better and a keyboard and mouse laying around this might be an option for you. If you are starting form the ground up there are laptops that will be a much better bang for your buck.

GC on a PI3 with Ubuntu Mate is a reaonable solution in my book. Please let me know if you found this helpful.

Thank you

6 Likes

I found that very helpful! Thank you for summarizing all of your work for us

Follow up - I was able to connect. It took a small effort. I installed the Arduino IDE, tested there then added my user to the dial out group, restarted, opened GC and was able to connect.

Thank you

3 Likes

First of all COOL TINKER-TOP! :smiley:

Thanks for that feedback on Pi3 experience.

What comes to mind is this:
What is you boot it up in terminal mode and launch GC from there, without running the entire desktop.

No clue if there are dependencies that prevent this from working, but if that works then there is also no other interference of typical desktop software that runs in the background.

2 Likes

When you do that by default in KivyPie you don’t get a mouse cursor. The mouse is invisible until you click, like a touch screen emulator. There’s a cursor module you can enable, however it’s laggy and also isn’t bound to the screen so you can lose it easily if it moves off the edge. It’s still extremely slow.

2 Likes

@Allen_Cook

Yes this was my experience as well. While this is workable and my goal was to find out if it was. My daily driver is a Lenovo T420 running Windows 10. Here is why - Cost ~$120 refurbished at Newegg. Experience - Open box , boot windows < 1 minute to login. Type in Windows License, Download Ground Control. Run Ground Control. ~ 15 minutes to go from Box to Running. I suggest the Arduino IDE as well that it’s maybe another 30 min.

Another advantage with this laptop is if the power goes out the laptop keeps running. There are options.

Raspberry PI - Long download of Image file - > 1hr, Burn Image file ~ 30 min, Boot Burned image, configure, ~ 30 min. Setup internet connection, Install Kivy, Pyserial, Ground Control, Several hours. You can burn through 8 hours pretty fast at this. However on a Pi for me this is the only acceptable solution at this point.

I appreciate your input.

Thank you

1 Like

@Bee Sorry I was replying to @vertex, never posted here before!

2 Likes

I’m trying to figure out what’s possible but I need to take a step back from this GUI stuff for now. I will try to get my hands on some touch screen hardware

** revision

I have VNC to a Pi running GroundControl and connected to a Malsow!

IMG_3586

Thank you

4 Likes

That’s great! Were there any special tricks? Didn’t I see a post about XRDP a little while ago?

WOW and more then 20 is all I can say, WOW!

1 Like

XRDP is working for software install but needs X11 help - X11VNC is working. I’ll write it up once it’s nailed down.

Thank you

2 Likes

Very nice Bee

Now i have to wonder if GC should be able to run in a webbrowser somehow (that would take VNC and RDP out of the equation)

You really will need a hardware E-stop on your machine. If VNC looses connection you really should have a way to stop it.

Actually - it is possible to run a VNC viewer in Java in a webbroswer. See were I’m going :wink:

Thank you

2 Likes