Issue with circles randomly being cut

There was an issue with random circles being cut as full circles instead of partial circles as seen in this video:

The solution was to turn off the automatic truncating of the number of digits being sent to the firmware.

Unfortunately because the settings file is only created the FIRST time ground control is installed the only to make the change for existing Ground Control installs is to force the setting value to false every time Ground Control is launched, so for the next few weeks to use the very useful feature of truncating the number of digits sent to the machine you will have to go into settings and manually enable it each time GC launches. Once most peoples installs have been fixed, we’ll turn off the auto disable on launch part.

If anyone can think of a better solution, let me know!

1 Like

It would help to know the gcode part of the arc (corner). It was G03 (CCW) but I,J (K) or R?

I’m pretty sure it was G03 I,J. The Gcode was generated by MakerCAM and I think they only use I,J notation

It’s surprising that truncating numbers would create a perfect circle. I would expect a more segmented number of lines, but what do I know. Good luck with that one :-). If it does not violate laws, share the snippet of the corner, would love to read it and create similar scenarios to test.

The new forums let us share files! How great! :grin:

Here’s the file:
Two R1s.nc (330.3 KB)

I’ve been seeing it happen kinda a lot actually. I think the issue has to do with with the way the CAM program is generating the gcode. It’s pretty common for the CAM to throw in sections of arcs that are basically zero length so the starting point and ending points are very close. By rounding the numbers the starting and ending points end up being exactly the same which results in a full circle.

I bet that we could figure out how many places we really need and truncate there. The issues we were seeing before happened when we were getting like ten digits after the decimal from MakerCAM in metric mode, right? We could probably just change the default to truncate to maybe 5 places and get the best of both worlds?

1 Like

All I can say for now, the gcode is not the issue. I could swear that a bug cant cut a perfect circle. Camopticts and bcnc show no circle. That corner is at line 1135, 1317, 1499,1645, 1875, 2065, so you are cutting in 6 passes. All are identical with a staring point at X30.019 Y12.8679 and a ending point at X30.9619 Y14.9094. I see is that we have 2, 3 and 4 digits behind the decimal in the code. How much are you truncating on 4 decimals? Will just cut that arc in the morning.
Edit: The suspect:
G3 X30.019 Y12.8679 I0 J1.4736
G3 X30.2424 Y12.9271 I-0.2162 J1.2669
G3 X30.4515 Y13.0253 I-0.4396 J1.2077
G3 X30.6549 Y13.1686 I-0.7438 J1.2721
G3 X30.8314 Y13.3441 I-0.9472 J1.1288
G3 X30.9644 Y13.533 I-0.98 J0.8315
G3 X31.0615 Y13.7426 I-1.1131 J0.6426
G3 X31.1252 Y13.9831 I-1.3875 J0.4964
G3 X31.1476 Y14.231 I-1.4512 J0.2559
G3 X31.1476 Y14.238 I-1.2852 J0.007
G3 X31.1281 Y14.4612 I-1.2852 J0
G3 X31.0677 Y14.6842 I-1.2657 J-0.2232
G3 X30.9619 Y14.9094 I-1.3819 J-0.5116

1 Like

@bar, you can choose the number of digits to truncate, at the bottom of the advanced settings frame.

1 Like

I just starting cutting things today and was seeing some random small circles cut and some strange behavior. Is it possible to manifest in this way (see photo). They seem to be put randomly and not necessarily always in corners or where it’s changing direction quickly.

Notes:
Yellow arrows = random small circles
Red arrow = Appears to be a large circle which cut off the bottom of the H

A short-term fix would be to go to ‘Settings/Maslow Settings/Advanced Settings’ and turn off ‘Truncate Floating Point Numbers’. I think that should make it cut without the mystery circles.

Changing this setting solved the problem for me.

3 Likes

I recut both pieces after turning off “Truncate Floating Point Numbers” and they both cut without the random circles.

Thanks for the tips!

2 Likes

Just making sure I’m on the right page here. The circles were/are sketch construction remnants for arcs. I’m asking because “Turncate Floating Point Numbers” sounds like it would tell the software to ignore those construction lines. Doesn’t the computer see an arc that has a 2’ radius and travels 120° still a complete circle to the computer. It just only displays 120° of that circle.:thinking:

That might be the way that some programs work, but gcode actually only sends the section of the arc that’s needed. Specifically it just sends the starting point, ending point, direction of rotation and radius.

The issue we were seeing was showing up when an arc of length basically zero was sent. Truncate floating point numbers was rounding the starting and ending points to the same number, which was resulting in a complete circle

3 Likes