Issues Calibrating with Maslow 4 Attached to Concrete Floor

Hi, I’m running into an issue when trying to calibrate my Maslow 4. I worked through some minor issues getting the cable cassettes to retract successfully, but now I’m able to retract and extend the cables smoothly.

I drilled holes in my garage floor and installed some drop in anchors. I followed the advice of the installation guide and my holes make a rectangle ~ 12 feet by 8 feet.

I updated the maslow.yaml file with my measurements like this:

I am using a standard 4x8ft sheet of OSB board in the center of my bolts during the calibration phase. Soon after starting the calibration the sled slides towards the bottom (towards the power cables) and then pulls itself off the edge of the board. Did I miss a step to define where my board is or how large it is?

Thanks in advance.

1 Like

Excellent work, that sounds like really great progress!

I think that the issue here is with the value for Maslow_calibration_offset. The default value of 500 means that the corner test points will be 500mm in x and 500mm in y from the anchor points which for a larger frame like that means that they are ending up off of the wood. I think that a larger number like 900 is probably going to fix that.

If you want you can measure from the anchor points to the corners of the plywood and then add a little bit to that to keep the sled on the wood.

I think that rather than having people measure, once there is a very basic
calibration, let the user drive to the 4 corners and then set those as limits
and finish the calibration.


That is a FANTASTIC idea.

We could use say four calibration points in the middle of the sheet to get a rough estimate for the anchor point locations and then we would know where to position the grid.


This is exactly the kind of reason that community feedback is so powerful. That’s 100x better than my plan :stuck_out_tongue:


Ahh makes sense. I was going to start playing around with the various configs, but figured I’d ask first. I should have some time tomorrow to play around with it some more. Thanks for the quick response.

1 Like

I actually had a few minutes so I updated the yaml and it looks like that’s all I was missing. Calibration is off and running without going off-roading. Thanks again for the quick response.

1 Like

What anchors did you end up using? I ask because I’m using my garage floor as well, but currently using the 3d printed version. Removable anchors sound much more solid.

1 Like

I bought a 12 pack of these anchors:

You will need a tool to set them:

I will warn that some of them didn’t want to set properly the first time (they ended up being too loose and pulled out of the floor). So if you do go with these I definitely recommend getting a 12 pack to have some spares. I’m not sure if that’s an indictment against these specific anchors or if I just didn’t do the best job of installing them.

There were no directions, but from reading reviews and item descriptions from similar anchors you are supposed to drill a 1/2in hole the depth of the anchor plus about 1/8in extra depth.

I have a couple anchors that are a little loose in the hole (I may have accidentally drilled out the hole too big), but they ultimately hold well enough. If they loosen up too much over time, I may go back and add a little epoxy to the hole. For the holes that I had to retry my installation on, I ended up wrapping the anchor in a couple layers of painters tape to make it more snug to the hole wall before setting the anchor.

My plan is to unscrew the bolts when I’m not using the maslow and I’ll 3d print some caps to cover the anchor holes flush to my floor to remove any tripping hazard and having to keep dirt/dust out of the holes.


@bar I ran into another issue during the calibration process. I’m getting an error: “Motor current on Top Right axis exceeded threshold of 4000mA, current is 4012mA”.

After getting that error, I decided to try and start over from scratch. I did a retract all and noticed one of the belts doesn’t fully retract now:

I assume that means there’s a tangle or bunch in that belt that’s putting stress on the motor, but figured I’d ask before disassembling the whole thing again.

Is that even the correct motor? The error says ‘Top Right axis’, but if I’m looking at it from the top of the router with the power cable down that would be the top left axis. At what orientation should I be looking at the router to get the proper axis positions?

1 Like

Nope, I fixed an issue with that yesterday. You are totally right that it was reporting the wrong axis.

The first thing that I would do is to try just pressing retract all again. Does it retract fully then? It can also help to extend it again and then retract again.

I was able to replicate this issue, I think it comes from increasing the current threshold for the Retract All. I will make a fix right now.

1 Like

I tried that originally and it still wouldn’t fully retract.

I decided to temporarily edit my maslow.yaml file and bump up my dimensions by a 1000mm to see if that would allow it to fully retract. That did the trick for that one cable.

1 Like

Can you give it a try with this version:

I think that this should (hopefully) fix your issue. The problem was that the same current threshold was being used when retracting the belts and when taking a measurement so changing the retract belts threshold was also messing with calibration.

Yep, that solved the issue. I was able to complete the calibration. Thanks for getting a fix out so fast.

1 Like

Absolutely! Thank you for the feedback.

It feels great to be finding and fixing so many things. I think that we’ve made more progress in the last week than in the last two months before that :grinning:

Assuming the concrete is in good shape drop ins require a lot of force to set properly. We use a 2lb (1kg) hammer to set them and even then they usually require 3 or 4 firm hits. They make a different noise when hit once set properly.

Also it is important to clear the dust out of the hole. Hilti supplies a blower bulb but a vacuum with the hose necked down enough to get in the hole is better. EG: tape a straw to the end of the hose.

1 Like

I did make sure to vacuum out the holes before inserting the anchors. The very first one I set worked perfectly. Had to redo a couple of the others though so I imagine I didn’t hammer it in hard enough. I’ll keep that in mind if I end up going back and redoing the slightly loose anchors. I was just using a basic hammer so I’m sure that was the issue.

Thanks for the info. I imagine if I had bought an actual brand name of anchor it might have come with some actual installation directions :slight_smile:

Much appreciated.

1 Like