Maslow Home Maslow Community Garden Newsletter

Left/right motors test fails, Z motor works

Hi all, and thanks for building and contributing to such a cool toy.

I bought a kit with Z-axis from @BenBurnett, and I’m having trouble with motor detection.

My test setup :

  • no load on the motors (chains and sled not attached)
  • alternative 12V 5A power supply, not the original one. Tried with another, 12V 4A, same results. Plugged in the Maslow shield :wink:
  • WebControl 0.94 Windows singlefile. Tried with Makerverse 1.1.2 first, could not find the motor detection, is it still there?
  • Tried with firmwares stock 1.28, 1.26, holey 51.27 and custom madgrizzle 101.25

From the logs after Action, Test Motors/Encoders :

13201.21: Sent: B04
13201.22: B04
13201.73: Testing L motor:
13202.75: Direction 1 - Fail
13203.78: Direction 2 - Fail
13204.28: Testing R motor:
13205.31: Direction 1 - Fail
13206.34: Direction 2 - Fail
13206.83: Testing Z motor:
13210.35: Direction 1 - Pass
13214.31: Direction 2 - Pass

No noise or movement from the left/right motors. The Z motor looks fine.

I switched the cables around, the Z motor works from every port (MP1 MP2 MP3), so I guess the encoders are OK. The left/right motors don’t work even on the Z port MP2.

Any idea what I could try next?

Thanks,
Bertrand

Thanks for reading the forums to see what issues other folks had :grinning:

I can think of two things to try. First let’s try plugging the each of the left and right motors into the z-axis port and running the test. That will confirm for us that there is nothing wrong with the motors or cables.

After that the only thing I can think is that there is something wrong in the settings configuration, although I’m not sure what that could be. If you aren’t worried about loosing calibration I recommend running Actions -> Advanced and restoring the settings to the defaults and wiping the EEPROM.

Have you had this hardware working in the past?

To clarify: the left /right motors don’t work in any of the ports, the z motor works in any port. It seems like a cable/motor or software problem.

I’ll try wiping the EEPROM, thanks for the suggestion. The guy who sold it to me had it working for a while, but hasn’t used it in about 6 months.

this sounds like a motor / cable issue. What shield do you have? Most shields have a pin connection pattern so the firmware knows what version it is and how to configure the encoders and motor direction. I’m not sure if they all do that and changing the firmware could be the issue (eastbay has a custom firmware version).

1 Like

I’m having just the opposite issue. Z-axis motor doesn’t work but the others do. I’ve reached out to @makermade where I purchased the entire package but to no avail; no response.

Whelp, I tried it again with a different USB cable and it works. Awesome! Thanks for your suggestions.