Ok so heres one that I'm scared to ask

So I got everything up and running I put the z axis on the temp sled so I can cut the final one. then I go to calibrate the bit and I got no movement I go over check everything all my plugs are good go to the back nope it’s plugged in good I go over and go to the actions button hit the test motors an encoders and I get testing L motor direction 1 fail direction 2 fail testing R motor direction 1 fail direction 2 fail testing z motor direction 1 fail direction 2 fail please tell me my 2 day old maslow that I haven’t even cut out the final sled is dead because I might just loose it if it is…

Check to make sure that the 12 V power supply is plugged into the Maslow board, and not into the Arduino. That is a common cause of complete motor failure.


It’s not I had the maslow going before I had even plugged the z axis in…

If I understand correctly, all the motors fail the ‘Test Motors’ in both directions.
Is the LED in the PowerControl board next to the 12V connector lit? If not, check that the blue LED on the power brick is lit and check the wall power cord. If the 12V LED is on, check that GroundControl is talking to the Arduino board - restart GC and look for something like ‘PCB v1.2 Detected’ and the version numbers for GC and the firmware.

1 Like

The good news is that when all three motors fail it’s almost always an issue with the board not having power since the motors are controlled by separate circuits having them fail at the same time is very unlikely :grinning:


Check the connections at the motors. I had a motor and I had put a zip-tie on that added enough pressure to just pull the plug.

Hope this helps - go back to the beginning. Check you have a green and red LED on the shield, check the connections at the shield, follow them to the motors check the connections there. Reboot the PC - connect - test

Thank you

Keep troubleshooting and I’m sure you’ll figure it out. If you don’t … Welcome to my world. A poorly placed clamp caused a chain jam and I fried my motor shield.

Thankfully, if yours is dead several members of this community sell replacement boards. I can confirm @Bee’s TLE5206 v1 is running beautifully. It was a fraction of the Maslow price and I was only down for 3 days thanks to FedEx and a solid human helping out.

Be prepared for the unexpected and disappointing. But don’t let them discourage you. When peers see you make something beautiful with a router, some bike chain and determination. It turns heads.

You got this.


Ok so let me first say thank you to everyone for trying to help me find out what was wrong. I would like to apologise for not getting back sooner but I got some help here and he pointed it out right away. It ended up being thisred cord I had all of my things plugged into my laptop, the maslow and the router. He said it’s not running all three at once so every time I turned the router on everything else would turn off and when I turned the router off it would turn everything back on. So in short I played ring around with myself checking everything over and over to make sure everything is fine when it was my being a ignorant idiot. I was able to make a test cut of my boss’s company logo and he loved it here it is it stands for lost coast custom creations. Then I got exited and made another cut, this time I went down got a small slab of rough cut pine slab and cut a salmon into it with gone fishing after I burned it and sanded.

Ok so that was all the good news now I’m running into the sled is not keeping up . I know everything is still working I ran the test motor and encoders button all fine there, but when I enter any file and hit go the z axis motor screeches at me. Now if I hit the home button the left and right motors screech… I can hit the stop button it all stops and then I can use the arrows to move the sled around just fine is it the g code is 30 inch a min to fast?


That shouldn’t be too fast. Was there any other settings that changed from before?

1 Like

No no change what so ever, I even tried loading the very last thing which what the salmon up and nothing. My z axis has a crazy high number on it and whenever I go to calibrate the z axis it just won’t move. I hear all three motors turn on but it won’t move up or down I again can hit the test motors and encoders button and all good but whenever I try to “play” any file, hit the home button I’ll get the sled not keeping up notification.


I have had a couple of things that mechanically stopped my z. One thing was the clamp on the base and the other was the top clear dust guard that slipped out of flush blocking it. “Squealing” a short time seems common for my motors as it is thinking (I call it thinking) and as a shot in the dark… When I was having a sled not keeping up error it was when I put in a “go to” gcode line that was not a z action. I do remember my motors singing and singing and doing no dancing when some of my attempts were dealing with the sled not keeping up error.