M4 Calibration Questions


I have a 12 x 8 frame with a centered 8 x 4 spoil board. I used 3600x2400 in the yaml.

The sled drives off the spoil board into air during calibration. It is worst top, left and right. The bottom is not as bad in that it only goes to the center of the sled where all the others go past center.

Is that expected? If not what should I look at?

It finished calibration and shut off here. You can see how far outside of the spoil board it is.

I don’t see that the calibration is computing after the sled finished moving.

I think that this is normal. You can change the value for Maslow_calibration_offset in the configuration file if you would like to move that point down a bit. A value of 500 (the default) means that it will try to put the top corner calibration point 500mm in X and 500mm in Y from the top anchor point which on a 12’ frame is going to be right about there.

You can tweak that number if you would like, but it looks like that is the correct behavior to me :+1:


I’ll give that a try. Thanks

Any thoughts on Why it quits and never moves on again. It stops where it stops, and the computer never gives any more response, even after Waiting for an extended period of time. I would at least expect to see that it is Computing. I am using a Mac with Safari if that makes any difference

1 Like

Yes, I think I know exactly why. I think that the calibration answer is appearing in the text box on the right, but it’s not scrolling down automatically to make it visible. That’s on my todo list to investigate and fix today. Try scrolling down in that text box and let me know if the answer is there :grimacing:

Edit: This has been fixed in this pull request and will be part of next week’s firmware update.

1 Like

The last thing it does is to shut off and never speak again. Until I do something.

Scrolling does not reveal any more. The last thing it says is computed target as a series of messages. Nothing about computing.

What can I try?

I believe “Cuurent pos:” is a typo in the calibration routine.

It absolutely is and that will be fixed in the next release also.

Darn, I thought we had an easy solution. Hmmmm.

I’m digging through the firmware tying to figure out what might be going on and how I can replicate it. Which browser are you using?

Something that is coming to mind is that maybe the computer going to sleep could be causing the message to not come through? Is that a possibility?

Edit: I don’t think that’s it.

Bar, i was watching video of calibration and i am wondering in vertical frame how much would being on an incline affect the calibration. I just ordered lumber for what i was going to build and even our parking spaces are not level. Seems to me it would affect with more weight on one belt vs the other. Wondering of horizontal calibration would be better?


Safari on a Mac. It’s running right now in Firefox on a Mac.

1 Like

I’m in Firefox on Mac too :confused:

There is something that I don’t understand that I am digging into right now which is that

Someone else pointed this out and I fixed it, but I’m realizing now that I never see this print during the calibration process. I see it in the code, and it seems like I should be seeing it, but I’m not.

Are you running both the latest firmware and latest index.html files from Releases · BarbourSmith/FluidNC · GitHub? (Just to try to make everything the same as possible)

OK, fixed this. I’m seeing the same things print now. I’ll try running through and see if I can replicate the issue that you are seeing.

No change.

Do you leave the “calibrating” dialog box open the entire time?

1 Like

I did, but I wouldn’t expect that to matter

I have to unexpectedly pick my mother up from the doctor, but I will keep trying to replicate it. I feel like I’m getting close.

No worries.

I have an old Intel Mac that has been set to never sleep so I dug that out and used it. It completed the process and gave me the results. Lots of repeating results in brackets. I will need to go decipher that.

I am thinking, maybe your first thought was the correct thought.

1 Like

I believe this, Mac got further into the process than previously. There is a message that states calibration complete. And then it goes into a bunch of bracketed results.

How do I know what firmware I have?

Do you have a screenshot? I haven’t seen that.

I’m glad to hear it, but I want to figure out what the issue was.

You think maybe the issue was with the computer falling asleep?

The easiest answer is to install the latest one and then you will know it’s up to date. Adding the firmware version number somewhere in the UI is on my todo list.

Was going to start a new thread but saw this one…

Can I run all the way to the edge of the board I’m cutting? planning to use standard 2400 x 1200 sheets

From reading other threads about previous maslows, I will need boards round the edge for the sled to run onto.

PS: Thanks for the calibration video :slight_smile: https://youtu.be/AE-2WHUTQm8?si=S17EZsVt7k1jkmdA

1 Like