M4 Calibration z height

So I was a bad boy and didn’t put my z-axis all the way down (in fact its near the top). I started calibration, and now I’m wondering if it is worthwhile to interrupt it and reset z, or just wait for it to finish then do it again with Z down.

I reaaaaaly don’t want to take it off the frame as I have it portrait and its 12’ tall and getting that thing on there was a bear :slight_smile:

1 Like

The calculations at the end will be a little off because that height is factored into them, but it’s not so bad that I would stop it. It should still be valuable feedback if anything goes wrong in the calibration process.

If it goes smoothly I would lower it and re-run tho before cutting things :stuck_out_tongue:

1 Like

I think that we need to work on making that step in the calibration process more intuitive (along with literally every other step :joy: )


it probably doesn’t caue much error, (unless it is trying to get especially
close to the corners where the belt angles will be the steepest compared to the
plane of the workpiece)

David Lang

wow, so that did not go too great. fitness 0.0068 something over and over in the output window… tablet disconnected so I can’t see the output anymore. The maslow is in the lower right corner, and jogging does not move it after a restart. how can I get it to retract the top belts halfway and start over without retracting everything again and getting this thing down from the frame, or is that the only way, to start from the beginning?

1 Like

Unfortunately the only way is to fully retract the arms :confused:

We can work on making it so that doesn’t need to be done so often, but right now there is a LOT of that

Roger that… out with the big ladder again, oh well

1 Like

Having some trouble here. I think the tablet I’m using has some wifi issues, so I’m thinking going AP mode would work better to get calibration done at least. I just got part way through another calibration and my tablet disconnected and at some point the maslow fan went off and was apparently stopped. when I reloaded it seems I’m back at square 1. I’ll reboot it all after setting it to AP mode, reloading everything from the latest firmware, etc and trying again.

I did notice in the steps it was taking that the lower left belt was always very very slack, and it never once tried to pull the slack tight. I am in vertical portrait orientation vs horizontal, so not sure if that is normal or not.

Also, assuming I get through the calibration, given how difficult it is for me to get this thing on / off the frame… If I’m updating firmware, will I have to re-calibrate?

That is not right, it should be pulling all four belts tight each time a measurement is taken. We should figure that out first because that is going to give you funky results. It needs all four belts tight at each measurement.

No, calibration should be a one time thing. Once we’ve established the XY coordinates of your anchor points unless those points move you do not need to do it again.

I tried to make the calibration sequence robust to losing connection. I think that there is some thing that happens with FluidNC where if the computer goes to sleep it sends out something which shuts down FluidNC. Closing the tab intentionally doesn’t do it tho so if you are worried about it you can start calibration, close the tab, wait for the machine to finish taking all it’s measurements, then re-open the tab and it will give you the answer.

OK, so I did start this over and now I’ve stopped it. it does not ever take up slack on bottom left. Thoughts on diagnosing/fixing this? That belt does retract all the way on retract all, and it did extend out on extend all, but “take slack” didn’t move it. I have my Maslow_Retract_Current_Threshold at 1800, but Maslow_Calibration_Current_Threshold at 1300… should I try again with that at 1800?

it takes a good 15 minutes for me to disconnect / reconnect this to the frame. I did build a little shelf to set the masolw on but the top right belt extended still does not reach the anchor point from there, so I have to carefully let it hang on the left top belt while I climb the ladder with the other belt in hand to attach it.

This is a good test since Take Slack uses the same code as the calibration process.

Can we try just running Take Slack with it at 1800? No need to put it on the frame, we just want to see that lower left belt move.

I must have an issue there. now it does not retract in retract-all either. I’ve re-seated the connections (ethernet, motor power) to that motor, restarted (unplugged and replugged) but its not reacting any more to retract.

1 Like

Will it extend?

It does extend.

1 Like

and now that I did that, I stopped, cleared alarm and retract-all did get it

I’m dubious if there is something wrong with that one…

1 Like

OK, I continued to pull the belts out a little, then take slack, but just that problem one didn’t take slack. BTW, I brought this back in my office so I can troubleshoot

1 Like

Is this at 1800?

yes, both are at 1800

1 Like

I think we should be fine to keep upping that number as long as we don’t let the belts actually hit something (IE retract fully).

That doesn’t seem right though, but let’s confirm that it’s a hardware thing and not a software think by upping that number until it moves in when we press “Take Slack”

1 Like