Maslow Home Maslow Community Garden Newsletter

Makercam SVG Import Resolution Setting Help


#1

First, special thanks to @madgrizzle and @bar for the calibration posts and benchmark test info. The fourth time was the charm for me on my new Maslow and its now dead on (2/6 +0.33). Patience paid off.

You’re gcode works fine.

I am drawing/designing on BiiCADo Pro (units = inches) on an iPad pro (264 ppi);
moving my DXF file to my mac (flash required) and then;
converting to SVG with convertio (have used two other solutions with the same exact results),
then importing into Makercam with the following results:

a 42" designed part comes up close to 3" onscreen (inches - yes :: at the default 72 SVG Import Default Resolution)

Changing the Import resolution setting gets me pretty close:
5.5 is too small, 5.4 is too big.
5.45 is pretty darn close to the 42" design

My number is a far cry from 72 or 90 and I can’t get my head around where the calculation has gone wrong and can’t come up with a number anywhere close to 5.45 multiplying or dividing into known numbers like inch to metric conversions (ie 25.4), 264 ppi, etc.

I would like to get the correct value mathematically if possible.

Thoughts anyone?


#2

PS
I did do a first actual run using the “Scaling” feature only at 1200% X & Y (thinking inches vs feet without checking the math) with the default import resolution kept at 72. Pushed the gcode to the Ground Control and the Maslow ran beautifully producing 4 perfectly scaled 38.25" pieces. (not 42"). Honestly, I was pretty proud of myself to see it run so I didn’t bother to check the production result until today.
(X and Y are off symmetrically. 42" is an X measurement).
Perhaps that’s meaningful…


#3

38.125"


#4

Life, the universe, and everything! I’m a little partial as I turned 42 this year.


#5

Have you tried converting the file to Metric?

from my experience I’d say Imperial to Metric is about 1 in 10,000. I’ve seen many issues working in inches. - FWW

Thank you


#6

Hitchhiker to accuracy :slight_smile:


#7

My temporary fix as follows:

I used the makercam coordinate tool (the arrow with the circle at the tip), and took the measurement between two known points after I imported the SVG.

point one x=1.2201 inches
point two x=4.4017 inches

Distance between two points = 3.1816

I wanted 42" so…

3.1816 = 42


100 New Scale Factor

4200/3.1816 = 1320.09

I punched 1320 into the scale factor and it regenerated to 41.998".

Voila!

I’ll keep trying to see where it is really going wrong.

@TheMerryYeoman - 42 was a good year, enjoy!
@Bee - I’ll try it in metric and report back.
@Gero - Thanks for the props. My third try I was off over 30mm total.

If at first (second or third) you don’t succeed, try following all of the directions!


#8

Not sure I fully understand your issue.
What happens when you go directly into Makercam.com, make sure you set it to inches and draw a 2" x 3" rectangle.
Then you make a profile operation, export it to gcode and cut it. What are the sizes you get?
If you don’t get the correct sizes (correctish) then it’s either the makercam settings or it’s the GC settings.
If it is close then the little offset is calibration and the large offset originates from the programs you are using before entering into makercam.
I hope that gives some food for thought.
Tschöhö
Guido


#9

Thank you for the ideas.

Inputs in makercam directly are correct.

If I draw a rectangle in makercam, inches and then metric, 72” x 24” and then 1905x600mm (yes-cm). They both come out perfect.

Its probably my cad settings. I don’t suspect it’s the converting program.

If I draw a metric rectangle in my cad, same measurements as above, it converts very small when I import the svg file into makercam.

In metric, I needed a makercam scale factor of 283.46 to bring back to size.

In imperial I needed a makercam scale factor of 86,435. Much higher than the 7200 I was previously using.

Difference between the two imperial designs, one was designed in feet and the other in inches.

The scale, x vs y is always correct no matter what I’ve drawn, so I am now testing the differences in units.

Ie Decimal/Architectural/Fractional/Engineering. I can also set the precision, in decimal places, 4 would be 0.0000 for example… still trying.


#10

It is possible to build/install Inkscape and LibreCad via macports onto your Mac. Both programs can import DXF and other formats. If you export the SVG out of Inkscape change the px/inch settings to 96 and not 90 as indicated in Makercam and it should maintain scale.

As @Gero mentioned the website has not been updated for along time.

image


#11

Thank you. I will try it.


#12

You should probably use http://maslowmakercam.000webhostapp.com which is the latest fork of makercam with the newest metric decimal place fixes, and not makercam.com :slight_smile:


#13

Tried it and will continue to use in the future.

Thank you for the link.

Imported part still same result.

48” part imported to 2/3”.

Still suspect my Cad parameters…

All ideas welcome.


#14

hmm. can you share a dxf and a svg created with your workflow, along with the expected dimensions?


#15

There are two online Gcode generators that can work with .dxf directly, both are considered beta still but also may work and are free,

Openbuilds will just open directly in the browser.
https://cam.openbuilds.com/

Inventables Easel you will need to register, but is free to use.
http://easel.inventables.com


#16

Try this…

Limits are 4’x8’

Top of piece is 4’ wide.

Height is 3’6“

Disregard the “L” in middle. I use it to align the workspace/material when I am defing home.


#17

Openbuilds gave me the same import, so still looking at my cad / settings.

Thank you for the link.


#18

link expired on the dxf…

you can just upload them here to the forum…

by the way, the svg units are in points for some reason, you should set them to in, and see if the size problem is fixed

example: the svg you posted is this:

see that “width=“595.276pt” height=“841.89pt”” there in the top? change that to “width=“595.276in” height=“841.89in”” and i’ll bet your problem goes away.

edit:
Apparently the forum software is stupid and wont let me post the raw code to a svg, even if it is set to “preformatted text”, it shows up as an empty block grrr. so i’ll have to embed images of the text rather than actual text :frowning:

here’s what i get if i take that edited svg and open it in makercam:


#19

@Jatt Thank you for the reply.
That make sense. I’ll try to recreate and find out where the source is originating.