Maslow Home Maslow Community Garden

Makercam scale issue


#1

Ive been using makercam with no issues, until now. I have always used CAD to illustrator to produce the svg file. Never a problem, but now I cant get it to work. No idea why.
I create a file that is n the artwork sheet to the size of the sheet, save as svg (as always) but when I open it in makercam its out of scale. Its square and a little over sized. I’m working on sheets of ply so1220x2440mm.
No idea why this is happening, even when I open a svg file from the past it is fine. So settings havent changed on makercam.

help - going mad here !


#2

If it’s off by a factor of 1.33 (either too small or to small) then its probably a pixel/inch setting issue. In makercam, under Edit->Preferences you can set the SVG Import Default Resolution (px/inch). I think it defaults to 72…


#3

I agree with @madgrizzle’s diagnosis. I have found 96 to be the correct value for me


#4

Cheers guys for the input, however this doesn’t seem to have made the dif. The default is 72 and I tried 96. It still comes in square instead of rectangular.
I even loaded the old svg which came in correct. As you can see in image hope it works.
The only thing I can think is that some setting as changed in my illustrator file and or export settings (but no idea how)
Considering that I exported the correct file on friday and it stopped working on saturday, I’m rather baffled.


#5

This may not be related but i was getting an issue where my imported svg files in makercam were oversized and it was down to the svg setting of decimal places. I had to increase the default setting of 1 to 3 to fix. This was using adobe illustrator.


#6

Unfortunately that also didnt work.
Really weird. Ive had a friend try it too (who has done it before in the past) and he couldnt do it.

I was wondering if anyone on here could have a quick look to get it turned into svg if possible for me.
I would be eternally grateful.

1800MM TABLE CUT FILE.dxf (381.9 KB)


#7

I don’t understand why the work-path .dxf to .svg. Going to from a real CAD to a vector an then to a vectotor reading tool.
In bCNC your .dxf looks almost perfect and the g-code would be as well.
Is that a metric inch issue with makercam?

The moves when Z (the cutter) is out of the material is terrible and will more then double your cutting time.


#8

Thanks for looking at this. Think I get what you mean.
Its all really strange isnt it.
It should be a simple enough process from my opinion.

Not sure why I cant get standard svg into the makercam, since saturday, the older svg files (few months) work fine.

Worried to see the double cutting time too


#9

What I will try is to load the .dxf to qcad and libre-cad and see what i get with exported .svg in makercam
Will take a moment.

Easy to fix


#10

Thank you so much


#11

Not much help.
First thing I noticed is in all programs the sheet is ‘upwards’.



The SVG-export from Libre-cad shows in the correct shape in makercam, but upwards and far to big, could be wrong mm-cm conversion.
The export from q-cam dosn’t load in makercam

Edit: I noticed all the layers! Perhaps trying to bring them to one before export?

One more edit: I’ve rotated it in Libre-cad, moved it so the centre is near the x0/y0 and then exported it again to .svg. In makercam i did not change any setting, loaded the file and then changed inch to cm.
If the grid is 10cm, then this looks correct


Notice the ‘Blocks’ comment during export:
image


#12

Ah ok interesting
In the past Ive used a few layers but not as many this time.

So Ill have look at that when I get back from work and have a go.

Thanks for looking at this.


#13

oh wow, you’ve nailed it.
I don’t have libre-cad, but will def try get it.
Would it be possible if I got that svg file off you? was hoping to get to it this evening.

Cheers


#14

Is this all one depth? Are those drilling holes? What is with the overlapping parts on the legs???
Material thickness? Spep-down per cut? Feedrates? 2 many questions and 2 many beers + girlfriend should arrive any minute. Guess I can’t help, at least not tonight. Sorry :frowning:

Edit: Oh the svg, not the g-code :-)? :beers:
1800MM%20TABLE%20CUT%20FILE-rotate

Edit: 1800MM TABLE CUT FILE-rotate.svg.zip (4.6 KB)


#15

You Sir are a gentleman and a scholar - I owe you a beer. :beers::beers:

Cheers


#16

A ‘warning’ is here Advice for Metric use of MakerCam (but also cool for imperial off-grid workshop)

If you run the maslow with the code form makercam in metric, test on scrap, once with ‘truncation turned off’ (default) in GroundControl and once turned on. It would be cool if it runs with the default settings but if there are issues, it would also be cool to know if our ‘truncate switch’ works as it should. If both fail use local makercam version.


#17

ah ok cool, I’ll def download the makercam offline version.

Not sure what the truncated means, youll have to explain that. But ive cut stuff on the maslow that went from illustrator to makercam to gcode before, so we’ll see if thiss svg file does the job (tho need it right as I dont have spare at the mo lol)