Hello everyone,

I’m encountering a few problems on my Maslow CNC.

I’m trying to test my Maslow CNC and I’m struggling a bit, despite a few promising tests I encounter precision problems.
I recalibrated the machine, but ever since I did the Z axis is kind of broken.
After starting a cut, the drill retracts itself until it hits the stop and continues to retract until the security is engaged.
Ever since, the engine still works but is making a noise that worries me.

Moreover, the motors are failing the “motor/encoder test”, but they seem to be working properly.

Any help would be appreciated.

Thanks in advance.

I think this is where we should start. Until the tests are passing the motors might move, but they won’t know where they are which will lead to the behavior you are seeing where the z-axis runs into the top.

Do all three motors fail the test?

Yes, the three motors are failing the test, except the left one which passes the test once in about 10 tests.

Is it normal that during the test the motors are only vibrating and not running ?

During the tests I’ve done the chains sometimes entangled in themselves and blocked the motors, could that have damaged the motors ?

Prbbly You didn’t destroy motors :stuck_out_tongue: I’ve done more stupid thinks to test them xD
Ok. Lets get to point.
Is it your first setup of maslow cnc?
In this setup there is possibility to swap motor direction and encoder direction.
To test that, run arudino IDE and start serial monitor. Open encoder case and rotate encoder by finger and watch the monitor. Is there any reaction?

Its safe test for motor encoder. Do photo of your encoder disc.

Thanks for the answer !

Yes it’s my first setup, I’m a total beginner.

Could you give me some specific instructions about the procedure to open the encoder case ?
Is this picture ( the kind of thing I’m looking for ?

hah, Maslow got much simpler encoder. It’s connected to the end of motor shaft (on top of your motor). Prbbly round black cylinder. There You can find black magnet that rotates and board with hall sensors. This is your encoder. Rotate that magnet by finger while watching serial monitor on Arduino IDE.

Result will be obvious :slight_smile:

Hello, I tried to test my motors just like you said. As soon as I open serial monitor, loads of text are appearing in a continuous way. Rotating the encoders don’t change anything. I added pictures of what I see on the screen.

Ok. Change bound rate to prbbly 119200 :stuck_out_tongue: or try luck to find good frequency in Arduino serial monitor.
Then You will get readout :stuck_out_tongue:

So I tried the 57600 baud rate, and I got a more plausible read out of it. But I still have no result when I rotate the encoders. I joined the result I got.

Ok. Rotate other encoder… the one that works once :slight_smile:
No changes mean there is no encoder connected :smiley:
Swap cables on board and test if it work on other slot. This way you can conclude witch cable don’t work.

I tried every encoder, without any results. I’ve also tried to change the slots where the cables are plugged, and never had any results.

Okay so I managed to have a result with an encoder. I switched cables and the other encoder worked, but the first one didn’t work anymore. Would that mean that the problem is cable related ?
I struggle to understand why the motor that works doesn’t pass the test. Do you have an idea why that could be ?
I have quite an extreme idea, would cutting the plugs off the cables and soldering them directly on my motors and the board work ?

check your cables with an ohm meter to make sure the cable wiring isn’t broken.

1 Like

I verified the cable they work . But maybe it came from the connecting ?

It’s possible the motor controller shield is damaged. The encoders, however, are basically wired straight through to the arduino so you should see encoder movement if you can move it by hand. Can you post a couple of good pictures of the motor controller shield (top and bottom… you’ll have to remove it from the arduino to get a bottom picture).

Here are the photos of the motor controller shield. It seems that the shield heated up until it was damaged.

I don’t readily see anything fried… and since the heatsinks are still there, I assume the chips under them are still there (there’s a failure mode where the chips fall off the board).

I assume you have a multimeter since you checked out the cables. Can you hook everything back up and make sure you get +5V and continuity to ground on the three connectors on the motor controller… follow this schematic (the part in the top right):

Ok so I checked the 5v and it works, but could you please be more specific about the ground continuity test ?

Just that the ground pin on the connector has continuity to the ground on the board… that way you know its not a power issue.

I went back to re-read some of the posts…

No, its not normal. The motors should turn one direction for a second or two and then turn the opposite direction for a second or two. During the test, the software just runs the motors at full speed and it should be smooth.

At this point, I’d say hook everything back up and redo the test motors/encoders… Lets first try to get the motors to turn properly. It still could be a bad controller board, but we’ll see.