Maslow Home Maslow Community Garden Newsletter

Z-Axis moves whenever router sled moves

I initially posted this issue back in May under a related troubleshooting thread, but I ran out of suggestions (and stepped away from the Maslow for a few months in frustration) and now I’m ready to try again…

The problem - during the initial calibration pattern test cut (starting at sled centered), the Z-axis motor initially raises the bit about a quarter inch as expected. However, when the sled motors engage to move sled to upper left corner, it also turns on the Z-axis motor to raise the bit further (and further, and further) until it shears the orange tab.

If I turn off the Z-axis feature everything works fine (sled centers, initial calibration cut as expected). During the initial calibration with Z-axis motor enabled, the Z-axis seems to work fine when raised or lowered and define zero appears to work. However during the calibration pattern test cut, the Z-axis motor runs whenever the sled is moving. As sled goes from center to upper left during initial calibration test run, it continuously runs Z-axis motor until the orange tab stop “tops out” (and get’s chewed up). In other words, when the sled motors engage to move sled to upper left corner, it also turns on the Z-axis motor to raise the bit. So while sled moves up to left diagonally, the bit just keeps raising until it “tops out” the worm screw after about 15 seconds. It’s like the Z motor is somehow being turned on by GC turning on the sled chain motors.

I’ve run through the calibration process multiple times (replacing 3 chewed up orange tabs so far) and everything seems great until initial calibration run. Other than the brass bushing to extend the worm shaft, it’s a stock Z setup and I’m using 1.26 GC. I’ve also tried previous suggestions from Gero and Diang. I’ve isolated the Z access control cable to avoid any potential of cross talk. I’ve also tried removing log files, in fact I tried removing everything on PC (factory reset) and Ardino and starting over. The fact that it still happens with a complete software re-installation from scratch has me thinking it’s hardware, not software. Any suggestions?

see if you can get a replacement motor shield perhaps?

What happens if you press the Actions -> Test Motors / Encoders button?

When I test the motors, the z axis motion tests work fine. However, when I test sled motion the sled moves as requested, but whenever the sled moves it raises the z axis at the same time. For example if I test motion to right, both sled moves right and z is raised at same time. When it finishes right motion the sled stops, but the z continues to raise for about a second after sled stops. Regardless of how sled is moved, z is raised during sled move.

If the tests all pass then I don’t think this is an electrical or hardware issue, it sounds like software to me.

Here’s what I would test next. Open the z-axis menu and set the zero position. Confirm that the digital readout is saying that the z-axis is at height zero. Then use the buttons in the z-axis window to move the z-axis up and down and check again that the height in the digital readout matches what you commanded.

This will confirm that the z-axis motor is behaving the way we would expect it to when isolated from the other two motors.

If that doesn’t work then I’m back to thinking it could be hardware and I’ve got some other ideas for what we can test.

have you tried wiping the arduino and re-flashing it?

David Lang

My original tests of Z-axis were based on worm drive motion. When I asked it to raise (or lower) relative 0.3 inch it raises and moves bit what appears to be a third of an inch in correct direction… The motor moves the bit up/down as expected when sled is stationary, so I considered that “Passing”.

However, I missed the encoder test results. When I do the Test Encoders, left and right motors each PASS in both directions, but both Z-axis directions FAIL.

One other interesting behavior. When I ask Z axis to raise or lower 0.3 inch, Z motor spins for about 15 seconds (as expected to move the bit that far). When I ask Z axis to return to (absolute) ground zero it ALWAYS lowers for about 2 seconds - regardless of where the z-axis is currently positioned. In other words, the sequence “Define Zero”, "Raise 0.3 inch (spins up for 15 seconds), “Go to Zero” (spins down for 2 seconds), repeated “Go to Zero” clicks (each spin down for 2 seconds).

And just to be sure I removed and re-inserted Z-axis cable and confirmed it is firmly seated on both ends.

I’m not sure what it means that motor correctly moves Z-axis up and down, but Z axis encoders both fail. I also don’t know how that ties to main problem - every time sled moves, Z axis is continuously spinning to raise the bit whenever sled is in motion.

1 Like

try swapping cables at the controller, see if the problem is in the cable/motor
or in the channel on the controller.

David Lang

Not sure I understand the request to swap cables. I’ve already tried swapping the two motor cables right for left, but that doesn’t change anything. I didn’t think swapping the Z cable with a motor cable was an option - isn’t the Z cable a different size (longer cable, smaller plug) than the motor cable?

on the controller side, all three are the same.

David Lang

Per David’s suggestion, I swapped one of the motor cables with the z-axis cable and tested encoders. The FAIL message switches from the z-axis to the motor, so I’m assuming that means it isn’t the z-axis motor or cable that are failing, but the channel on the controller. When I restore the z-axis cable to proper connection both motors test fine, but z-axis encoder test fails in both directions. I also tried wiping/reloading the Arduino firmware and both motors test fine, but z-axis encoder test still fails in both directions. However, when I ask GC to raise or lower z-axis, the z-axis motor works as expected even though the encoder test for z-axis fails…

1 Like

This sounds like a hardware issue with the z-axis motor to me. Great sleuthing to track down what is going on.

Who did you originally buy the kit from? I think the thing to do is to get them to send you a replacement z-axis motor.

If you are feeling ambitious and want to try to get a fix asap while you are waiting for the replacement motor you can pull off the black cap on the end of the motor and take a look in there to see if something is obviously wrong. A picture of what’s under the cap could help us to all make guesses.

@Dlang and @bar - Thanks for all the help and the troubleshooting recommendations. Bar, I’m not sure how you narrowed it down to the z-axis motor, the fact that commands to move the bit up/down seem to work fine would have pointed me away from a bad motor.

The kit was purchased from @MakerMadeCNC, so I’ll contact them for a replacement.

As for pulling the black cap off the z-axis motor, in my case that’s no challenge since I don’t think it has a cap. My z-axis motor just has a small round circuit board with a cable plug on top. My assumption was that was “normal” since that’s how it came, but maybe I’m missing a cap. I’ll send a picture this evening.

since the failure message moves to the channel that you have the cable for the Z motor plugged into, that means that it’s not the board, it’s something in the Z cable or motor

the fact that you don’t have a cover on the encoder for the Z motor indicates that it got banged around before you got it, and it’s very possible something is wrong with it.

1 Like

Per the suggestion, attached are snapshots of the end of my z-axis motor (after disconnecting cable). As I mentioned before, it doesn’t have an end cap. Since it didn’t originally come with an end cap, I never realized it was missing. The close up picture certainly makes it look dustier than it does to naked eye, it looks pretty clean until you zoom in for the picture. If anything appears broken from pictures I can give it a shot at fixing. I’m reasonably good with solder iron and precision soldering.



Oh fantastic! I think we can be pretty sure its the z-axis motor at this point then :grinning:

I would contact them about getting a replacement, the black cap which protects the electronics will go a long way to preserving the life of your motor.

The good news is that we might be able to get you up and running without even doing any soldering. Dust should be OK because the sensors use magnetic fields which can pass right through the dust. To me it looks like the issue is that the hall effect sensors which measure the magnetic fields have been bent away from the magnet. That’s these here:

image

If you can carefully bend those back up without breaking them off I think you might be good to go.

image

They should be close to the edge of the black disk without actually touching it. Post more pictures if you have any trouble!

1 Like

Bar -

Congratulations and thanks! It appears you may have found the issue, since it now “passes” the z-axis encoder test. I made progress on getting z-axis working last night based on your last recommendation. I was able to bend back the sensors, which was a bit challenging since one of the sensors was both bent and “twisted”.

One of the sensors (on the left in the marked up photos) appears to have a longer “cap” that extends down and leaves very little of the connection (mounting) wires exposed. However, the other sensor (on the right) has roughly 3/8" of the connection (mounting) wire exposed. That sensor was sufficiently bent that two of the three wires were actually touching. Not sure how that impacted motor behavior, but it may have contributed to original problem that started the troubleshooting thread (z-axis raised whenever sled moved).

I can’t actually raise/lower the router since my orange lock tab was shredded by the runaway z motor. The bottom line is it now passes z-axis encoding test, z-axis raise/lower each seem to rotate the motor as expected, and testing sled motion does not engage z-axis motor. I have to re-calibrate again (for what feels like the zillionth time), since my cable/controller swaps during diagnoses messed up calibration. Hopefully it will complete the “bow tie” test cut during calibration without chewing up another orange lock tab - I only bought 5 spares and I’m down to last one.

I’m really looking forward to actually using my Maslow to cut something!