Maslow Connection to Ground Control

My Maslow says I am connected in ground control but it does not run the Maslow for set up or calibration. I am connected to port COM3 is that correct or is it another issue, PLEASE HELP I AM DESPERATE!!!

did you plug the 12 V power into the top board of the controller? the USB will power the bottom board, but the motors run on 12 V and must have an external power source.

Is there a top and bottom plug in?? I am away on a trip now and will get some one to do that.
I think I plugged it in the bottom.

Yes. The bottom board should be the Arduino. The USB cable will get plugged into this. The top board is the motor shield. The 12v power supply should be plugged into this board.

Either way, the 12v power shouldn’t affect not seeing the board by GC. I have made this mistake (sadly a couple of times not really paying attention), but GC and WC still saw the board and let me connect to it. I just didn’t have any motor movement as they didn’t have the power.

When you get back, see if you can verify the firmware actually updated on the Arduino. Also, I think I mentioned this to you in another post, but GC is not being supported any more (I don’t know why it is still being used in setup directions). If you have the Classic Maslow (with the MEGA board, not the DUE), then WebControl has some nice features that I think will allow you to flash the board with updated firmware (though if the board is not being recognized, then this may be a moot point). @Orob @bar , am I wrong in any of this thought?

I took this to mean that GC WAS connecting to the controller but he wasn’t seeing any movement/response of the motors. maybe i misunderstood the problem?

For what its worth, I think WebControl with Holey calibration should be the baseline standard Maslow ecosystem OS. That’s just my opinion, which isn’t worth much

according to the manual, it is the default…

1 Like

… I gladly stand corrected

1 Like

I may have misread that and was still thinking he was not getting GC to connect. That is a very big possibility on my part, so I just wanted to make sure.

I am with both of you on this, but there are kits being sold with “assembly instructions” that say to use Ground Control, and then they end up here asking questions. I would have hoped those vendors would have kept up with what is current when they are sending out their links. I’m not saying it is wrong, but as GC is no longer supported, as well as issues you (@Orob) have fixed with WC and compatibility, I would have thought it would have become standard. Just my honest and humble opinion, I just feel there have been quite a few newcomers on here asking for help with GC (not as many as the other “new” software, but I will admit I am a little biased on that front).

1 Like

Back to the OP: @tliubakka were you able to get motor movement? Which kit did you buy? If you bought an M2, GC won’t work. If the controller you bought is an arduino mega, it must likely be programmed first before it will work, so it might connect, but won’t do anything until the firmware is loaded. I would refer you to the manual link above in my previous post, but scroll up and start at the beginning. If after checking power and firmware, you aren’t finding success, post photos and information on your specific kit and we will help further. All the best to you!

Thread hijack:

@c00nphrog yeah, me too. I wrote a good portion of the manual, so that is biased in and of itself, however, I can see why GC is still used. The reason it was falling out of favor had to do with the library deprecation and the lack of support for the newer operating systems. If Eastbay fixed it and it is useable, then it still has a place. As long as it is the recommended software from the vendors, it won’t go away.

Did the GC github get updated as well? If so, it might make sense to fix the calibration procedure in GC to be more like WC, so it is easier and then maybe we need the vendors to make a hybrid recommendation: standalone vs web based and recommend one based on the use model. Use GC if you are on a machine next to the maslow connected via usb and Webcontrol / makerverse if not and connected via the web browser. I think the holey calibration is the technique to use though for accuracy and all that theoretically can be put back into ground control if desired. I think as a new user, it was scary to stray from the path of the documented instructions at first because I was trying to get my investment to not be a pile of garbage. GC is simple and easy to use at first. Webcontrol has tons more available options, which become useful and desired, but may not be the best first experience… we are all jaded now because we are no longer noobs at this. The thing I like best about webcontrol is that it will flash the firmware with one button press, though I’ve never tried it on a board that was unprogrammed…

The main thing I like is that the groundcontrol.ini file can be imported into webcontrol and then it is ready to go and you can actually switch back and forth between them if you want. When I was testing out webcontrol, it was cool to realize that the calibration and position are in the arduino mega controller and not in the software, so as long as you have them both set correctly, you can use either one, though not at the same time. When I started, I was worried about losing settings and calibration information moving from one to the other, but that didn’t happen. I currently use makerverse or webcontrol: usually makerverse for tuning settings because it has easier settings access and webcontrol for cutting because I just like that interface and it works well with its z movement skip forward options.

As long as this movement is open source, people can and will do what they want with it. I have no right to tell the vendors they can or can’t do something. We could write up a user drafted maslow install guide though and offer it to the vendors and then that might help.

1 Like

@Orob It all makes sense, and I was informed in another post by @2cents that East Bay is maintaining GC (which I was wholly unaware of), so I will recant my previous statements that GC was unsupported. Like you, I don’t like to change just for the sake of changing, especially as I was learning the machine and how to get it to work/cut properly, but I was not a huge fan of GC. In my opinion (though I was a total noob and didn’t know a whole lot about anything), GC didn’t seem very user friendly, and the menu options for me was a bit confusing (though again, I knew nothing “John Snow”). WC came online around that same time, and I tried it out, and liked the interface so much better, that I made the jump and have been using it ever since. I like the access it gives me to update the different versions of the firmware, as well as some of the ease of use (to me at least) for getting everything set up and measurements inputted.

It would be cool if the vendors did incorporate the Holey Calibration into GC and Makerverse. It just seemed so simple to use and have calibrate the machine, and it turns out pretty accurate too (that is as long as you don’t miss a line inputting your measurements…but that is a different story!)

Ok, I think that is enough of a Thread Hijack…

@tliubakka Please let us know any progress you have found, and we’ll get back to our regularly scheduled broadcast!!

Not quite because I think this subject is relevant to OP’s original post and future posts regarding GC.

To be clear, I don’t think you were incorrect with your statements. Nor do I think @orob was incorrect with his. We should clarify that there are now TWO versions of Ground Control. The original GC developed by @bar and now the version that has been ported and is curently maintained by EBS. Since the original version is still available on the MaslowCNC GitHub for download and is STILL used by many in the community, we now need to be carefull of which version we are discussing. It is because of this that it is still correct to say the original version developed by @bar is depreciated and should be abandoned.

@bar can you test the new version and then update the one at the maslow CNC github to mirror it?

one of the beautiful things about git is that which copy is ‘master’ is a matter of convention, not anything in the repo, so in a case like this, we can just change which copy we consider the master and everyone will be happy :slight_smile:

1 Like

Well slap me silly and call me Susan!!! Again, something that I was not aware of, but makes absolute sense!

I know I have a tendency to point people to what I know works, and there were discussions on the forum that was stating GC was depreciated and should not be used. So I was getting a little concerned to keep seeing other users still asking about, and having some issues, with GC. With knowing that WC works, I was always pointing them to that. But knowing that there are technically 2 versions, and as @dlang has asked to potentially update the Maslow CNC Github to mirror EBS’s, then I think that would help me in my confusion (glorious state to be in…sometimes :rofl: :crazy_face:) and I may just look to try the new version again. It would be nice to have something to possibly fall back on if my RPi decided to take a dump on me again!

It seems like each purveyor of hardware has their own recommended control software at this point. I could try to keep up to date, but I’m not really set up to do the testing to make sure everything works right so it probably makes more sense to point people to where they got the kit for the correct software to use.

I’m looking to ESP32 GRBL for the future. It’s basically GRBL with a web interface similar to how web control works. That means no software to run on the computer at all other than a web browser which is nice.

1 Like