Maslow Moving Slower?

Maybe its because I’ve been away for a bit over a month in doing any cutting, but I updated from 1.03 to 1.09 and everything seems to be running “slower”. Motors turn slower, sled moves slower… Was there a change in GC that might affect this?

1 Like

Yes! We slowed everything down because some folks were running into issues when going faster…there is now a settings option to change the maximum feed rate so you can set it back to 1000 (default is now 700) if you want to go fast again

1 Like

I wanna go fast! Lol… glad it wasn’t me losing it.


Regarding speed, how does 700 or 1000 translate to inches or mm per minute? Is it 700mm per minute?


That’s right, 700mm per minute.
There is ongoing tension divergence between the desire to go fast because of concerns about chip load and heat, and the desire for accuracy in all parts of the workarea. The ‘speed limit’ has gone up and down with changes in these concerns and improvements to the firmware. At this time, speed selection is an art not a science.


Is this setting still there? I don’t see it in the settings in GC 1.25.

It’s in the Advanced Settings that are a bit hidden. Click on the grey bar on the title Maslow Settings to show a menu with the stuff you should not mess with :wink:

1 Like