Maslow stops while cutting out the sled

Hello and thanks for your help. It took a lot of trial and error but finally my maslow is calibrated and cutting. after following the tutorial here. I created the gcode necessary to cut the sled. the two brick tabs cut then at the second hole in the sled the computer just stops. the values for x, y and z don’t change at all even though it is clearly in the middle of the project. I am at a loss as to what to do.

I would upload the Gcode but it seems I can’t because I am a new user.

I hope someone can help, thanks in advance.

1 Like

A few comments, likes and post will get you over that soon.
Do you have dropbox/gmail drive or so to upload?

Edit: It always helps to know the versions of GroundContol and Firmware you are using.
In your GroundContol folder there should be a log.txt that can give more clues and find out what is happening. If you are familiar with VNC you could also record your screen if you can replicate the error. Don’t worry, with the crazy folks here this should be sorted soon.

Edit2: I forgot the WELCOME! Sorry for that, kindly accept my apologies :frowning:

1 Like

the new user restrictions go away after a day or so.

1 Like

Did anyone ever try that pizza pan for the sled I can’t recall who said it but I’ll look

Thanks for the replies. Here is the Gcode.

I am running
Ground Control 1.11
Firmware 1.10
Ubuntu Linux 16.xx

Here is the log.txt.

I was having issues with getting disconnected every time I turned on the router but that seemed to be fixed when I put the router and arduino on different surge protectors.

I am having issues with loosing connection still randomly and when I pick the port and reconnect the port that is selectable for my device interpolates between dev/ttyACM0 and dev/ttyACM1.

I don’t know if any of this helps but I appreciate the assistance.

Edit: Thanks for the welcome!

1 Like

The gcode file looks fine. Does the log.txt file come from the session when the failure happened?Im the log, it looks like your z-axis isn’t operational. Did the problem happen when you were expecting a prompt to move the z axis?

I’ve run the complete gcode file (without a bit in the router) in manual z-Axis mode, and all went well.
I wonder if we need to look at the PC running GroundControl. Others here on the forum have more experience with GC on Ubuntu but I’m pretty sure GC has been successfully used on that platform. Was the PC running any other applications at the time? Did the screensaver kick in? Did GC show ‘lost connection’ when the failure happened?

It is good to know the G-code is good, thank you.

Both times it stopped was upon the z access pulling out of the second hole on the sled, so I could see it being z access related. How would I make sure the z access is setup correctly?

Thanks for the reply, The ubuntu install is stock, installed onto this computer for this purpose alone. I had a browser open while running it I think but I wasn’t actively retrieving pages. I am not sure if that log.txt is from the session where I was having the issues. It happend to me twice and the second time is still currently paused.

Your z axis is manual, not motorized, yes? For manual mode, there isn’t any setup other than having the setting for Z Axis Automation ‘off’.
Could you try quitting GC, delete log.txt, clear the terminal scrollback and run GC, doing the cut up through the failure, then post the log.txt and the contents of the terminal window, particularly the last 200 lines or so? There might be info about the failure in there.

Sure, I will do that tomorrow. And no, my z access uses automatic.

If you have a manual Z, then when it goes to make a Z change, it’s popping up a
window telling you to change the Z and click continue.

you may be missing the window (it may be under the main window)

Doh! I guess I assumed that the z-axis was manual because I saw it fail the motor test for both directions. Check that the connectors are well seated, run the TestMotorsEncoders a few times to see if it fails intermittently. It could be that GC is waiting for the z-axis to reach its destination and the motor isn’t responding.


I am running it now this morning with no bit and no power to the router. So far so good.


OK I got the sled cut today!!! I think it was a loose cable on the z-axis motor. Ran the whole project with no technical glitches.

However now the issue is that the router didn’t cut deep enough. I set the z-axis zero by pushing the router all the way against the wood and then lowering the z-axis until the retaining tab clicked in to its slot.

If anyone has any tips for that that would be great.

Thanks for all the help.


That’s great news!

I always set my depth of cut to be about .05 inches more than the thickness of the wood to make sure it goes all the way through.

Having something provide pressure to keep the router down helps too

1 Like

Hey, thanks for all your support. Do you mount the router to the new sled in the same way we did the temp sled? That is to say the plastic ring from the router will still be on the bottom?

If I’m understanding correctly you should take the plastic ring off of the bottom. The wooden underside of the sled will be in direct contact with the wood you are cutting.

1 Like

Even on the temp sled

1 Like

Yes, I took the plastic sled off my router before mounting it to the temp sled.

1 Like

cool, thanks for the clarification!