Maslow Home Maslow Community Garden Newsletter

Loses the chain length and can't find where the sled is

So I just got my Maslow built and started to cut the pieces for a new sled and it worked fine for about half of the pieces then it just cut off to the right side in the middle of a piece. every time I turned the system on it though the center was someplace off to the far left corner and I could not get it to change. I did a whole new calibration and the system started to work, but it went weird again and cut a line to the top of the workpiece.
Does anyone know what my problem is?
I am using Qcad, Cambam, CAMotics, and Ground Control v1.26 with firmware 1.26.

I think I’m getting confused here. Do you think you could post a picture by any chance?

0909201805.jpg
The first time it was cutting a tab and it just went off to the right.

0912201613.jpg
the second time it was cutting a straight line and just keep going.

This seems to me like it’s most likely to be an issue in the gcode. Do you think you could share the gcode file with us?

gcode attached

Final Try.nc (43.4 KB)

I ran the gcode twice and it failed in different place each time

If you’re using GroundControl make sure your computer isn’t going into sleep mode during the cut.

nope sleep is turned off and always plugged into power.

I have had similar problems in the past. My system would lose the connection with the computer through a static discharge from the vacuum hose or from me touching the machine. I put cable ferrites on the data cable which helped but not 100% of the time. What helped the most was breaking the cutting operations into smaller gcode procedures and drilling a hole at a master reference point that I could reset the chains and move the sled to that location and restart the Gcode again. I recently transitioned to a R-pi web server with a short cable with ferrite core between the arduino and the pi. I don’t have enough experience with the server to say if it has helped or not. Lastly be sure that the electronics are on a different electrical circuit from the vacuum and mill. Maybe put a length of heavy copper wire onto the frame and connect to the foundation or ground. I also suggest searching the forum for electrical noise considerations.

1 Like

so, me being new to this, when it loses it’s usb connection how so I get the system to know where the cables are at?
I have been going through the set chain lengths - automatic and then it can’t find the correct center of the work surface so I can’t restart the job it won’t cut in the same place.

If you create a reference point, for instance a Gcode that drills a hole in the work surface and call that point home and start all of the gcode procedures from that point, then if the machine loses it’s position all one needs to do is center the sled by resetting the chains, move the sled to the reference point, call the point home and start the procedure over. Does that make sense?

yes thanks

Maybe one of the encoders isn’t talking to the controller properly. Do the tests pass under Actions -> Test Motors / Encoders? It could be worth unplugging each motor on both ends and plugging them back in.