Maslow update and calibration feedback with V 0.71

Finally got a “successful calibration” late last night. Here are a few observations and questions:

  1. I believe that the order that firmware and ancillary files are updated matters. Could be in the instructions and I missed it, this would have saved hours. Is there a way to check the version running on the system, text on the UI or something? Maybe a quick version compliance red green or in the settings/description? There may be one and I’m ignorant. The first time I updated the index and yaml files first and then updated the firmware. The result was that it didn’t progress beyond the first phase of calibration, it calculated for a very long time (hours) the first go-around and I believe it timed out, but didn’t know that was the case. I jogged it to the left of the frame and the cables got tight enough to lift Maslow off the frame and emergency stop. Tried again a second and third gave me the you need to restart - know it is annoying message going to fix it ASAP like I got earlier. After re-reading a the thread that mentioned matching binary and index, last night I re-uploaded the bin and then updated the yaml and index files afterwards and it worked much better, got a full calibration on the books. A quick summary trouble shooting table of the failure modes and what one might trouble shoot might be a great resource for the next few cohorts of kits.

  2. The setup interface could be much more user-friendly. If the first thing to do is retract all, then that could be the only thing Maslow allows until it is happy, then extend all. At least once I was distracted by family and when I came back I made a mistake - so restart, disconnect, retract all, extend all, reconnect to frame… I really wished that I had chosen quick connect anchor mounts. Either way, getting my squats in.

  3. How do I understand how “good” the calibration is? It would also be really useful to have a visual que that Maslow has a successful calibration onboard. Also would be nice to update the users guide text, even if terse at some level so that folks know if their calibration was successful or if they are running into something like I did in #1.

  4. Assuming that we’re going to have to re-calibrate with new firmware updates, suggest that a discussion / walkthrough of the nominal use and calibration in the discussion about frames. I am so very glad that I didn’t go with the tall vertical option I was considering. Would have been moving a ladder back and forth and climbing over and over and over. I also would have prioritized quick release mounting points.

1 Like

as Far as recalibrating goes. Download and save your .Yaml File. Its good to have backups of this file. If it goes Corrupt, you just update the newest Yaml file with all of your current numbers. and re-upload it. This goes for updates as well. When Bar releases new Updates on wednesday, all you have to do is update the Yaml file with your good calibration numbers, and you’re all set!

1 Like

Excellent feedback!

Yes! Pressing the “Test” button will give you the version numbers for the index.html file and the firmware.

This is a good suggestion. We should throw an error automatically if they don’t match

This should be how it works now. Pressing any of the buttons out of order shouldn’t do anything. If that’s not the case I will fix that.

This is tough because it’s hard to know how good the calibration is. We have the fitness score, but it’s not foolproof. I totally agree with the value of having something like that, but we’ll need to work on figuring out a way to do it.

Absolutely not! Once you have good measurements of where you anchor points are you don’t need to ever do calibration again unless your anchor points move (like if you build a new frame).

Thinking I went back a step rather than forward - caused me to go back and restart. Just trying to think through visual cues. All nice to have, not need to have.

That is great news! Then only for frame upgrades. :wink:

1 Like

On second thought - this may be completely user error. I may not have re-navigated to the 0.71 folder when uploading firmware, it remembered my old folder from the previous update. Would still be nice to do a version compliance check to idiot proof.

1 Like

Yeah, I think that this is the key. If there is a way for it to be wrong and not obvious we need to fix it. I’ve made an issue for it on github so that idea doesn’t get forgotten

Maybe just a confirm dialog? I’d like to be able to run experimental UIs along with firmware that may not fully match version?

1 Like