Motor current on Bottom Right axis exceeded threshold of 4000

Maslow 4 Consistently producing this error when cutting in upper left at about 710mm, 410mm x,y from center, it also happened twice at 270y. So not very far to the upper left.

I’ve got a vertical machine, about 15 degrees, and the motors are not hitting the uprights at the point of the error. I’ve got 3/4" material so machine is up 3/4" from plane in which calibration was done. It seems sensitive to cut direction - this happens traveling left when in upper left and cutting .1" deep cut. The geometry here isn’t helpful, of the upper belts that is the one further from the work surface. But it’s not that belt that throws the error it’s the opposite. So what’s going on here? config:
Maslow_vertical: true
maslow_calibration_grid_width_mm_X: 1800.000000
maslow_calibration_grid_height_mm_Y: 700.000000
maslow_calibration_grid_size: 9
Maslow_tlX: -8.000000
Maslow_tlY: 2335.100098
Maslow_trX: 2991.000000
Maslow_trY: 2336.500000
Maslow_blX: 0.000000
Maslow_blY: 0.000000
Maslow_brX: 3002.899902
Maslow_brY: 0.000000
Maslow_tlZ: 100.000000
Maslow_trZ: 56.000000
Maslow_blZ: 34.000000
Maslow_brZ: 78.000000
Fitness was 1.0088

I read in another forum that calibration might be a cause but things are cutting very well and even restarting and following previously cut code 3 times.

thanks for the help!

1 Like

can you move the machine around with the arrows (joggging)?

did you remember to hit the alarm after powering it on?
how close do the calibrated numbers match what you expect from your frame?

David Lang

How does the tension in your belts feel? This error generally means that the belts are pulling too hard which could be a calibration thing.

Your calibration looks great though so my next guess is that the z-axis height might be off. You can reset it by lowering your z-axis all the way down so that it bottoms out and then pressing

Tried to measure frame bolts with laser measure - X dims are very good. The Y dims are about 16 to 20mm too big but then I’m measuring inside both bolts not center to center. The tilt to the left is pretty accurate, the TLX -8.

Jogging was working ok and cutting as well. I reran the same code in the exact same spot. I’m not sure I even thought about the “alarm” it let me move over to the home location and jog around an inch back and forth as I set the Z.

Ok, thanks, I never understood the Z-stop. But I did wind it all the way down with the bit out for calibration.

New problem. After taking it down and retracting the top left belt it is completely stuck. Won’t retract or extend, has about .5 m out. I’m thinking the motor gear is jammed. Does this happen? Was something maybe going bad on that top left corner while cutting and now the mechanics are out if whack?

What is the fix? is there a partial disassembly procedure?

1 Like

Is the belt stuck in the gear or is it just not rotating? I haven’t seen one get stuck without having something physically stuck in the gears. Does it move at all or not even a little bit?

So the belt is not in the gear, I can slide it in and out of the encoder like an 1/2” and the led on the encoder pulses.

The belts were tight when it was running but that’s kind of subjective. This over current lower right happened 3 or four times in a row at virtually the same spot. (Upper left of cutting area)

I did clean the sled bottom and reduce friction with graphite powder and it made it through one problem area and a set of cuts more inboard. All very well. But when it got to the upper left again (now 5” higher) it had the over current error like previous runs.

It was cutting along the edge of the material so the cutter was pulling / diving in and the machine was having trouble maintaining a straight horizontal line headed left. With the cutter half in half out of material at 1/8”
depth. (Error always happens going left) it was kind of swerving from the cutter load and belt elasticity it seemed.

One thing is… I get that the machine should stop at the over current event. But does it have to reset completely? Why not just pause and ask for user input with a question of “is it stuck on something?” Give the users a few tries before a full reset. Give us away to abandon the job but not have to retract the belts.

I guess I’ll disassemble the arm and see what’s up. I’m hoping I can come from on top and just pull the top of the uprights off and the router out. It is the top arm.

Part of what is going on here is after 20 belt remove-the-machine-and-retract-belts I finally dropped it. It was always hard to hold and kind of heavy given the reach needed to rehang the upper points. It has a crack in the sled where a z motor tried to slam through it. Also cracked the little clamping piece on the lower router clamp. Seems like a full rebuilt to access that. Just a heads up that the repetitive belt retract routine is not without consequence and the most significant pain point.

It was cutting perfectly and I couldn’t find any distortion or bent parts so I’m not sure it’s relevant to the over current issue.

1 Like

Here is the cut where it first had the error.

1 Like

anesbitt wrote:

I guess I¢ll disassemble the arm and see what¢s up. I¢m hoping I can come from
on top and just pull the top of the uprights off and the router out. It is the
top arm.

One thing that was pointed out is that the motor can be shifted slightly, if
it’s nearest to the center, it doesn’t mesh well with the idler and you end up
with more current needed to move it, so if you can shift the motor out towards
the encoder, it should help.

David Lang

1 Like

This is a great point. We should make it work that way.

This doesn’t seem quite right. It does sound to me like the error is being triggered by something going wrong, but I’m not 100% sure what exactly is going on. If you can get a video of it happening I think that could help a lot to diagnose what the issue is.

One option could be to lower your spoil board slightly. The performance is better lower down so you might find that having the sheet you are cutting not exactly centered in the anchor points might help

Ok a bit of a confession!!.. On disassembly I found the lower right arm (the one throwing the over current error) was not bolted together. The two bolts at the encoder were in place but I must have overlooked the 6 around the hole for the router. I suppose being unbolted would allow some strange behavior although it is all held around the router.

Upper left which was acting dead. The belt was doubled over for like 3 inches at about 2 wraps so making a lump. I’m thinking that didn’t have anything to do with it the motor playing dead but more evidence of problems retracting belts early on. The part that is concerning is that the double over part was invisible till disassembled.

When apart I turned the motor with pliers. It moved freely and on testing before reassembling it seems to have retracted ok.

putting it all back together… will let you know what happens

2 Likes

I’m curious about what ‘doubled over’ looks like/means… Twisted?

1 Like

Double over - so I mean in a ‘Z’. From the anchor on the spool it spirals / wraps around the spool. Well at some point it double back on it self and then back again in the correct direction forming a Z like lump. In this
Case it was about 3” of belt and the machine had been running with it so it was completely squashed with the doubling back of the belt squished to a hard 180 both ways. I’m not sure it actually affected anything but if that had been unspooled ever the machine would have instantly dropped a few inches.

1 Like

Another confession! On reassembly it looks like the arm sequence might have been wrong. I can t be 100% sure. Question is does that perfectly explain the over current error? I think the arm could have been one higher than designed, that would over tighten the belt if you are calculating the hypotenuse for the belt length. Dumb mistake if that’s the cause.

Looking forward could you guys come up with a help page with a simple check list for certain errors. I’d have been happy to trouble shoot the error myself but didn’t even know where to start.

A list the with a sequence. Like:
Calibration ok
Remounted on frame correctly
Machine not obstructed at time of error
Then Moving on to build problems:
Encoders all working
Belts healthy. Not twisting no fliped connection on frame, no miss wraps on spool
Arm stack sequence correct.

This seems simple to write now but that’s just because I went down the list till the last one turned up. (At least I think so)

1 Like

@Bar (or anyone knowledgeable) could you expand on this? Is this only true of vertical frames and is it due to reducing the effect of shallow angles on the upper two belts when near the top?

1 Like

Yes, and exactly. As you get closer to the top of the frame the force on the top two belts goes up exponentially. At the point where the router is directly between the top to anchor points in theory the force on the belts reaches infinity and the universe explodes. It’s an effect of gravity so it isn’t an issue in horizontal mode.

:joy:

1 Like

Bar wrote:

Yes, and exactly. As you get closer to the top of the frame the force on the
top two belts goes up exponentially. At the point where the router in theory
the force on the belts reaches infinity and the universe explodes. It’s an
effect of gravity so it isn’t an issue in horizontal mode.

actually (to be pedantic on this), as the belts get flatter you will have more
problems pulling hard towards the two anchors, gravity just adds to how hard you
need to pull.

in horizontal mode, you will have the two arms both hitting the verticals long
before you run out of force, so hitting the arms causes grief long before you
are flat enough to really run into the other problem.

David Lang

1 Like