Maslow Home Maslow Community Garden Newsletter

Motor stutter or jitter when cutting arcs near top of sheet--

Has anyone had trouble with jitter or stutter when cutting arcs? I’m cutting large arcs, 8’ long to be used as a template in my artwork. (visualize a very large French Curve) using a full sheet of 3/8" plywood. I use a sharpie in a pen holder to outline the cut and check for errors since plywood is now crazy expensive. Everything is fine except for the top of the arc near the top edge of the plywood. When the sled reaches to top it starts ‘jittering’ or stuttering for about 12-18" of the arc the bit (or pen) seems to be creating small circles or loops. This is about 1-2" below the top of the sheet. The sled and motors stutter, then on the down slope it resumes a smooth scrolling action

Is your motor shield overheating and causing the stuttering?
Is your sled catching on something?
Is your beam high enough to not overtension in the top center?

1 Like

Thanks Orob
Motors are 375mm above work piece. Motors/shield don’t seem to be overheating, but I will check later. Sled is not catching.

What shield version or machine version do you have?

I’m using the latest MakerMade M2 CNC Due Board + Shield. Just purchased it less than a month ago.

3 heat sinks on your shield board?

Yes, there are three heat sinks

Point of clarification. This stuttering starts 18" left of centerline of the workpiece, 5 inches down, extends for about 18-20" on the upward part of the arc moving toward the left end of the of the panel, then continues for 3-4 beyond the high point (top of the arc), then it smooths out as the cut continues downward --still about 18" from the left edge of the panel

can you post a picture?

So you are getting this with a pen and not cutting…I’ve seen “hopping” when my 2 heat sink shield got too hot, but adding a fan fixed that and you don’t have that shield.
Is your sled ring and router not centered so when the sled twists, the mill/pen shifts?

I think @Orob is probably right that this could be caused by overheating. When the controller board overheats it shuts down for a second to protect itself and that could cause the behavior you are seeing

Thanks,
Sled ring and pen are centered. I’m very fussy about accuracy. The sharpie has a spring to facilitate contact, but I must admit it drags a bit although nothing like the resistance a router bit would cause.
I will remove the cover from the shield to facilitate cooling and may add a fan for good measure.
On my first attempt, cutting 1/2" plywood the left side hit the edge of the extension board used to keep the sled from tipping. Then for some reason on the passes it would move inward an inch or two.
Also, the bottom lower right corner went a bit crazy cutting a spaghetti pattern, hence the sharpie.
I will post a photo a bit later. I did not photo my first cut (should have), I was in a hurry. Kicking myself for that.

Hey guys,
See the attached photos. I did find the scraps from my first attempt at cutting my French Curve arc template. Sorry for any duplicates. They all seem to paste with the same name. The photo of the lower right shows the intended cut in Sharpie and the partial cut on the first try. I think the sled is very weak in the lower corners. I added a 12’ beam which seems to help, but since all of the weight is axial, it does nothing to ‘pull’ the sled into the far corners. I’m looking at a way to add a pull chain to assist in the corners

French Curve GRFFrench Curve GRBL, 8-21-2021rench CurveFrench Curve GRBL, 8-21-2021 GRBL, 8-21-2021BL, 8-21-French Curve GRBL, 8-21-20212021French Curve GRBL, 8-21-2021

all I see are file names… can you snip or screenshot the pics and just paste them in the forum?

will do



This is the second attempt using the Sharpie–notice the jittering


Doesn’t seem to be an overheating problem. I just ran my program again without the Sharpie or the router and had the same result–jittering at the top of the arc.
The motors and shield are slightly warm to the touch. No excessive heat detected.
Interestingly the lower arc does not seem to suffer with the same jittering as the top arc

and the top of the arc is closer to the corner?

normally one would expect to see the variations shown in the lower corners where the beam isn’t far enough out to pull the sled sideways

How are your chains hooked up? when they get let out that far in the lower corners, does your slack system get super tensioned up?

I have a couple ideas, but non are a smoking gun based on what you have shown.

  1. is your frame laying at 15 degrees from vertical? If at 20 or higher, you will have excessive sled drag and that will exaggerate the lower corner problems… after further consideration, if you built using the M2 metal frame pieces, you should be pretty close to 15 degrees
  2. Is the bottom of your sled smooth and the cutting surface reasonably smooth to not cause it to bind
  3. Is your beam height far enough up - you said M2… those tend to be very low.

You might want to check with the makermade facebook group because most of them run the M2.

the chains need a lot more tension across the top than they do elsewhere in the
workspace, so they draw a lot more power there. If the heatsinks don’t have good
enough thermal connectivity to the chips,the chips could be heating up enough to
trigger issues even when the heatsinks don’t feel hot yet.

try cutting the feed rate in half (much less power needed) and see if you still
see the same pattern.

David Lang

1 Like

Orob
Thanks for the suggestions. I will check into them. The frame is a modified Maslow–not M2. I switched to the M2 Due board because I was having so many problems with the EastBay board Z function.
I have added to my chains so that they are not overly tensioned. I have also added an HDPE anti-friction ring under the sled.
The area you circled in the photo is where the sled bumped into the filler board just outside the workpiece. It was barely 1/32" thicker than my 1/2" plywood. The problem area is at the top (see the attached markup)
Here’s something that I’m really having difficulty with. It seems that no matter how many times I calibrate this thing, it will not save my settings. I think between the two boards I have calibrated at least 50 times. Every time I reboot instead of reloading my calibrated settings, my sled goes off into never-never land and I need to re-calibrate. It seems if there is some little hiccup in the G-code it scrambles my configuration.
Whats the point of having an EEPROM if it doesn’t save my settings? There must really be something missing in the firmware. Am I the only one facing this problem? It should re-start with my saved settings. Once calibrated, the sled should go to home every time–no exceptions (baring a chain break or other mechanical problem) but it does not do this. How can we build upon what we have done if we start from scratch every time?
If your PC rebooted with different settings every time you started it and you had to reconfigure your software every time you booted up, you would go berserk.

the two areas with the biggest problems have very different reasons.

  1. in the bottom corners, the sled gets pulled towards the outside corner only
    by the force of gravity, modified by the chain angle (for the math geeks, the
    force is sin(angle from vertical) * G) so the closer the chain is to vertical
    the less force there is. on a stock size frame, there is less than 4 poounds of
    force available. The angle of the frame, slicness of the workpiece, slickness of
    the bottom of the sled determine how much friction there is and it’s very easy
    to get enough friction that this 4 pounds of force isn’t enough. Going to a
    12’top beam roughly doubles this available force and makes it work much better.

the classic symptom of this problem is that if you try to cut a L shape from the
center out, then up, it will tend to round the corner rather tham making a sharp
L

a similar issue if there is too much friction is that vertical cuts moving down
can havethe sled stick and then cut jagged lines down. This can only be solved
by making the sled more more easily.

  1. in the top center, the chains get the closest to horizontal, and the chains
    need to provide enough tension that 2 x sin(angle from horizontal) > weight of
    sled. if the power supply isn’t putting out quite enough power, it’s very easy
    for the machine to struggle in this area.

the classic symptom of this problem is that what should be a stright horizontal
cut across the top will tend to sag and then hook up noticably at the end of the
cut

If you measure the voltage and see it sagging down from 12v as it’s having
problems, this is your cause. A more powerful power supply (higher amp rating,
or putting a 12v battery in parallel with the power supply) is the real
solution, slowing down may reduce the power demands to where your power supply
can keep up.

David Lang

the standard firmware saves the sled position after it’s stopped for a couple
seconds (the motors stop buzzing), if you restart things without letting this
happen, the maslow doesn’t know where it is and you need to reset the chains to
a known position

could that be what you are running in to?

David Lang