Maslow Home Maslow Community Garden Newsletter

Motors won't turn to anything but 360 degrees, strange noises

Hi everyone! I just received my EastBay kit and tried assembling a quick stand to get started. So, I am at the stage when the motors are in place all electronics are connected and I am in Ground Control trying some calibration moves… Amd failing miserably! When I press " Turn 1 degree CW" or 5 degree - any direction, any motor, left or right it’ s the same. The motor makes some noise and visibly attempts to turn - but the shaft doesn’t move at all. The " Test motors/encoders" button makes the motors spin both ways in what seems to be a normal fashion, the left one then the right one. Still, when I enter calibration - I cannot make them move correctly. Am I missing anything? It does look like the steps/degree of turn setting is off somehow, but I cannot find any place where it’ s configurable. The lights are on on both the Arduino and the shield, the power is supplied to the shield, rather than the Arduino. The power supply of the motors is supplying 12.57 volts so it seems to be good. And I have tried both the 1.26 and the 1.25 versions - firmware and Ground control. No luck. Please help

First of all, try changing over to WebControl. In effect what it does is set up a small webserver on your system, which you can then access with a standard browser to control your machine.

Next, I had problems like this (but not exactly the same) when I first got my Maslow. What I did was to rollback a version of the Arduino software, and GroundControl.