Maslow Home Maslow Community Garden Newsletter

Need Help! Was working, tried firmware update, now no motor control

Hello all, as the topic states I need help. I just got my kit the other day, and managed yesterday to get my first project cut using ground control. After reading a topic on how to upgrade to holey 51.28 so I could use makerverse on my mac book, I can’t get web control to work at all, I just can’t figure it out. So I broke out my old windows laptop, installed the run from directory web control, communicated fine, So I then upgraded to holey 51.27, then followed the in preparation for makerverse topic and upgraded to 51.28, now the left motor just runs, no control with web control. then I went back with web control to 1.26, which stops the motor, but now nothing works. I went back to mac ground control, sees the board but no control either. I’m at wits end, if I could get back to yesterdays success I could deal with buffering issues in ground control. I have tried to wipe the control and setting in web control and redo the firmware to 1.26 but nothing again. I don’t know what to do next. I have arduino IDE, I have compiled the maslow firmware 1.26 and flashed the board that way as well but nothing.

I though I would take everything apart and use arduino ide on my mac to flash the firmware. I can again see it in ground control but still no motor control. I know the shield or driver board is working because if I flash the firmware to holey 51.27 the won’t stop working. Anyway, here is a screen shot of where I am now from ground control. is there a way to completely wipe the mega 2560 and start as if it was a new board?

abit more info, I test the power supply everything is working, when I use ground control, test motor, all fail but when testing the z axis, the right motor moves, bit it also fails. in the program, so this leads me to believe the firmware is corrupted on something is not right. I guess it needs a complete wipe and refresh some how.

This is very strange…hmmm. I wonder if it could be detecting the wrong version of the board. Does your board say version 1.5 on it?

If you want to the settings and start fresh Actions -> Advanced has options to do that. You want to wipe the EEPROM (settings stored on the Arduino) and then use the button to reset all the settings to the defaults.

Holey firmware does not work with ground control. Have to use stock firmware.

Hey all, thanks for the responses, I actually got everything working again through support in the holey 51.28 thread.it turns out my shield board isn’t supported in the firmware, maybe in the 51.29 build. Thanks again for the reply’s, I am actually quite pleased over all with the performance.


Acouple of dog beds the wife wanted. :slight_smile: going to try out a sheet of 3/16 aluminium tomorrow.

2 Likes