Maslow Home Maslow Community Garden Newsletter

Holey and Makerverse on mega original Maslow not functioning

I haven’t used my Maslow for a year or more and decided to install Holey and use Makerverse in preparation for getting the M2 upgrade. Used Arduino IDE to upload Holey firmware and then tried to use Makerverse to test using manual controls. Nothing even though Makerverse showed com3 Manufacturer: Arduino LLC selected. All controls in Makerverse not functioning. I have a feeling I have missed something very basic. HELP!!!

what shield version do you have? What firmware version did you load? What version of makerverse did you try?

Maker1.0.6
Firmware-Holey-Release
I assume by shield you mean Mega 2560?

Makerverse 1.1.2 is required to be able to use the mega. You need Holey-51.28 firmware for it to work.

1 Like

Thanks Orob!
How do I get the version number for Holey?

Orob
Also my information is that Maker 1.0.6 is the current version. How do I get 1.1.2?

Found 1.1.2
Looking fore firmware

the .hex file was on the forum or you can get the arduino code here and use the arduino program to flash.

oh and by shield version, I mean the printed number on the board on top of the mega 2560. It is 1.2b or 1.3, 1.4, 1.5, 1.5b, 1.6 etc… it is the upper board with the heat sinks on it that the motors plug in to.

shield version is 1.2b
I have downloaded both the firmware and Makerverse.
I installed Makerverse and updated the firmware with Arduino 1.8.1
Running Makerverse took me to the web where I had to create an account.
I can select my machine but the firmware seems to want me to update as it has a box (pink) Required version 51.28.
I am at a loss where to go from here and considering going back to Ground control. The cryptic instructions for installing webcontrol and creating a Repository etc. are starting to frustrate me. I need someone to explain in English not Geek. Sorry if I sound negative. I studied programming in the 80’s and have run computer labs in my career as a teacher.and have been retired for 15 years. Things get harder when you get old believe me. I lust want to get this thing working so I can get on with my projects!

Just to be clear, you want to use makerverse or webcontrol or groundcontrol. With the mega you can choose any of them.

As I mentioned previously, if you want to use Makerverse, you have to put holey-51.28 firmware on your mega.

  1. download arduino IDE (1.8.1 will work -> sounds like you have it)
  2. download the source code / repository: link here
  3. unzip the file you just downloaded (do not just click into it because nothing else will load and the compiler will fail to find the dependencies).
  4. open the cnc_ctrl_v1.ino file with the arduino program
  5. select the arduino mega 2560 as the board (shown below)

    and verify the processor is correct.
  6. connect the controller to the laptop running the arduino and make sure makerverse and webcontrol or groundcontrol are NOT running
  7. Select the correct port where your arduino is. (I don’t have one plugged in right now, so it won’t show up, but yours should as com?
  8. press the upload button and wait for the program to compile/build/link and then wait for the lights to stop blinking and you should be good to go.
  9. plug back in, start makerverse, calibrate, cut…

Thanks! I will try again tomorrow. Your Instructions seem excellent. I think I made a basic mistake by not opening the cnc_ctrl_v1.ino. I should have known better but I was getting frustrated after spending a couple of days on and off trying to get things to work. Thanks again and I’ll post what happens.

of days on and off trying to get things to work. Thanks again and I’ll post what happens.

Sprasher

3m

I followed the instructions and tried several times deleted and replaced arduino, Makerverse and firmware to make sure I was using the correct versions. Not working still

arduino compiles sketch uploads and says done with the the following message.
Sketch uses 62284 bytes (24%) of program storage space. Maximum is 253952 bytes.
Global variables use 2047 bytes (24%) of dynamic memory, leaving 6145 bytes for local variables. Maximum is 8192 bytes.
Makerverse still has pink box - Firmware: Required version: v51.28 Confirmed Protocol: Maslow
At Baud Rate: 57600
Response Protocol: Grbl v1.00
Firmware: MaslowClassic v1.28
I don’t know if any of this helps explain what is happening! I am using my tower with win 10 and will bring my laptop over to the shop after lunch and see if that changes anything.
Any advice help?

By the way. lights don’t flash during upload.

Tried laptop with exact same results. It looks to me that the firmware is not updating for some reason.

Looks like you have 1.28, not 51.28. Try downloading avrdude_gui and grab this 51.28 hex file. Open the gui program and select the hex file. Select the correct arduino port and then program it. No compiling. The lights that flash during programming are on the lower board, so you may not see them if you aren’t carefullly looking for them.

I’m out of my depth here.
Tried your suggestion.
got this message:
trying to connect to device…
‘avrdude’ is not recognized as an internal or external command,
operable program or batch file.
‘avrdudeGUI.exe’ is not recognized as an internal or external command,
operable program or batch file.
Press any key to continue . . .

maybe this will help?

I struggled through this video. I can’t believe that this is considered an instructional video. A few instructions in English would have been a lot less time consuming and far more instructional.
After more than an hour of watching and re-watching this is what I got:
The code execution cannot proceed because libusb0.dll was not found.
I have come to the conclusion that this may be a hardware issue. i will take the controller down and try a short usb cable to see if that will allow me to flash the firmware.

I took the controller down and tried to update with my printer cable. Exactly same results no change in the firmware.

I tried using the reset button which did not reset anything or change anything.