Maslow Home Maslow Community Garden

Problems with 1.24 version, motors test and cutting corners


#1

Hello everyone,
After I bought maslow cnc, I made some projects, box for “brains” with coolers, cut out plexi and dibond for sign. If was ok. Was difficulty to find cutting feeds and speeds. I`m the only one who confused finding info in all maslow webpages? Like github, comunitygarden, forums… Can someone put all things in one place, like maslowcnc.com not with external links to github or comunitygarden or in forum mess.

Problem No 1.
I worked with 1.18 and 1.21 versions. After i updated top beam, I instaled 1.24, calibrated and started cutting. First error: sled can`t keepup. On motor test starting to draw circle.
Tryed: lose some weight on sled. Didn’t worked.
Changed to higher error limit. Didn’t worked.
Removed sled. Didn’t worked.
Cheked all pins. Didn’t worked.
Downgradet to 1.21. Worked!
Something with firmware?

Problem No 2.
In 1.21 after Test motors/encoders motos stops not in same posicion and after test if I press play - sled is not keeping up…
If I press to cut, everyfing looks good.

Problem No 3.
How to cut inside corners? slow down? or pre drill? look in picture.


#2


#3

There is a known bug in 1.24. 1.25 has the fix.


#4

At what feed rate did you cut that? Seems really odd that you don’t even see any part of a dogbone.


#5

Feed 350mm, 3mm one flute bit, ~9400rpm


#6

Near GC 1.25 “No changes in 1.25, just keeping the version numbers synched up”


#7

The firmware was where the bug was…up that to 1.25 and the issue you had might go away.


#8

350 mm/min is plenty slow enough. Can you post the gcode?


#9

moose legs.nc (24.3 KB)


#10

I wonder if its not just a combination of the small movement you are trying to make with a small router bit. maybe there wasn’t enough force to push it into the corner for that short jog. I ran it in webcontrol on a simulator and it was hard to even tell it made the move. It’s such a short distance.


#11

The top corners don’t look at all well either. Your code has a nice smooth radius on it and your cuts look more “angular”. How did the rest come out?


#12


bottom on an angle


#13

Maybe you are trying to cut too deep with a small bit. At 0.15 inch (~4 mm), I’d be using a 1/4-inch bit (~6 mm vs. the 3 mm you are using).


#14

Maybe it’s a case, I’ll try cut half of bit, 1.5mm


#15

The metric version of the online makercam creates positions with up to 16 digits after the decimal point.

The offline version has fixed that.
I had plenty of issues in the past with this much digits.

Edit: camotics gives warnings:
Briedis kojo laikiklis 100x120mm.nc:30:Arc radiuses differ by 0.00210541
Briedis kojo laikiklis 100x120mm.nc:45:Arc radiuses differ by 0.00243621
Briedis kojo laikiklis 100x120mm.nc:159:Arc radiuses differ by 0.00210541
Briedis kojo laikiklis 100x120mm.nc:174:Arc radiuses differ by 0.00243621
Briedis kojo laikiklis 100x120mm.nc:290:Arc radiuses differ by 0.00210541
Briedis kojo laikiklis 100x120mm.nc:306:Arc radiuses differ by 0.00243621


#16

So problem with gcode generated by makercam?


#17

I don’t know. I had bad experiences running this kind of files in the past. Buffer overflows that have be caught and fixed.
But the math is constantly increasing and would not put my mega through this calculations. I would even refuse if someone would ask me to simple additions with this numbers :slight_smile:

Edit: It would be good to know though. I will run the file in fake server mode and see if anything shows up in the log.

The log is full of ‘Large-radius arc replaced by straight line to…’
Was the .svg done in inkscape?

I could not find issues with the .nc in the dog-bone part with bcnc, but other parts have issues like asking maslow to move tenth and hundredth of a mm 3 lines in a row.
I can’t tell if it’s the .nc but you could try if turning on ‘truncating’ in GC makes a difference:
In GC click on settings and on the grey ->Maslow Settings to go to ->Advanced settings.
Turn on ->Truncate Floating…


#18

Made g code in jscut.org. And different story. In corners feeds slow down. Never use macercam… I`m concern about straight lines which going up in deep pass, in small passes looks straight, can it be guilty weight, because my sleds weight are in middle. Or rotating milling bit rising upwards then cuts?


#19

Your gcode says:
(Generated by PartKam Version 0.05)
in the first line :speak_no_evil:


#20

Never again :slight_smile: