Sled will not go to top of board same parts are cut different sizes


I have rechecked distance between motors have set chain length. My top of board vertical to motor sprocket center is `17.5 in or 445 mm. My sled will not go to top of board or 24 in from center position. i think this is causing part size issues.

My scale is off. parts set at 5 inch from top of board are squashed. at least an inch less down from part specs.

this is killing me. My board width is 2440 mm and board height is 1220 mm.


Hi @Jimr ,
Welcome to the Troubleshooting forum section.

Your description matches the known current firmware release limitations.

Note that what people often try to do is to cheat the left-right motor distance to pull up the center.
However, Recent research has shown that the importance of some parameters were underestimated: chain stretch and chain tolerance.

We are collectively in the process of improving the Maslow software, and we have an improved solution in beta test. To finalize this very promising improvement, @Joshua has designed an improved firmware /Ground Control and calibration for the MaslowCNC.

Would you like to try it out?

1 Like

I think I remember reading about this before.
Just a sanity check. What sled style are you using? Quadrilateral or Triangular?
Then the next question come naturally: Does your Groundcontrol know what sled you have?

1 Like

i have the triangle and set in gc as such.

sure ill do it

Hi I’m doing new calibration in 4 hours. Please send any tips suggestions. Thx jim

1 Like

HI, I am having awful issues this morn. I go to shop, maslow is updated to new arduino, gc and specs u sent me.

I cant move the sled without getting a fast sled not keeping up and then cant find chain position errors. I have resetted chain at least 6 times, and move to center. btw, the center is too low again. Then finish and try to move sled using top right controls and error cant find chain lengths comes up.

The first attempt at moving sled gets errors again. I have reset arduino and re loaded new firmware.

thanks JIm

Hi Jimr,
I reviewed your last posts on this topic as well as the Holey Calibration Topic.

This is the kind of situation where we have a chance to share about what is going on in the arduino, and name new places to recognize the situation.

For the context, here is what makes the arduino complain about not finding positions error:
The arduino keeps in memory the amount of chain that is extended above the sprocket 12 O Clock position. At power up, it reloads the last values saved in the EEPROM.

At first, the arduino has to figure out where the sled is on the workspace, the arduino will use these chain length values along with some parameters describing your setup as entered via GroundControl.

The arduino always limit sled movement to not exceed the workspace coordinates in knows. And when figuring out the sled, it will always assume the sled has to be on the workspace. If it can’t figure out how these chain lengths make up a sled position on the workspace, it will flag this “can’t find position error”.

Now why would the sled not be on the workspace anymore (especially because you see it is)? Usually because it is somewhat close to the edge before some parameter change. (remember that the workspace boundaries you see and the workspace boundaries arduino estimates are different until calibration is fine). So when changing parameter, you want to first bring the sled close to the center. Otherwise, after a change it might end up for the arduino to see it outside, even maybe just a little bit.

Actually, the arduino will try to figure out sled position after each related parameter change, or at power up. If you get into the “can’t find position” it won’t want to move. But you can revert parameters, (click stop button in upper-right GC will show x,y recomputation results), then be able to command it to move the sled, then enter parameters again. No need to go through the burden of reseting chain lengths. These should always be fine unless you get chain skip or off the sprockets.

I have also met this situation when I had mistakenly input a related wrong parameter value in GroundControl ( a typo). Say… a number out of range like 35012 mm motor distance.

To help you, I need to understand the details of your current setup and you recent actions.
Could you share the GroundControl.ini file listing all you setup parameters?

Much thx. At one point on move to center sled went bottom rt and would have exceeded work area I have I did not stop. This happened in set chain length on move to center

I’ve witnessed on my side that changing settings without a closing of GC and disconnecting the arduino and reconnecting it, could leave the arduino or GC in a ‘undefined’ state. Surprisingly i end up in that stage often even in fake sever mode and get the same 2 messages you do. Till date i need to provide a replicable procedure to be secure enough to open an issue. My guts want tell me that not every change is written to the .ini and the eeprom and reread/recalculated at the same time of the change.
Edit: rewritten/reread/recalculated

Should I clean out eeprom.

Not saying that, just mentioned that a believe to see similarity.
Did not intend to interfere with the experts, just noticed a similar pattern.

After starting GC and connecting to the Arduino, If you review the maslow settings and advanced settings (don’t worry about the PID parameters, just look the parameters you know or changed) and if everything is ok, then that is a first good check.

If homing the sled goes out of the workspace area, I would suspect chain extent count is messed up or some parameter is wrong. You could redo the 12OClock reset of the chains. But before spending a lot of time going through these handlings:

I’m at work and will fix later. I did something stupid. I created two beta gc folders deciding to do 6 hole optimization. I did not remember which gc folder I had set up. I believe I sent Arduino wrong data. I just need to figure out how to cleanup this mistake? Jim

Hi, I want to apologise for whining yesterday. I went home after work deleted extra gc file, shut down all, fired up gc, set work area, and bang. Worked like a charm.
Thx, Jr

Thx all



Could you tell us how flat the top and bottom sled movement are on the workspace edge?

To do so, simply position the sled in the top corners and the top center as reported by GroundControl. Then check what is the vertical distance of the router bit to the real top workspace edge.
top left : mm or inch
x = -800, top y: mm or inch
top middle : mm or inch
x = +800, top y: mm or inch
top right : mm or inch

Simpler for bottom edge:
bottom left : mm or inch
bottom middle : mm or inch
bottom right : mm or inch

That would give us an estimation of the proper tuning of chain stretch, motor distance, chain tolerance, 12 OClock, Rotation Radius, motor vertical offset above workspace, …

For the chain sag, could you report the same observation (but horizontal) for left and right workspace edges as well?
top left : mm or inch
middle left : mm or inch
bottom left : mm or inch

(I would expect the left and right to be symmetrical)

I will confirm that I have seen that too and I have not been able to figure out exactly why that happens.

1 Like

Blew out left gear. Sol till New ones come.

Sorry to read that :hushed:
Could you share some details on the cause of that failure?

I’m getting “Unable to find valid machine position” after changing motor distance from 3613.15 to 3613.77. Happened immediately. This is surprising for such a small change.

I hade already homed the sled before changing the value. The motor distance was the only thing I had changed when the error came up.

I’m confused how this is a work around. Unfortunately I’ve already started the reset chain lengths. I pressed “automatic”, which never results in the same tooth going back to 12 o clock position for me. I didn’t have time to complete the process so, out of curiosity, I pressed the “move to center” button which moved the sled all the way off the bottom of the frame. I know that isn’t the correct process.

I don’t have access to the ini file tonight.