Maslow Home Maslow Community Garden Newsletter

Stuck trying to center sled, and finish calibration

groundcontrol
accuracy
calibration
#1

New build. Can’t finish calibration. Arduino 1.8.5, GC 1.19, Firmware 1.19, MacOS 10.13.6

Measured motors to plywood? Check
Motors to 12:00? Set zero? Check, check
Pull chain tight & measure? Check ??
Direction? Chain off bottom. Check
Calibration generated? Check
Measured rotation radius? Check
Adjust chain to known length? I THINK I did this properly…
Move to center? Not clear if I’m supposed to do that or not, but I can’t. When I try, the left chain lets out and the right chain doesn’t move. Both motors move under manual direction. Machine doesn’t seem to know what I’m asking it to do. Since I know nothing about this stuff, I’m stuck.

Thanks all, Joe

#2

Were you able to move both chains back so that one link on each was at the 12 o’clock tooth on the gear and then extend them?

I would expect both chains to move the same amount when moving to the center. How close to the center do you end up?

It sounds to me like there might be a step missing. Did you see these two steps before entering the rotation radius?

1 Like
#3

Thanks Bar. You can ignore this. I found that WilleyAZ and Duane had the exact same issue, and I’ve jumped onto that thread, called “Sled not centering.” It has to do with measuring the distance between motors, extending chain, etc. You’ve updated the instructions, to, I think, NOT remove the chain from left sprocket after measuring. The revised instructions are still not clear to me. Blurfi and MadGrizzle provided suggested wording that makes sense to me. I will try later today.

#4

My suggestion was to actually change the calibration process to eliminate this confusion… happens way too often. Don’t do what I said.

When you extend the left chain out to the right sprocket and click measure, the chain gets pulled tight (that’s when the software measures it) and then lets out a little slack. At that point, remove the end of the left chain from the right sprocket only. Leave the left chain where it is on the left sprocket. Install the right chain on the right sprocket such that the first link is on the 12 o’clock tooth. When you go to the next step to extend the chains the correct distance it will actually retract the left chain to where it needs to be and extend the right chain to where it needs to be.

#5

Thanks MadGrizzle. I read further down where you clarified it. Later today I will be doing what you just wrote in the last paragraph.

1 Like
#6

Just to clarify, are you trying to go through the complete calibration process from start to finish (not skipping any steps)? I don’t want to steer you wrong and assume this. If you are hopping around in the actions menu, the procedure is different…

#7

I agree fully with changing the calibration process. I have tons of problems getting mine to do what it needed.

#8

You have tons of problems or had tons of problems? if you still have problems, what are you running into?

#9

Yes, I was going step by step, inch by inch… Everything worked until the I tried to center the sled. I am pretty sure that is because after I measured the distance between the motors with the chain, I took the left chain off. I think the directions still say to go to “link 1,” which can’t happen unless you physically move the chain. And I don’t recall directions to use the “retract” function. It’s still not clear EXACTLY when to hit “move to center.”

And yes, since this is my first time (well, not really any more) I didn’t even really know what I was supposed to accomplish… The “big picture” ie calibrating IN ORDER TO FIND THE CENTER of the 4 x 8 requires these steps…

Have to go do some “earns the $” work. Bye.

#10

Had problems. I finally have all working well. I would get odd things happening in the calibration process. Chains running opposite directions, program not telling me to remove chain after setting length. I finally broke every connection down and reset every connection and verified router position on sled.

#11

After you make your “$”, read this…

Ok, well, are you using a top-feed or bottom-feed configuration? If top-feed (where the slack of the chain drops vertically down) then what I said will work. If using a bottom-feed (where the slack of the chain goes horizontal toward the center of the top beam), then you will have to manually set the left chain on the first tooth of the left sprocket. I apologize for the confusion.

If using top-feed:

After you measure the distance between motors, you will be brought to a screen that has five buttons… “Adjust Left Chain”, “Adjust Right Chain”, “Stop” and “Move to Center”. At that screen, press “Adjust Left Chain” and the left chain should retract. After it’s done, put the right chain on the right sprocket and press the “Adjust Right Chain”… the right chain should extend. Connect the chains to the sled and then press “Move to Center”. Hit “Stop” if something goes awfully wrong.

If using bottom-feed:
After you measure the distance between motors, you will be brought to a screen that instructs you to remove the chains. Do so and press next. The next screen will have you set the sprockets vertical. Do so (I think you can just press “Automatic” and it will work) and then press “Set Zero”. The next screen that has five buttons… “Adjust Left Chain”, “Adjust Right Chain”, “Stop” and “Move to Center”. Put the first link of the left chain on the the left sprocket and press “Adjust Left Chain”… the left chain should extend. After it’s done, put the right chain on the right sprocket and press the “Adjust Right Chain” … the right chain should extend. Connect the chains to the sled and then press “Move to Center”. Hit “Stop” if something goes awfully wrong.

#12

Sometimes I wonder if the software routine that is being used is switching things properly before top and bottom feed configurations at the various steps of calibration (which could cause issues as you and others have described). I can’t find a bug in the code though…

#13

It might be best to set this variable in the very beginning of the calibration process instead of part way thought.

It definitely did switch things on me.
I ran the calibration multiple times (6+) back to back and I seemed to get different issues almost every time.

I even restarted my computer, unplugged the Arduino and the Maslow board to “reset” everything that may be stored in the boards. I actually spent about 2 weeks battling the complete setup, troubleshooting and correcting accuracy problems.

At one point I started lying to the program and telling it I was bottom loaded so the chains would turn properly and I could move forward. After I pulled everything and re-seated all connections and “rebooted” everything, it ran the calibration fine and gave me no issues. It was with version 1.16 and I have not calibrated since (sort of afraid to rock the boat) so the issues may have gone away in the latest version releases.

After I finally got a good calibration done, I focused on getting it as accurate as I could. The weight distribution of the bricks had a marked affect on the accuracy as did the accuracy of centering the router to the sled.

2 Likes
#14

I don’t know code. And I don’t know the answer, but I’m pretty sure that I know where the problem is.

After I measure with the chain, from the left side, I am left with the following situation: About 3045mm of chain running from the top of the left sprocket, to the right, along the top beam, to the top of the right sprocket

AND about a foot of chain going from the top of the left sprocket, TO THE LEFT, looping down and up, and ANCHORED into the top beam by the nail that I originally used to connect the chain WAY back in the “build the default frame with down feed to sled instructions”, but which I had to undo to follow the calibration instructions. Here it is:

BUT, if I’m going off the BOTTOM (so my chain doesn’t have to cross itself), then my anchored end…

HERE’S THE PROBLEM

… the ANCHORED end, should probably NOT BE ANCHORED. Because when the left sprocket retracts in order to get a “known length” of chain, I’m left with a big ANCHORED loop coming off the bottom, and the loose chain (ostensibly the end to be connected to the sled) STILL IN A TOP CONFIGURATION. So…

STUCK.

I may have missed the “take chain off of nail,” instruction but I don’t think so, and it’s not intuitive, because the instructions are very detailed.

My theory would explain the common problem of “the chain retracting in the wrong direction,” yet the code actually being correct. The code is working correctly, but on the wrong configuration/perception of the chain. So… garbage in, garbage out. I think that my theory might also explain why so many people having this problem. They, like me, are simply looking at the WRONG END OF THE CHAIN. This misperception is ONLY because the other end of the chain, which SHOULD be the woking end, to attach to the sled, is still anchored.

If the % of people having this problem in the calibration is proportional to the number of people configuring their machine with a “bottom feed,” then this is the problem.

I can’t tell, because I don’t KNOW how it’s SUPPOSED to work.

But there are about 1,000 people on this forum that do.

So, I’ll have the answer soon!

Thanks all. Joe

2 Likes
#15

I believe that once you have stretched the chain across to the other motor and done the chain length measurement ( what I think you are showing in the pic? ) You then retract the chain to remove the tension and orient it in the direction you want it. I got slightly caught at that point as well but after carefully reading what ground control says to to do I figured it out. So once you stretch the chain and get the length measurement saved, you then take the chain off the gear and route it the final direction to do the next step which, if I recall correctly, then sets the length of chain on each side and then you add the sled.
I do know that I never had to remove the chain from its mounting point, just had to take it off the motor sprocket and reorient it to the configuration I planed to use and then let Maslow set its initial chain lengths on each side and attach the sled.
Hope that helps.

2 Likes
#16

So, if you selected bottom-feed configuration when asked during calibration, the program should instruct you to remove the chains from the sprocket after you finished measuring distance between motors. So do that. After doing so, it will ask you to set the sprockets to vertical… do that by pressing ‘automatic’. Then, reinstall the chains in the correct bottom feed configuration…

This is a picture of the left motor/chain when you reinstall the chain. The right is the mirror image.

Once you do that, it should work. If the left sprocket for some reason turns clockwise when you tell it to “Adjust Left Chain” on the next screen (causing chain to fall off) then the software thinks you are in top-feed configuration.

2 Likes
#17

Good morning MadGrizzle.

OK, all good so far. I have run out chains and attached my sled, which is centered left to right, but pretty high up on my plywood.

Directions now say “press next,” which I have NOT done.

The following direction / comment says “The Move to Center button will move the sled to the center.”

I’m sorry for being so picky, but which button am I actually supposed to push? “Next” or “Move to Center.”

I suspect that I want to center my sled before moving on……

#18

Yes, you would “Move to Center” but I’m a ‘little’ concerned about it being high up on the plywood. What is the length of your top beam?

#19

120 inches

#20

Do you recall what the distance between motors that maslow measured?