Problems during initial calibration

I was just trying to calibrate my temporary setup machine dimensions. When trying to measure the left chain length it extended all the chain until the motor stalled, bending the nylon/screw chain glider in the process, then proceeded to measure out what appeared to be the proper amount (or at least not all) of the right chain. On the next step I got a lost position error, recalibrating the chain position didn’t correct it, so I guess it’s not supposed to run out all the chain to measure it.

No Internet in the shop so I came back in to see if the weekly firmware update had hit yet. Guess not so I’ll power cycle the Mega to reboot and continue onwards. Probably tomorrow.

I did a bit of playing around moving the sled around before calibrating dimensions. Perhaps it was enough activity to have triggered a problem.

I haven’t seen those particular symptoms before, but let’s keep an eye on it. Let me know if it comes up again.

It might be worth running actions->test motors/encoders to make sure that there isn’t a loose connection or something preventing the arduino from reading the encoder properly.

I had done a test motors and encoders as part of the initial fooling around, er, testing. No problems.

I first thought that pulling the left chain tight was to get an accurate length, at least until it started bending the screw (which survived). If it continues after the next firmware update I’ll take notes and open an issue

1 Like

I havent build the frame, but tested the motors, for the first time on v.81 when i tested the motors they kept turning then i cycled the power and rebooted gc and everything seemed to work. So could it be you put the new firmware on and hadnt reboot/cycled the power?

No, it was power cycled more than once, plus the motors run on the bench inside after programming the board.

Well, I’m going downhill fast.

I installed the firmware from the master branch today, and am unable to calibrate. It’s lost track of my chain position, “Unable to find valid machine position. Please calibrate chain position.” with undefined hold and continue options. Click either and the message will reappear several times again after what seems to be a random interval. Yes, I know it needs to be calibrated.

When repositioning the chains there’s about 5 seconds of motor buzzing after the one degree turns. Low pitched on left, high on right. No visible motion during this time, just buzzing. This also happened with 0.82

The s hook and chain idler on the right side went sprong and flew off. Found the s hook, the sprocket is lost somewhere in the thousand square foot barn. Crimped the left side onto both the elastic string and sprocket, will punt on the right for now. Maybe I can 3D print a new one with Gearotic.

When calibrating the chain both ends have developed a tendency for the chain to stay on the sprocket and wrap around it. I can catch it on the left, but since there’s no warning when it switches from left to right if I’m watching the left chain the right will jam. Managed to get both sides to calibrate, finally.

Restarted calibrate machine dimensions (it kept the pulley to pulley spacing) and skipped to step 7 to set the router bit position again. GC kept the inter-motor and motor offset distance from last time, and I’m reluctant to repeat the motor spacing test if I don’t have to - it deflects the arms since it pulls the chain so tight. When moving the Z down one mm it then raises the sled around 4 inches. Almost had the bit back to zero (calibrated before but it moved it up when it had problems the last time I tried) and it started repeating the calibrate chain popups. At this point I’d been at it for around an hour and getting pretty close to my frustration tolerance, and quit for the day.

Left and right chain calibration should have an option to just do one at a time. No idea why the end of the chain is starting to stick on the pulley but will try to clean and lube the end (FinishLine Dry chain lube, what I use on my 3D printer screws and rails). Possibly I slightly magnetized the end while searching for the sprocket with a magnet on a string since I did catch the chain a couple times.

The directions should mention bending in the ends of the S hook to prevent sprocket flinging when calibrating since the chain loop more than reaches the floor. I should have remembered that…

Something very strange is going on while trying to zero the router bit. No way it should move the sled straight up when trying to position the Z axis. No way it should loose track of the chain position while doing it, either.

I’m going to go back out to the woodpile and do some more cutting and splitting. 5 full cords cut/split/stacked, need about 7 more for next winter, and there’s 40 still sitting there as 8 foot long logs; we had some of our woods selectively cut, took our share in enough to feed the outdoor boiler for another 3 or 4 years while the logger kept the sawlogs and the rest for pulp. All that commotion out in the woods helps annoy the swamp rats and maybe they’ll relocate.

I’ll take a notebook and take better notes the next time I go out and try again.

Actually, a lot of these things sound pretty normal except for the “Unable to find valid machine position”. I know it’s annoying that the warning message shows so many times, but we had some many issues with the sleds going rogue early on that I wanted to be sure that everyone knows when the calibration needs to be run. Each one of those that shows up represents a different test. If you wait 10-15 seconds without touching anything all of the tests will finish and you can just click to close one message instead of them continually popping up. You were most likely seeing this because of a previous calibration attempt that was interrupted from the chains wrapping.

The chains wrapping when they have no load on them is also a pretty normal issue. There should be a warning message in the text of that step of the calibration process. It tends to happen more when there is excess grease or sawdust on them, but it’s always a concern. I find that my chains usually only bind near the beginning of the measuring process when there is almost no weight pulling the chain off the sprocket. Once a good amount of chain has been measured out on the left, I switch to watching the right.

The buzz from the motors for a few seconds after each movement is normal, the PID controller stays active for two seconds after each move. It sounds different for each motor because the PWM frequency (the shape of the wave controlling the motors speed) is different for each motor due to some of the internal structure of the Arduino chip.

Having the sled move while adjusting the z-axis for the first time, but annoying. What’s going on there is that because the machine’s dimensions have just been updated and so the machine’s understanding of how long the chains need to be to find the center of the sheet have changed. It’s moving to the new center of the sheet. It shouldn’t result in that unable to find machine position error.

I would try checking the settings to see if the first calibration attempt left you with an unreasonable value for one of the settings. If the machine thinks that the motors are only 10mm apart or something strange like that you will get weird behavior. Here are my settings as a reference for what “normal” is:

When you give it another go, let me know how it works and if you have suggestions for how to make the process simpler or more clear they are VERY welcome.

Good luck! It sounds like you are doing everything right!


I’ve suffered this issue as well, when I tried to skip some of the steps in the autocal process. The only solution I have found is to set the sprocket zero points and do the autocal chain calibration. Since I’ve marked the chains, I can let the motors run without the chains attached :wink:.

1 Like

I’m glad you mentioned the marked the chains. IDK if I replied to that or not. It wouldn’t be hard to pop that link out and repace it with a colored link. Chain tool is cheap and easy to use. Colored links are cheap. Plus it won’t wear off over time.

1 Like

I also was concerned that maybe you were getting the chains need to be calibrated issue due to some bug. I couldn’t find anything that seemed wrong, but I rewrote and cleaned up that part of the code so I feel good now that if something is going on it will be easy to track down

I like the idea of marking the chains. Perhaps a dab of paint to start.

I’m still concerned about the way the sled moves up with each z move. When I stopped it was almost to the top of the plywood, another move or two and it would have pulled the chains tight. Probably should try to zero it outside the calibrate routine.

How hard would it be to find another idler sprocket? The flying one has found a good hiding place.

At least I took some more off the 60’ long pile of logs after splitting yesterday’s cutting; new full chisel chain on the Husky 61 cutting logs almost like butter. Mrs. Moose stacked yesterday’s splitting but decided that was enough. Hope to get back to the Maslow tomorrow, will update the firmware first.

1 Like

Bike chain tools are cheap, used to farm machine roller chain sizes. Time to prime amazon

This one should work and should hold onto the hook better since it’s got a bearing pressed in it.

Thanks for the link @iRoc999! I ordered a couple of them.

1 Like

I heard they cast desire to travel on swamp rats, but I don’t believe none of that mumbo jumbo…

Once you have a moose in the forum it’s easy to believe in swamp rat repellers.

Obnoxious buggers. They’ve already built the missing sprocket into their nest with all the other things that have gone missing.

Some steps forwards, a few back. This is GC 0.81, FW master from 7/27. Downloaded GC from master, but didn’t get the portable version, so left it at 0.81.

First, the missing sprocket reappeared in a place that had been thoroughly inspected last time, both optically and magnetically, plus swept/vacuumed after the search. While it may have fallen off the adjacent lumber stack it’s possible the swamp rats are feeling anxious and returned it. The S hook was carefully closed with pliers, although I plan to find a couple small clevises and mount the ball bearing eBay sprockets when they arrive.

I attempted to update to the latest master firmware but while motor calibration worked nothing else. Reflashed back to 7/27. Looks like a cockpit error, left the Arduino IDE running in between. Exited after the second flash. Things worked lots better.

My dimensions from before were, well, weird. Motors 1235 (+/-) mm, etc. Messed up from the chain wrenching first attempt?

Restarted the machine calibration. This time it worked pretty much as expected, without the try to pull the machine apart chain tightening from last time. Got 2925.6mm, matching my metric tape (within my personal measuring tolerances, at least). It takes 6 minutes and 30 seconds to calibrate the chains, Marked with a (at least) 20 year old junkyard paint marker.

Got to step 8, cut the test marks. Invisible. Guessing that has to do with the missing bungee Z backlash device (although this could be remedied in firmware, keep track of the backlash and twirl that much extra when changing direction). Will bungee next time, just didn’t remember the old forum comments. Since there was no way to say retry without putting in some numbers I faked it. Retried, right sprocket came off. Must not have had the setscrew on the flat and it finally worked loose (just guessing, but plausible). Reinstalled and recalibrated chains (another 6 and a half minutes) just in case there was some slippage last time. Both chains measured 1667mm. Left mark was off, removed and redid. Right, interestingly, right on.

Back to calibration, this time (with some manual backlash adjustment, plus a re-Z zeroing) got usable marks. 604V/602H mm. Entered and clicked recut. It started to position the router, then quit moving. Exited back to the main screen, hit home (it did) but found it was trying to move the Z to 350mm. Hit stop. Got paged for dinner and shut everything down.

I’m using a 1/4" OSB spoil board for calibration, don’t want to mark up a $50+ sheet of 3/4 ACX. It’s probably the backlash issue (didn’t think of that until seeing the post today), but I would be nice to have an option to set the depth. No idea what’s going on with that 350mm Z move, hope it didn’t strip off the plastic button.

A couple suggestions (or maybe I messed them). There doesn’t seem to be a way to enter manual gcode commands. Is there a debug log? I couldn’t find it in the menus.

Will retry next time with the latest firmware. Probably not until Tuesday or so, paramedic shift tomorrow.


One way to enter manual gcode commands is to use the macros :slight_smile:. There is a debug log named log.txt that lives in the same place as and groundcontrol.kv. The swamp rats were teasing you with the lost sprocket :smile:!

1 Like

I saw the macros, but it seems like a big hammer when all you want to do is enter g0 x0 y10 z0 . Plus it burns a macro.

I’ll check for the log file. Almost had it working before it decided to try and extract the router from the base, would like to see where that came from. SWMBO is pretty serious about dinner time or I would have tried restarting everything and trying again.

Maybe threatening the swamp rats worked. Bad enough we’ve got deer and racoons in the garden, mice in the barn, and wolves snd bears in the woods. Darn swamp rats are taking over the shop.


I’m using the portable unzipped version of 0.81 so the files are in a subdirectory under downloads. log.txt has the same date as the other extracted files (7/23) and is empty. Is there a way to enable debug logging explicitly?

I’m searching the whole laptop for any file named log.txt just in case it’s in one of those strange WinDoze places. Nothing for the Maslow, but I did find some Cura files with gcode in them. Nothing found