[SOLVED] M4 - Motors will not retract during calibration

My son and I were able to assemble the entire unit without any trouble whatsoever. We followed the beginning of the configuration steps including updated firmware and other files form GitHub (in order to lower the z and retract).

Z control works just as it should, but when we select “retract all,” the fan spools up for about 2 seconds, the motors begin to twitch, and then everything stops.

All four motors have solid green lights.

The retract all command shows in the history with no error, but nothing really happens.

I am getting position error readings on the history as well, but it looks like that is normal based on the video?


1 Like

I installed the new firmware released just an hour ago, as well as the new index file. No luck in changing behavior, but it does offer more info:

1 Like

I recall the assembly instructions saying not to over tighten the top and bottom cases for the arms. I don’t believe we did this, and before we’d gotten this far, there were a couple occasions where the arms tried to extend out, and seemed to have no trouble running in that direction, so I don’t think the gears are bound up.

1 Like

This looks to me like when it is going to retract the arms it is finding that they are already all the way retraced…basically it thinks that it’s hitting the end stops immediately.

I agree, I don’t think that’s an issue. I was more worried about people stripping the bolts in that step than with preventing the spool from rotating.

The fact that its all four arms makes me think that it’s something thats common to all of them. If one were having an issue that could be an issue with just that arm, but all four seems suspicious.

Are you able to freely move the belt in and out by hand?

What happens if you press “Extend All” after pressing “Retract All”?

I can freely move the belts. And when I press extend all, they do begin to extend. I hit stop to avoid over extending each time we’ve tried that.

After “extending,” the retract function still does not work.

As a curious note, at one point, when cycling through, trying to get it to do something, updating firmware/other files/etc, one arm did retract about 6 inches before stopping. Then back to the usual behavior. So I know it’s mechanically possible. This did only happen once though, in the midst of 30-40 tries.

1 Like

OK, so it sounds like like everything is working, there is just more friction than expected when retracting the belts which is making the machine think that they are already fully retracted.

If you push some belt through so that there is slack on the spool side and then move it back and forth a bit does it move freely?

It does! Completely free, and the yellow light blinks on and off to confirm free rotation of the guide gears inside.

1 Like

Something that someone else pointed out which wasn’t clear in the instructions was the path of the belt, is it routed around the gear like this by any chance? Just guessing things :confused:

Darn :joy:

Let me think on it for a second

We got this one right as well. Thanks for thinking through it! I’ll check in tomorrow morning! Getting late on eastern time!

1 Like

We can up the current threshold at which the motor thinks the belt is fully retracted since we know that it can spin, but I’m worried that’s masking something else that’s going on. If it was just one arm I’d think it was something preventing that arm from rotating freely…but all four is weird :confused:

I’m open to giving anything a try!

How would we make this change?

1 Like

I will make it a setting in the .yaml file and give you an update. I’m a little hesitant because I’m worried that if something is wrong giving it more power might not be the real solution. I don’t want to break anything.

I guess we can always replace anything that breaks so it’s not the end of the world. I’d still love to figure out the root cause so we can fix it.

The two of us are totally open to exploring any and all options!

You aren’t seeing this behavior, right? Clicking the button more times doesn’t eventually retract them?

It feels to me like there is something jammed which adding more power might break

yes. the belts retract a small amount sometimes and other times they will run for 10 or 20m sec before stopping. eventually the belts retract - but it takes a number of tries

1 Like

they all look right.

1 Like

Yeah, that looks right to me. I’m going to make a setting so you can change the threshold for when the machine thinks that the belts are fully retracted. That’s the next thing on my todo list so I should have something ready soon.

Get ready for some more good info

We’ve found that if you manually turn the spool (very hard) it will initiate retracting. This worked for two of the four. The other two were not able to initiate. Too hard to turn.

Upon disassembly of an arm, it did begin to turn on its own, but only after the entire bottom plate was effectively removed, eliminating sufficient tension.

After reinstalling the bottom plate, even without tightening the screws completely, it fails to turn itself. The idler gear seems to turn freely, and is sufficiently lubricated.

Video: IMG_8605.MOV - Google Drive

1 Like