Solving Chain Jumping

I’ve been having trouble with the chain jumping while cutting parts, but I have used a method I saw on the forum and seem to have completely eliminated the problem. I thought I’d post what worked for me, as i suspect it will work for others too. I have moved the nylon tube that was guiding the chain to a point where it is close to the sprocket. This keeps the chain in place when feeding on to the sprocket (I think this is the only direction I ever had a jump from).

Here’s pictures of the left and right motors:

Lubricating the chain also helped a little and the 3D printed chain guides (the black and white bits) helped a bit as it prevents movement of the chain in and out, but the fix that seems to have totally fixed chain jumping is the nylon tubes that I have mounted in one of the motor mount screw holes. I have cut down long M4 screws to just the right length.


Not passing judgement, but, man, there’s a lot of sawdust in those pictures.


I’m cutting chair legs from scaffolding board with a 12.5mm cutter. I have dust collection but there’s still a lot of dust. With the nylon tubes sawdust doesn’t seem to be a problem. The 3D printed guides clean some of it off as well. Perhaps a brush somewhere would be and idea… hmm.

There’s a video of a chair leg being cut here:


What’s that “roller” at the top of the sled for?

Can’t believe someone still uses quadrilateral setup :slight_smile:

The ‘roller’ is a lump of steel used to stop the sled from pulling away from the workpiece due to centre of gravity being too far ‘out’ from the base of the sled.

I’m still using the original quadrilateral setup because it is accurate enough for me, and mainly because I am cutting 16 of these legs and I do it by cutting them all in exactly the same place on the machine using exactly the same firmware and calibration, so they all come out exactly the same size. I adjusted the gcode to make the piece the size I wanted sometime last year…


I also tried moving the guide to different points to see if it would help by keeping more teeth on the gear, but it didnt fix my problem. I also added a small piece of PVC to guide the chain, and keep it close to the arm so it would stay in contact more - didnt fix the problem. I almost bought new chains and new gears for the motors because they kept wrapping and getting bent. Moving the guide also caused an issue when I was cutting to the far left, or far right of the board the chains would rub, it was frustrating.

The solution for me was to eliminate the Z type pattern the chain made over the 3 connection points: start, gear, sled. A wise mechanical engineer told me ““Each leg of chain should be parallel and coplanar””

I extended the top out so the chain started in alignment with where the chain attaches to the gears. I then added a block to the bottom to bring out where the tension cable terminated - later adding a counterweight system (as others have) to ensure the chain stayed perfectly flat in alignment. No more skewed chain, and the chain never had another problem! Has worked wonderfully for months, not a single jump since.

Not the best photos, but notice the side view of the maslow. All 3 sections of chain should be in alignment with one another. You should not see any zig-zagging.

1 Like

This shows it better. Also would remove any grease and clean up your chains.


So I stopped the chains jumping when the chain was feeding on to the sprocket, as I mentioned above. Then, while cutting a chair leg I got this:

So this time the chain didn’t exit the sprocket properly and wrapped itself round. I fixed this by hanging weights on the chain, which was mentioned somewhere, and works.


Try extending your motors away from the frame, so the chains align, when viewed from the side.

If you shoot a laser level from the motor sprocket towards the sled, it should hit the mounting hole your chain attaches to.

The problem here though, was that the chain didn’t leave the sprocket correctly. I’ve added weights to the chain which has sorted the problem.

1 Like