Maslow Home Maslow Community Garden

Tabs generated in MakerCam do not show up in Groundcontrol


#1

Hi there,

i am new to maslow and doing my first cuts here in germany - very exciting :slight_smile:

i have problems with teh tabs that should hold the object in place. like in the tutorial i did the following in makercam:
Insert > circle > 15 cm
select circle
CAM > profile operation
CAM > calculate all
CAM > add tabs to selected > spacing 15cm, width 5 cm, height 0.5 cm
CAM > export gcode
result is:

when i open this file in groundcontrol i see:

when i cut the circle no tabs are there.
is the a common error users can do / forget when inserting tabs?
is there a better way to work with tabs than with makercam?

thanks a lot!


#2

Willkommen im Forum :slight_smile:

I’ve followed your steps and there a 5mm 0.5mm! tabs in the g-code.
The online version of makercam has issues with metric. One issue is the up to 16 digits behind the decimal.
Checking the g-code with camotics, the tabs show, but allot of errors are shown as well.

You can make them higher, or try to turn truncation on in GC, to see if that helps.

Edit: In your screenshot the tabs are showing as green (bit goes up) and red (bit goes down) circles.
That they are not cut can have to do with:

  • the material thickness is not set correct
  • Z was not zeroed correct on the top of the material
  • the pitch setting in GC does not match the actual pitch of you router
  • a backlash on the pitch-screw

Edit2: I usually set the material up to 2mm more then it actually is, to ensure that I cut all the way through.
Then I add those 2 mm to the tabs. Try to see if the tabs show up if you make them higher.


#3

I have good news. You have done everything correctly and the tabs are there :grinning:

When you cut that file it will cut with tabs.

The tabs look a little different in Ground Control because Ground Control is showing just the gcode file which is made up of machine movements. It doesn’t know that it is making a “tab” just that it needs to move in a certain pattern. When the z-axis moves up it is shown with a small green circle and when it moves down it is shown with a larger red circle. You can see the beginning and ends of your tabs shown like so:

Great work!


#4

thanks gero and bar for your help!

i did a test cut of the circle but the tabs were not cut. will try again with your hints on pitch settings and backlash.

thanks again!


#5

This could be a clue also:

If I compare the post to the screenshot, this could be reason you end up with a 0.5mm tab that will hardly be cut, instead of a 5mm heigh tab.


How To: Tabs in Makercam
How To: Tabs in Makercam
#6

gero - you are my hero!

yes: using makercam.com and generating tabs with measures set to centimeters, the tab height has to be multiplied by 10, due to an error in makercam.

this feels like a bis step towards cutting my first real piece - not just test. so fine calibration is next.

thanks again gero!

ps: @bar this info about the tabs could be very useful for all maslow starters using metric makercam.com - perhaps it should be in the wiki.

(sorry for the confusing test cuts around the circle with tabs)


#7

Done here How To: Tabs in Makercam within minutes by amazing fast @madgrizzle


#8

FYI, as a wiki page, anyone can edit the main post (or any post tagged with wiki status). I was more than happy to add it though.


#9

Great work everyone! And thank you for the success picture @berty, it always feels good to see the proof :grinning: