How To: Tabs in Makercam

One of the most common problems that people run into when first entering into the CNC world is related to the creation of tabs. Since the Maslow is vertical, once you fully cut out a piece from your material, gravity takes over and it will fall or worse, get hung up in your sled.

So, it’s common to add “tabs” to your project to prevent the piece from falling. These tabs are just small segments of uncut areas that hold the piece in place. After all cutting is done, you manually cut these tabs away and extract your piece from the plywood. A nice sharp chissel works perfectly for this. They look like this.

Now that you know what a tab is, how do you make them in Makercam? Tabs are added after you calculate your toolpaths. Select the toolpath you want to add tabs to (they will be the green lines in Makercam) and then select “add tabs to selected” from the CAM menu item.

There are three values to enter. First is the tab spacing. Makercam will add tabs along the toolpath based upon this setting. If, for example, your toolpath cuts out a 6-inch x 6-inch square using 0.25-inch router bit, the total length of the toolpath will be ~24.784 inches:

Entering a value of 5 inches would result in 4 tabs been created (24.784 inches / 5 inches = 4.95 and rounding down results in 4). If you entered 4.9 inches, you would get 5 tabs (24.784 inches / 4.9 inches = 5.06 and rounding down results in 5).

The second value is the tab width. When you enter the width of the tab, add an amount equal to the diameter of your router bit to get it to come out right.


The final value is the tab height. When you enter the height of the tab, realize that its based off the bottom of the cut, not the thickness of your workpiece.


A nice feature of makercam is that you can click on a tab and drag it along the toolpath. This allows you to place tabs where its easiest to sand them off after you are done. I try to minimize the number of tabs, place them strategically to hold the piece in place, and try to place them on a straight segment where I can get my sander on to grind them away.

Important Note:
Per @geo, if you are using metric, there is a bug causing you to end up with a tab the 10th of the height you would expect it to be:


Could this get moved to the wiki?


Has anyone had to troubleshoot this process?
When I click “ok” nothing changes. I’ve tried various values in the 3 settings for tabs, and I’ve ried “Calculate selected” and Calculate All" afterwards.

My overall process is:
File > Open SVG File > [select file]
I check the outline - it looks good, the dimensions look correct when I count the squares both when it it set to Inches, and when it is set to cm.

CAM > Profile Operation > [Fill in ToolPath details]
CAM > Calculate All > [it thinks, then outlines the piece with pink highlight the width of the bit]

I select the piece and the outline of the piece turns red; the pink toolpath remains around it.

CAM > add tabs to selected > [ for example, on a 68" profile cut with 1/4" bit and 3 passes to cut through 1/2" plywood, I put tab every 5", 0.75" wide, and 0.25" deep.]
I click “OK”…
No change.
CAM > Calculate All > [it doesn’t seem to do anything]

Seems very simple, but I can’t get it to work like I’ve seen on some youtube videos.

Any Ideas?

Try this. Start a new session and use Makercam’s own insert to place a circle. Then make a profile on that circle and calculate to make a toolpath. Then try to add tabs to that one toolpath.


did you find a solution for the non-appearing-tabs @ManOfScience?

i am stuck with the same problem here. so tabs sho in makercam but are not shown in groundcontrol / are not cut out.


Share your file and someone might be able to help you.

1 Like

thanks jatt! it seems not to be a file problem.
possible solutions were provided here:

If you are using metric, there is a bug causing you to end up with a tab the 10th of the height you would expect it to be:

I use inches and try everything. They (the tabs themselves) seem to choose if they wish to appear or not. I hope this “solid” scientific observation doesn’t sway anyone, but rather beckons to anyone who can collaborate (or better yet clear this up with a solution)! :rofl: