Test request (weight and angle)

Since we gained chain sag calibration, we have not had anyone go back and test lighter sleds and steeper machine angles.

I have strong suspicion that with the chain sag being accounted for, we can run with less weight and a steeper angle and still get good accuracy.

I remember there is one person (I don’t remember who) who has stacks of steel blocks as their weights, could you go back to lighter weights and run the calibration/test steps multiple times with different weights to see what happens?

Also, if someone could test different tilt angles of the machine, the default is about 15 degrees and earlier testing showed that going below 5 degrees caused problems.

If needed, I will send money to cover the plywood sheets that are sacrificed to these tests to whoever can post results.

1 Like

David, sorry this got ignored. Had a busy weekend away from the Maslow. I’m hoping to get back to my machine this next weekend.

Are you referring to these?

IMG_20171109_194316

I’ve been meaning to experiment with different weights now that we have chain sag calculations. Each one of the steel weights are ~550g, or ~20 oz. I can systematically reduce the weight, run the calibration routine, and then benchmark the resulting configuration so we have comparable results. If I remove 4 weights at a time, I can test in 5 lb increments. I think that should give us sufficient data.

While I have been thinking of a mechanism to allow it, I currently don’t have any adjustment in my machine’s angle. I would like to be able to test that too, but I have so many other machine improvements and projects I need to get to it would take me quite some time to get to a place where I can test that.

2 Likes

I can tilt any angle, but the next 2 days no weight that is adjustable like that. It’s flat steel cut to size right? Guess I can replicate that fast. For weight differences I have enough fishing lead.
Time is my issue, but throw a weight and angle at me.
Currently more important, on what FW/GC do we sync tests?
1.03?

1 Like

Yes, I used 1 1/2" (38.1mm) x 1/2" (12.7mm) steel flatbar cut to 6" (152.4mm) lengths. I picked that size because it’s what I have on hand.

I know the feeling… >.>

All the previous accuracy tests I’ve run have been using v1.03. I’m not planning on updating as of yet, I’ve seen a lot of troubleshooting with newer versions that I don’t want to get into right now. Maybe I’m just out of the loop, but would the newer versions significantly alter the results? I know we want to be all scienticious, I’m simply not sure what differences new versions would cause.

2 Likes

Good to know. I found my last task for tonight :+1:
Rename .ini, wipe eeprom, ect.

2 Likes

9 x 550 = 4950 x 2 = 9900 ? :scream:
Do you have ~10kg is that ~22 lbs? on your sled?
Did you run the accuracy test with that and what is the weight of your sled without steel bars?

Yes, it is a very heavy sled. I have only ever done the math to derive my sled weight, as I don’t have an accurate enough scale that goes up to 40+ lbs. If I went any heavier, I’d be worried that I would start stalling my motors.

According to my math, this is how much my trial sled weighs:
image

1 Like

Tried to get a start for Friday/Saturday, but can’t calibrate right with 1.03.
Sled is far to low on the sheet. Gave up after 2 times yesterday.
All measures look close to real life, only rotation radius was hundred. I changed that to 6"/152.4mm and the sled went further down. I can trick the software by reducing the hight of the sheet around 20cm, but it does not feel like a system to do comparable tests. Friday will be investigation day.

1 Like

Damn, sorry to hear you’re having trouble with v1.03. Are you using the larger (new) top-mount kit? I just received it and the “horizontal” arms are longer compared to the older version. The new kit, as a result, should have a larger rotation radius. I haven’t tested it yet to get an idea of what the rotation radius should be, but but the size of the linkages would lead me to believe that it would be more similar the 270mm for the 45 degree kit. The difference could be what’s causing the misalignment, I had that issue when I switched from top-mount to 45 and forgot to switch the groundcontrol.ini file as well.

The horizontal arms on my kit are 7". I see my rotation radius at 6, bit to mount 1 is 3" and mount 1 to 2 is 6". If I flip the kit up the chain hole would meet at 6". @dlang , can you help me out?
Increasing the radius would make my sled go further down then it already is.

@gero rotation radius should be 6.375 for the version you have (without the half-links), the arms are 7" long with the holes 6" apart. This then gets the 1/2 link that sits past the 12 o’clock position when you hook the chain on the bracket (1/8 or .125") and the master link that connects the chain to the bracket (1/4" or .25"), if you had the half-links, that would add another 1/4"

but this should all be discovered by the calibration routine.

1 Like

I have 1 connection link from chain to hole. That is on the chain during calibration.

so what is the rotation radius discovered during calibration?

It was 100 and that looks like a preset.
Edit: The 6.375 was for a thank you, I will do
Edit 2: Higher rotation’r puts sled the further down.

1 Like

That is, indeed, the default value. I know I’ve seen people have an issue where too small of a rotation radius will cause the sled to move down instead of the desired direction. Not sure if that might be part of the issue here?

Your edit helped clarify. :wink: I’d enter 161.925mm as your starting value, and see if calibration can fix it from there.

The more worrying thing to me is that the 161 isn’t that far off from your 152. :confused:

Would going to a more recent version muck up our results? Has the calibration procedure changed much from v1.03?

1 Like

Catching up on this thread, but in short, for what is being done here it has not.

2 Likes

I looked better on 1.07 light weight vs. 1.03 heavy weight. I increased sled weight again, to 16.4 kg and heavy has not be a issue till now.

1 Like

What is the calculated motor Y offset? And what did you get for the third measurement in the calibration process, the one from the top of the work area to the top of cut 5?

1 Like

I guess that’s in the logs, I failed to document. If you give me a moment, I will grab the .ini and .log from the workshop.

3 Likes

The Y offset was unacceptable as the sled started far to low for calibration cuts.
iniAlog.zip (61.6 KB)
The log is to long as I did some demonstration of moves :frowning:
At one point we should start timestamping them with every new file loaded, or by date.
Edit: I mean timestamping and cutting
Edit 2: The motoroffsety in the 1.03 .ini is tweaked by me. The rl-value is around 458.

2 Likes