Tool change, is this the way?

Trying to get manual tool change to work.
Are there any suggestion ?
This worked for me but does not seems to be the easy way.
I’m generating code with Kiri:moto and it inserts toolchange commands.

Maslow stops, but no prompt.
I can change tool and set new Z zero.
Trying to get going again ‘play’ does not work. (telling me to use ‘stop’ then…)

BUT after using the ‘stop’ button and entering the next line number( adding one to the halting line no) and use ‘goto’ button I get the prompt to proceed.
Doing so it continue in the code. ( PS this was a dry run only.)

Are there easier ways? (I’m a noob.)

Which firmware and control software are we talking about?

I’m using the controller from EastBaySource and Raspberry PI & WebControl Version v0.94,

Then this sounds like the right operation. It should start again when you press play, I don’t think you are doing anything wrong.

Another option is to split the program into multiple files with one for each tool. It’s a bit of a hassle, but my guess is that’s the fastest way to get going.

OK this works for me. Short version. Webcontrol on Raspberry PI.

  1. Maslow stops at Line no. n. Waiting for toolchange.
  2. Stopping the spindel, I change tool, set new Z-zero if needed.
  3. Push ‘STOP’
  4. Enter linenumber ‘n+1’ in the Line # field, tap ‘Goto’.
  5. I get the ‘Resume’ prompt and hit it. And we get going again.
1 Like