Maslow Home Maslow Community Garden Newsletter

Tool change operations

I made a gcode file with the makercam, It was to cut the profile and then some pocket operation. I ran the profile and then it paused. I change the tool and then I was unable to re-zero the z-axis. So I hit the pause button to unpause and then is started performing all of the z-axis commands that I tried while trying to zero the z-axis. So I hit stop. Then I zero’d the z-axis and told it to go to like 798 (where the pocket operations start) it did 2 pocket cuts and then went back to cutting the profile with the larger tool and messed up my project. What am I doing wrong?

Groundcontrol our WebControl?

Groundcontrol

Is there any chance that the outside path was also selected when generating the gcode in makercam? Do you have the gcode file? We can take a look at it and see if we can figure out what is going on there.

Here is the file. Line 798 starts the features. It is like it started over from the beginning all by itself. snowman.nc (26.6 KB)

Feel free to make yourself a snowman or two.

It looks to me like that gcode file has two extra passes at full depth after the cut finishes. I’m not sure why that would be, but you can see them when you run the file through a simulator like

This seems like maybe a Maker CAM issue, or maybe an issue with a path being doubled up or something in the .svg file? It’s only the outside edge which cuts twice, so I’m not sure exactly what that means.

I see three ‘profile’ operations in that portion of the code. Did it only do two of them and ‘restart’ or did it do all three of them?

It only did 2 of them.

Hmm… which two?

The eyes and nose

ok… each eye is its own operations… so there were a total of three done.

I can’t say exactly what happened, but it seems that the program finished and then started all over again.

When it finished the eyes and nose, did you get a tool change request?

I don’t remember if I did or not. But I see now that the mouth is missing. Which is odd because in the makercam I selected those additional 5 operations. What I ended up doing on the next run was break the profile and the pocket operations in to 2 different files which worked perfectly until I got a USB error and that was the end of that.

Perhaps it is possible that I hit the start button thinking that I needed to do that to start the mouth cut which is totally missing. I think I need to start using this simulator before cutting anything. I certainly would have noticed this.

Thanks
Erik

That’s a plausible explanation. I’ve never seen it just start on its own. I suspect you received a tool change notification as well or at least hope you did because that’s what is supposed to happen.

1 Like

Functions of ATC It provides the storage of the tools which are returned automatically to the machine tool after carrying out the required operations , increases the flexibility of the machine tool , makes it easier to change heavy and large tools , and permits the automatic renewal of cutting edges.