Triangular Kinematics - Distance between sled mounting points

I’ve tried, I just can’t find it. What should the distance between sled mounting points be? In the calibration process, it says to skip that part. Did I miss something? If there’s a 0 there, I get errors regarding unable to find valid motor positions and the sled is located really low after it feeds out the chain (should be centered I thought).

1 Like

Sorry I realized my answer was not about Triangular Kinematics - I have not gotten my linkage yet.

Hi madgrizzle. I had this problem yesterday. The machine thought the center of the work area was about 8 inches low due to using the measurement from the quadrilateral sleds. If i remember right it was 209 mm in GC. I took a measure of my sled with linkage installed at the center of the workarea, and the chain ends were about 400mm apart. I entered that in and then moved the sled to the center, and it was close.

I still havent been able to complete the linkage calibration process, i keep test cutting and measuring but so far it wont let me pass. I should say that without manipulating that measurement, i wouldnt have even been able to run the test cuts as the sled ran off the bottom of my frame. Is there any way to tell GC that im using a linkage system besides going through the auto calibration?


In the calibration process, it tells you to skip the measurement of the number of links between sled mounting points. So that value ends up being a zero. After calibrating chain length step, I get the sled low on the board and an error message saying “Unable to find valid machine position for chain lengths…” So it seems I need to put some number of links in… but I can’t readily translate a mm measurement to chain links… Am I doing this wrong?

May I ask you all to post the version of GC you are running please?

Thank you

0.96 (is the version I’m running…)

Thank you -

I am running in Windows, I have an _ old release directory - I move the files too.

I would suggest the latest -


First update the Firmware

I do not know this address this - new updates are for good reason normally.

I looked at the changelog for 0.97 and there was nothing that would solve the problem.

I redid the autocal again (fourth or fifth time today) and put 70 links in for the distance between sled mounting points. That gave me about 440 mm spacing. Continued through the process and, again, after the chain length feed was done, I got the same error message and the sled was low on the board. Taking a break for the night. Are there values in settings that I need to manually change because I’m using a linkage and real sled before I do the autocal???

Well crapple… Looks like if you click settings at the top of settings you can bring up advance settings where you set the machine to triangular kinematics… sigh…

I assume if I set this and go through the calibration again (and put 0 in for the number of links) it will work… we’ll find out later…


Still no luck. With kinematics set to triangular, 0 for distance between sled mounting points I don’t get an error and the sled centers in the middle of the board. But as soon as I run the last step to fine tune the calibration, the sled drops to the bottom left of the board (my temp sled calibration never cut anything in bottom left) and proceeded to roll along the floor.

Can someone post what their settings look like on their linkage setup? I must be doing something wrong for the sled to drop to the lower left instead of move to the upper left.


Is it possible there is an issue with the last automatic calibration step? I ran a file from and got two vertical lines close to where they were supposed to be (1789 mm from inside to inside of cut vs 1780 mm). And the sled didn’t roll around on the floor.

@madgrizzle: So part of your problem here is that the “Distance Between Sled Mounting Points” is meant to be for calibrating Quadrilateral kinematics. In switching it to Triangular, that particular measurement should be obsolete. I myself have noticed that changing that value does have an effect on the calibration of the machine, but I haven’t tested it thoroughly enough to actually know if that is strictly because of it or not. I have been doing A LOT of calibration work on my machine so some of the tests are blurring together. If that is the case, it’s a bug in Ground Control.

I think right now I have somewhere is the realm of 200 set for my distance between mounting points. Having a zero in that field may cause Ground Control to have some trouble with it, so regardless it may be a good idea to put a positive value there.

I had some trouble getting the last calibration step to work. Ultimately, I used the old calibration method I used when I first got my Maslow set up and got pretty reliable results. In Maslow settings and advanced settings, there are a couple of values that can be tweaked to dial in the machine. Triangular kinematics should use two values, the rotation radius and the distance between motors. I then cut 100mm x 100mm squares into the face of a test piece until the machine was within tolerance, ±0.5mm.

Maslow Settings:

Advanced Settings:

Disclaimer: These values are from my dummy Ground Control and are not the actual values that I use on my machine!

The rotation radius depends on which linkage kit you have. DLang’s top mount or Logan’s 45 degree kit threads should have some mention as to what a good starting point is for this number. After that, you probably could use the automatic calibration process to help dial in the machine.

Good luck! :smiley: Let us know how it goes and if there is something you need clarified.


Thanks for the response. My first problem was that I didn’t find the second page of settings where I could set the kinematics type to triangular. I assumed that was done in the calibration process where it asked the type of kinematic. Once I set it to triangular in setting, I could set the “distance between sled mounting points” to 0 and set the “rotation radius for triangular kinematics” to whatever was recommended (can’t remember the value atm… 270-ish). When I got to the last step of calibration, the sled dropped to the floor and started to roll, but the center position was pretty close to center. So I tried to make some cuts using the 1780mm test pattern and it came out pretty well.

When I cut the 6"x6" test rectangle in the top left corner of the board, it came out a bit parallelogram-ish. It was out of square by 1/8-inch over the 6-inch length… which isn’t terrific. I wonder if it’s frame bending or something… I was able to cut the pieces for the final frame and they look decent enough. I’ll be adding extra stiffeners when I build the final frame and hopefully I’ll get better accuracy.

I still think their may be a bug in GC for triangular kinematics last step of calibration.

For the 45˚ kit it should be around 270mm.


Makes sense that one’s choice there should persist in the settings :smile:. Would you open an issue in GroundControl to capture this? Sounds like something that should get attention quickly.

Well, I never successfully completed the autocal process where I selected triangular kinematics so maybe that’s why the setting never ‘persisted’ (i.e., doesn’t save the setting unless you finish the process). When I went to settings->advanced settings and set it to triangular there, it has persisted, even through multiple failed autocal attempts.

1 Like

I’m going to try a fresh install of Ground Control and see if I can get the same issue to show up with my linkage kit. This sounds like a bug to me. When you change the kinematics type during the calibration process it will have the same effect as changing it in settings, and entering the number of links should have no effect at all (clearly it does matter, I will find out why and fix it)


I think my sled rolling on the floor issue is the same issue as discussed here… I still got the sled dropping to the floor even after manually changing it to triangular kinematics in advanced settings (and with the distance between sled mounting points set to 0). My frame is still resting on the floor (just cut the pieces for the final frame last night) so mine probably dropped the same as Andrew’s.